Search found 815 matches

by Micha
Fri Jan 13, 2012 12:20 pm
Forum: Oolite-Linux
Topic: Help with installing 1.76 on Ubuntu
Replies: 41
Views: 18964

Re: Help with installing 1.76 on Ubuntu

- definitely no Oolite icon in the Games menu (or anywhere else) Ok, finally managed to dust off my Lucid VM and test it, and I cannot repro this bug; game icon appears as it should (under "Games") after installation, and disappears, as it should, upon deinstallation. You -are- running the standard...
by Micha
Fri Jan 13, 2012 12:17 pm
Forum: Discussion
Topic: Laser overheating, yawn ;)
Replies: 18
Views: 2638

Re: Laser overheating, yawn ;)

It could be improved (pseudo-code-ish as I haven't had time to look at the code, but weapon_temp_per_shot must be retrievable from somewhere):

Code: Select all

if ( (weapon_temp + weapon_temp_per_shot) / PLAYER_MAX_WEAPON_TEMP >= 1.00 )
{
   /* Disable weapon */
}
by Micha
Fri Jan 13, 2012 10:24 am
Forum: Outworld
Topic: Happy Friday the 13th
Replies: 29
Views: 4777

Re: Happy Friday the 13th

Wow.. I hadn't even noticed it's that kind of day again. As a query of interest, I'm aware that '13' is considered unlucky for some obscure reason (yes, I could look on the internet), but why is Friday unlucky? I mean.. end of working week, surely that's a good thing? If anything, -Monday- the 13th ...
by Micha
Fri Jan 13, 2012 10:21 am
Forum: Discussion
Topic: Laser overheating, yawn ;)
Replies: 18
Views: 2638

Re: Laser overheating, yawn ;)

Hmm, ninja'd. And where is my post? This is the second time a post of mine has gone missing because others posted in the meantime.
by Micha
Thu Jan 12, 2012 2:40 pm
Forum: Oolite-Linux
Topic: Help with installing 1.76 on Ubuntu
Replies: 41
Views: 18964

Re: Help with installing 1.76 on Ubuntu

I've made install packages for 32- and 64-bit Debian lenny and squeeze, and Ubuntu lucid and maverick, although they are not linked on the pages yet. To test, go to http://debs.oolite.org/AptSources.html, and replace the 'test' with 'release' in the deb sources for your distro. Feedback welcome. PS....
by Micha
Thu Jan 12, 2012 11:26 am
Forum: Discussion
Topic: Oops. I sold the cargo I was meant to deliver.
Replies: 22
Views: 4705

Re: Oops. I sold the cargo I was meant to deliver.

then you might as well request that ship.dock() / ship.launch() have a parameter to suppress the docking rings as well.. (although that might take a bit of fiddling)
by Micha
Thu Jan 12, 2012 11:24 am
Forum: Expansion Pack
Topic: [WIP]Miner Pod OXP (v0.1 Released)
Replies: 51
Views: 10640

Re: [WIP]Miner Pod OXP (v0.1 Released)

10. As Gimi said, please always change the version number when you upload it. The experience mentioned above of you getting different behaviour from someone else combined with not changing version numbers is a classic problem in software change control. Uploading code that has been commented out is...
by Micha
Thu Jan 12, 2012 11:17 am
Forum: Expansion Pack
Topic: Sugestion for a new Docking AI
Replies: 27
Views: 3040

Re: Sugestion for a new Docking AI

The docking computer in the Commodore 64 Elite was bloody incredible. Even if only 90% successful... There was a decent chance of a 'press space' moment. So I always watched it like a hawk - and ready to press disengage and abort the attempt. In my personal vision of future Oolite docking there are...
by Micha
Thu Jan 12, 2012 11:01 am
Forum: Suggestion Box
Topic: NPCs following the player's wormhole
Replies: 5
Views: 1331

Re: NPCs following the player's wormhole

IMHO Police ships should never follow the player - they'd be leaving their jurisdiction. Pirates.. unsure. Perhaps only if they have a hyperspace motor to get back to their base. Otherwise they'd risk being stranded on somebody elses' (dangerous) turf. Bounty-hunters, definitely. Traders, possibly.
by Micha
Tue Jan 10, 2012 7:31 pm
Forum: Suggestion Box
Topic: station scripts / DOCKING_REQUESTED
Replies: 9
Views: 3423

Re: station scripts / DOCKING_REQUESTED

So maybe we need a new mechanism that can block certain ships on request. Or just a station property that refuses all ships unless they are in the same group as the station. (Or have the station as leader.) So how would you like that to work in-game? Blast-doors (or shields) in front of the docking...
by Micha
Tue Jan 10, 2012 7:28 pm
Forum: Discussion
Topic: Oops. I sold the cargo I was meant to deliver.
Replies: 22
Views: 4705

Re: Oops. I sold the cargo I was meant to deliver.

All this means we really need a way to 'tag' cargo... :twisted:
After all it's specific items ("Laveian Tree Grubs", for instance) that want transporting, not generic 'Food', so no sneaky selling the goods and replacing them with inferior local substitutes!
by Micha
Tue Jan 10, 2012 12:50 pm
Forum: Suggestion Box
Topic: station scripts / DOCKING_REQUESTED
Replies: 9
Views: 3423

Re: station scripts / DOCKING_REQUESTED

Also if there's more than one it doesn't tell you anything about their order in the docking queue unless you keep an internal list. In the current implementation there is no such thing as a docking queue. It's more a docking scrum apart from the 2-3 ships which are currently actively approaching th...
by Micha
Mon Jan 09, 2012 1:53 pm
Forum: Oolite-Linux
Topic: Help with installing 1.76 on Ubuntu
Replies: 41
Views: 18964

Re: Help with installing 1.76 on Ubuntu

Then I opened a terminal window and typed sudo oolite-1.76.linux-x86.run and it replied sudo: oolite-1.76.linux-x86.run: command not found So I am perplexed as to what to do next. Any suggestions? Or, alternatively, for a system-wide install: chmod +x ./oolite-1.76.linux-x86.run sudo ./oolite-1.76....
by Micha
Sun Jan 08, 2012 12:46 pm
Forum: Expansion Pack
Topic: [RELEASE] Zeke Mining Transporter 1.0
Replies: 41
Views: 11580

Re: [RELEASE] Zeke Mining Transporter 0.3.1

Also, I've tweaked and uploaded a new version of Shady Sungs which has standard ship prices, so as of V1.2 it's not a conflicting OXP anymore.

EDIT: And the requires.plist's max_version should be 1.76.99.
by Micha
Sun Jan 08, 2012 12:40 pm
Forum: Oolite-Linux
Topic: 1.76 on Ubuntu - package updates needed
Replies: 3
Views: 2714

Re: 1.76 on Ubuntu - package updates needed

Uh, that'd me being lazy and thinking nobody was using the old repository anymore. Can't do much about the official repositories as I'm not a Debian/Ubuntu maintainer, but I'll see about updating the Oolite repository as it seems there's still interest. A problem there is that for the older distro's...