Page 1 of 2

invisible ships and stations or odd colours

Posted: Fri Oct 12, 2012 9:06 pm
by phonebook
not sure if this is the right place for this, but, on my MBP 10.8.2, some very very odd things are happening to the graphics- occasional invisible ships, stations or suddenly in bright white or yellow

seems to affect griff ships the most and groove stations

Re: invisible ships and stations or odd colours

Posted: Sat Oct 13, 2012 6:53 am
by phonebook
after testing lots of permutations, it appears that Groove Stations is the main culprit

have removed and all is back to normal - if indeed there is normality in the ooniverse

Re: invisible ships and stations or odd colours

Posted: Sat Oct 13, 2012 8:06 am
by Shipbuilder
Glad to here that you managed to sorted it out and welcome to the board. :wink:

Re: invisible ships and stations or odd colours

Posted: Sat Oct 13, 2012 2:24 pm
by Commander McLane
Shipbuilder wrote:Glad to here that you managed to sorted it out
Hm. Removing an OXP that should work normally is not really "sorting out" anything.

@ phonebook: can you tell us more about your system? OS, GPU, etc. Alternatively post your latest.log
Shipbuilder wrote:and welcome to the board. :wink:
That's a funny thing to say to a member who joined the board two years and nine months prior to yourself. :lol: :wink:

Re: invisible ships and stations or odd colours

Posted: Sun Oct 14, 2012 2:50 pm
by phonebook
Commander McLane wrote:
Shipbuilder wrote:Glad to here that you managed to sorted it out
Hm. Removing an OXP that should work normally is not really "sorting out" anything.

@ phonebook: can you tell us more about your system? OS, GPU, etc. Alternatively post your latest.log
Shipbuilder wrote:and welcome to the board. :wink:
That's a funny thing to say to a member who joined the board two years and nine months prior to yourself. :lol: :wink:
fisrtly, yes i've been a member a long time but I took a long break from here, so I am glad of the welcome back

well the problem is back- os is 10.8.2, its a new retina display mbp- yes lucky me- thunderbolted into a thunderbolt display- still the same symptoms if its full screen or window- those symptoms are:

space stations are sometimes bright white, or bright yellow or invisible apart from the docking slit

ships very occasionally ditto

and odd chunks of flickering light orbitting the planet (or appear to be from distance- they are like rainbows in that i cant get near them

here's the log:

15:47:59.937 [log.header]: Opening log for Oolite version 1.76.1 (x86-64 test release) under Mac OS X Version 10.8.2 (Build 12C60) at 2012-10-14 14:47:59 +0000.
Machine type: MacBookPro10,1, 8192 MiB memory, 8 x x86 (family 1f65e835) @ 2600 MHz.
Build options: spoken messages, mass/fuel pricing, JavaScript console support, Debug plug-in support, OXP verifier, localization tools, debug GraphViz support, JavaScript profiling.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

15:48:00.008 [dataCache.rebuild.explicitFlush]: Cache explicitly flushed with shift key. Rebuilding from scratch.
15:48:00.008 [rendering.opengl.version]: OpenGL renderer version: 2.1.0 ("2.1 NVIDIA-8.0.61"). Vendor: "NVIDIA Corporation". Renderer: "NVIDIA GeForce GT 650M OpenGL Engine".
15:48:00.009 [rendering.opengl.extensions]: OpenGL extensions (135):
GL_EXT_texture_compression_dxt1, GL_EXT_rescale_normal, GL_EXT_transform_feedback, GL_EXT_blend_func_separate, GL_EXT_framebuffer_sRGB, GL_ATI_texture_env_combine3, GL_ARB_draw_elements_base_vertex, GL_EXT_geometry_shader4, GL_EXT_secondary_color, GL_NV_texgen_reflection, GL_EXT_shadow_funcs, GL_NV_blend_square, GL_ARB_texture_compression_rgtc, GL_EXT_stencil_wrap, GL_ARB_texture_env_crossbar, GL_EXT_framebuffer_blit, GL_EXT_bindable_uniform, GL_ATI_separate_stencil, GL_APPLE_vertex_point_size, GL_EXT_texture_rectangle, GL_APPLE_specular_vector, GL_EXT_packed_depth_stencil, GL_EXT_blend_color, GL_ARB_fragment_program_shadow, GL_EXT_texture_env_add, GL_ARB_imaging, GL_EXT_provoking_vertex, GL_EXT_texture_array, GL_ARB_texture_env_combine, GL_EXT_compiled_vertex_array, GL_ARB_point_sprite, GL_ARB_multisample, GL_EXT_framebuffer_object, GL_ARB_framebuffer_sRGB, GL_EXT_texture_lod_bias, GL_APPLE_pixel_buffer, GL_ARB_vertex_program, GL_EXT_bgra, GL_APPLE_fence, GL_APPLE_ycbcr_422, GL_EXT_timer_query, GL_EXT_vertex_array_bgra, GL_ARB_depth_clamp, GL_IBM_rasterpos_clip, GL_ARB_pixel_buffer_object, GL_SGIS_generate_mipmap, GL_EXT_framebuffer_multisample_blit_scaled, GL_NV_vertex_program2_option, GL_ARB_shader_texture_lod, GL_ARB_texture_float, GL_ARB_texture_rectangle, GL_ARB_vertex_shader, GL_ARB_provoking_vertex, GL_ARB_texture_env_add, GL_APPLE_object_purgeable, GL_ARB_texture_env_dot3, GL_APPLE_rgb_422, GL_NV_depth_clamp, GL_ARB_texture_mirrored_repeat, GL_ARB_texture_cube_map, GL_APPLE_element_array, GL_ATI_texture_float, GL_ARB_window_pos, GL_ARB_sync, GL_ARB_vertex_buffer_object, GL_APPLE_texture_range, GL_NV_fragment_program2, GL_NV_conditional_render, GL_EXT_stencil_two_side, GL_ARB_texture_compression, GL_ARB_instanced_arrays, GL_EXT_blend_minmax, GL_ARB_texture_border_clamp, GL_EXT_draw_buffers2, GL_ARB_shading_language_100, GL_EXT_blend_equation_separate, GL_ARB_vertex_blend, GL_EXT_blend_subtract, GL_EXT_packed_float, GL_APPLE_aux_depth_stencil, GL_APPLE_row_bytes, GL_NV_light_max_exponent, GL_EXT_abgr, GL_EXT_texture_filter_anisotropic, GL_ARB_vertex_array_bgra, GL_ARB_draw_buffers, GL_ARB_transpose_matrix, GL_ARB_color_buffer_float, GL_EXT_gpu_program_parameters, GL_APPLE_client_storage, GL_ARB_texture_non_power_of_two, GL_ARB_multitexture, GL_EXT_gpu_shader4, GL_APPLE_flush_render, GL_NV_vertex_program3, GL_ARB_framebuffer_object, GL_APPLE_vertex_program_evaluators, GL_APPLE_transform_hint, GL_EXT_texture_compression_s3tc, GL_APPLE_flush_buffer_range, GL_EXT_texture_integer, GL_SGIS_texture_edge_clamp, GL_EXT_texture_mirror_clamp, GL_ARB_occlusion_query, GL_ARB_fragment_shader, GL_ARB_texture_rg, GL_NV_fog_distance, GL_ARB_fragment_program, GL_ARB_seamless_cube_map, GL_ARB_shader_objects, GL_EXT_draw_range_elements, GL_APPLE_vertex_array_object, GL_ARB_depth_texture, GL_NV_fragment_program_option, GL_EXT_texture_sRGB, GL_ARB_half_float_vertex, GL_APPLE_vertex_array_range, GL_ARB_shadow, GL_EXT_multi_draw_arrays, GL_ARB_half_float_pixel, GL_APPLE_packed_pixels, GL_ARB_point_parameters, GL_EXT_texture_sRGB_decode, GL_EXT_clip_volume_hint, GL_EXT_depth_bounds_test, GL_SGIS_texture_lod, GL_EXT_fog_coord, GL_EXT_texture_shared_exponent, GL_ATI_texture_mirror_once, GL_NV_multisample_filter_hint, GL_APPLE_float_pixels, GL_EXT_framebuffer_multisample, GL_NV_point_sprite, GL_ARB_depth_buffer_float, GL_ARB_draw_instanced
15:48:00.012 [rendering.opengl.shader.support]: Shaders are supported.
15:48:00.072 [speech.synthesis]: Spoken messages are off.
15:48:00.089 [dataCache.rebuild.explicitFlush]: Cache explicitly flushed with shift key. Rebuilding from scratch.
15:48:00.090 [searchPaths.dumpAll]: Unrestricted mode - resource paths:
/Applications/Oolite 1.76.1/Oolite.app/Contents/Resources
/Applications/Oolite 1.76.1/AddOns
/Applications/Oolite 1.76.1/AddOns/Commies.oxp
/Applications/Oolite 1.76.1/AddOns/griff_dodo_normalmapped_fullsize_tex_v2.01.oxp
/Applications/Oolite 1.76.1/AddOns/Griff_Shipset_Replace_v1.34.oxp
/Applications/Oolite 1.76.1/AddOns/Griff_Shipset_Resources_v1.2.25.oxp
/Applications/Oolite 1.76.1/AddOns/Rock_Hermit_Locator1.3.3.oxp
/Applications/Oolite 1.76.1/AddOns/Staer9's Shipset (shaded) v1.0.oxp
/Applications/Oolite 1.76.1/AddOns/System_Redux.oxp
15:48:00.175 [shipData.load.begin]: Loading ship data.
15:48:00.617 [script.load.world.listAll]: Loaded 8 world scripts:
communist_population 2.11
oolite-cloaking-device 1.76.1
oolite-constrictor-hunt 1.76.1
oolite-nova 1.76.1
oolite-thargoid-plans 1.76.1
oolite-trumbles 1.76.1
rockHermit_Locator 1.3.3
System Redux 1.2.3
15:48:02.416 [loading.complete]: ========== Loading complete. ==========
15:48:02.468 [joystick.connect]: Joystick connected: SideWinder Joystick
15:48:02.486 [shader.uniform.unpermittedMethod]: Did not bind uniform "alertlevel" to property -[ShipEntity alertCondition] - unpermitted method.
15:48:02.737 [sound.mixer.failedToConnectChannel]: Sound mixer: failed to connect channel <OOSoundChannel 0x10c748280>{ID=1, state=stopped, sound=<OOCAStreamingSound 0x101b632d0>{"OoliteTheme.ogg"}}, error = kAudioUnitErr_CannotDoInCurrentContext.
15:48:02.737 [sound.play.failed]: Failed to play <OOCAStreamingSound 0x101b632d0>{"OoliteTheme.ogg"}

Closing log at 2012-10-14 14:48:07 +0000.

does this sort of stuff mean anything to anyone?- thanks in advance

Re: invisible ships and stations or odd colours

Posted: Sun Oct 14, 2012 6:34 pm
by Commander McLane
Due to lack of availability in the development team Oolite hasn't been thoroughly tested on Apple's new retina display yet. Speaking as a lay person, I suspect that graphics glitches in your configuration may have something to do with that. I'm sure that one of the boffins will be here soon with some more insight (and probably some more questions for you).

Re: invisible ships and stations or odd colours

Posted: Sun Oct 14, 2012 6:41 pm
by Eric Walch
As McLane writes, has trunk some changes for better retina support. You might try the trunk version that is available here. This is no version for real playing, but if this fixes things for you, you might stick to that version and report any retina issues as none of the devs uses a retina display.. If not, better revert to the current stable version.

Re: invisible ships and stations or odd colours

Posted: Mon Oct 15, 2012 6:55 am
by phonebook
thanks, I rather agree with sentiment that my mac is a very new one and that time will provide solutions! the thing is, i'm not using the retina display- i'm using a thunderbolt display- the mbp is closed

I have the laptop set to only use the nvidia graphics card (which is the recommended thing to do for graphics apparently)

I must stress that there is no problem unless I Include the OXPs

as a further experiment, I will make a bootcamp partition and install windows 7 and see if the apple drivers for the graphics card are up to the job- will also install oolite onto my apple pro at work and see if the OXPs do the glitches to an older apple mac (tho well specified one)

prior to this for tonight at least I have turned shaders off completely- a couple of people in the chat room suggested that- so far it is working, however I have had false dawns before

again thanks to everyone who is reading, making suggestions, trying to help

Re: invisible ships and stations or odd colours

Posted: Mon Oct 15, 2012 8:15 am
by Commander McLane
phonebook wrote:I must stress that there is no problem unless I Include the OXPs
The OXPs are using something called "shaders" in the graphics department, while the "vanilla" game does not. That may be the culprit with your configuration. But then again, I'm no expert in these matters.

Re: invisible ships and stations or odd colours

Posted: Mon Oct 15, 2012 9:07 am
by phonebook
a quick play on a griff shipped version on my mac pro at work and at full shaders and everything is perfect (same OS as the mbp retina)

this leads me to think it is an issue of shaders on my mpb retina, but we shall see

Re: invisible ships and stations or odd colours

Posted: Wed Oct 17, 2012 11:56 am
by Svengali
phonebook wrote:this leads me to think it is an issue of shaders on my mpb retina, but we shall see
I think there's more going on on your machine.

Code: Select all

15:48:02.737 [sound.mixer.failedToConnectChannel]: Sound mixer: failed to connect channel <OOSoundChannel 0x10c748280>{ID=1, state=stopped, sound=<OOCAStreamingSound 0x101b632d0>{"OoliteTheme.ogg"}}, error = kAudioUnitErr_CannotDoInCurrentContext.
15:48:02.737 [sound.play.failed]: Failed to play <OOCAStreamingSound 0x101b632d0>{"OoliteTheme.ogg"}

Re: invisible ships and stations or odd colours

Posted: Fri Oct 19, 2012 5:50 pm
by phonebook
yes i saw that too! but I was putting it to the back of my mind, graphics issues first then sound once it all looks good

Re: invisible ships and stations or odd colours

Posted: Fri Oct 19, 2012 6:10 pm
by Cody
It's most probably a useless suggestion, phonebook - but have you tried updating your nVidia gfx drivers? You never know - it may help.

Re: invisible ships and stations or odd colours

Posted: Wed Oct 24, 2012 1:18 pm
by Griff
phonebook wrote:occasional invisible ships, stations or suddenly in bright white or yellow
seems to affect griff ships the most and groove stations
PAG mentioned seeing some graphic problems with the pagroove stations.oxp the other day, try installing the new version (v1.3) the came out earlier this week, it replaces most of the custom shaders with effects from Oolite own 'materials' system, it looks prettier than before and shouldn't have any graphical problems.

The other issue (yellow/white glowing ships) sounds like what happens with my shipset if the shaders start looking for their glow maps in the wrong place, instead of restricting the glow effects to small spots on the hull the whole ship glows. Are you seeing this problem on all the different types of ships or only on the anaconda? I reworked the anaconda a while back and it did end up glowing for some players until the shader .fragemt files were updated too.

Does Staer9's shipset reference any of the textures or shaders in my oxps? I downloaded the latest version of this from the wiki (v1.0.5) and i can see that it doesn't, but i can't remembr if there was an earlier release that did - i might have edited some of my texture/shader files since that oxp came out and this might be causing the glowing ships problem. try takin gout my shipset for a bit and just keeping Staer9's see if everything is ok, then maybe just try with my shipset for a bit, and if this still look OK, then both together again to see if the problems come back, if so there's a clash between those 2 oxp's

Re: invisible ships and stations or odd colours

Posted: Wed Oct 24, 2012 1:21 pm
by Cody
Griff wrote:I reworked the anaconda a while back and it did end up glowing for some players
Like this, flashing on and off:

Image