Oolite Bulletins

For information and discussion about Oolite.
It is currently Mon Oct 23, 2017 4:14 am

All times are UTC




Post new topic  Reply to topic  [ 28 posts ]  Go to page 1 2 Next
Author Message
PostPosted: Wed Jan 16, 2013 11:49 pm 
Offline
Above Average
Above Average
User avatar

Joined: Mon Nov 06, 2006 9:02 am
Posts: 22
Location: Italy
I downloaded oolite 1.77 on my mac 10.6.8.
It crashes at start up.
What can be the problem?!

My old 1.73.4 version starts and works.

Here the mac log:
http://dl.dropbox.com/u/13585283/177_crash_on_mac.rtf

thanks in advance

_________________
Macbook Pro 1,3 (2.4 GHz Intel Core 2 Duo) - Mac Os X 10.6.8


Last edited by pescenaufrago on Sun Jan 27, 2013 8:33 pm, edited 1 time in total.

Top
   
 Post subject: Re: 1.77 crash
PostPosted: Thu Jan 17, 2013 8:27 am 
Offline
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
User avatar

Joined: Sat Jun 16, 2007 3:48 pm
Posts: 5536
Location: Netherlands
The crash happens in the sound part of the code, so it is probably specific for the mac. I have no clue for that part of the code. Or maybe the Vorbis libraries are not linked correctly into the project. I see the library name red in my compiler, but on the other hand does it work without problems for me.

_________________
UPS-Courier & DeepSpacePirates & others at the box and some older versions


Top
   
 Post subject: Re: 1.77 crash
PostPosted: Thu Jan 17, 2013 9:59 am 
Offline
Above Average
Above Average
User avatar

Joined: Mon Nov 06, 2006 9:02 am
Posts: 22
Location: Italy
how must be linked "vorbis libraries"?
i'm not a tecnician... :?

_________________
Macbook Pro 1,3 (2.4 GHz Intel Core 2 Duo) - Mac Os X 10.6.8


Top
   
 Post subject: Re: 1.77 crash
PostPosted: Thu Jan 17, 2013 11:16 am 
Offline
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
User avatar

Joined: Sat Jun 16, 2007 3:48 pm
Posts: 5536
Location: Netherlands
Quote:
how must be linked "vorbis libraries"?
i'm not a tecnician... :?
If that is the fault, you can't do anything. But than probably every user has the problem so I am not sure what is the problem.

_________________
UPS-Courier & DeepSpacePirates & others at the box and some older versions


Top
   
 Post subject: Re: 1.77 crash
PostPosted: Thu Jan 17, 2013 11:29 am 
Offline
Above Average
Above Average
User avatar

Joined: Mon Nov 06, 2006 9:02 am
Posts: 22
Location: Italy
I can't believe other mac users can't use 1.77 version...
have nobody my configuration?

macbook pro 1,3 with 10.6.8.
oolite in installed as in screenshot

_________________
Macbook Pro 1,3 (2.4 GHz Intel Core 2 Duo) - Mac Os X 10.6.8


Top
   
 Post subject: Re: 1.77 crash
PostPosted: Thu Jan 17, 2013 12:14 pm 
Offline
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
User avatar

Joined: Sat Jun 16, 2007 3:48 pm
Posts: 5536
Location: Netherlands
Quote:
macbook pro 1,3 with 10.6.8
Probably not a missing library as the current mac release is compiled on my laptop under 10.7. There the libraries look good. It no longer compiles on my 10.6 mac and that was the one I noticed the libraries marked in red.That older version of XCode can't compile the current code anymore, when might the cause it looked bad to me.

But, I also use this Oolite build mainly on OS 10.6.8 and see no issues. So I wounder what is the difference.

_________________
UPS-Courier & DeepSpacePirates & others at the box and some older versions


Top
   
 Post subject: Re: 1.77 crash
PostPosted: Thu Jan 24, 2013 10:15 pm 
Offline
Deadly
Deadly
User avatar

Joined: Mon Oct 13, 2008 7:32 pm
Posts: 254
Location: Namab
Crashes on mine too. even with no oxp's in. just the 1.77 fresh as it appears after download.
i mac 2.4gz
osx 10.6.8

_________________
Image


Top
   
 Post subject: Re: 1.77 crash
PostPosted: Fri Jan 25, 2013 8:31 am 
Offline
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
User avatar

Joined: Sat Jun 16, 2007 3:48 pm
Posts: 5536
Location: Netherlands
Quote:
Crashes on mine too.
If your crash log also contains the lines
Code:
Exception Type:  EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   org.aegidian.oolite           	0x00000001002eb588 vorbis_synthesis_headerin + 2104
1   org.aegidian.oolite           	0x00000001002e8397 _fetch_headers + 1383
2   org.aegidian.oolite           	0x00000001002d3c56 ov_open + 342
3   org.aegidian.oolite           	0x0000000100005d88 -[OOCASoundVorbisCodec initWithPath:] + 163
4   org.aegidian.oolite           	0x0000000100004823 -[OOSound initWithContentsOfFile:] + 81
5   org.aegidian.oolite           	0x000000010002560e +[ResourceManager retrieveFileNamed:inFolder:cache:key:class:usePathCache:] + 194
6   org.aegidian.oolite           	0x000000010002578e +[ResourceManager ooSoundNamed:inFolder:] + 126
7   org.aegidian.oolite           	0x0000000100042e35 -[Universe preloadSounds] + 274
8   org.aegidian.oolite           	0x000000010002681f -[Universe initWithGameView:] + 1297
9   org.aegidian.oolite           	0x000000010000c288 -[GameController applicationDidFinishLaunching:] + 477
as the crash log of pescenaufrago shows, we are talking about the same crash. You both are using the same system. Although I also use 10.6.8 and never had problems. That makes it difficult as other parts of the OS system also interfere in the bug. It happens on initialising the sound. I've never looked at the sound code and currently have no clue were to look. And specially because its a bug that not happens on all similar systems. :cry:
I hope Ahruman finds time to look at it, because he probably is the only one with knowledge about the sound code on the mac.

_________________
UPS-Courier & DeepSpacePirates & others at the box and some older versions


Top
   
 Post subject: Re: 1.77 crash
PostPosted: Fri Jan 25, 2013 9:05 am 
Offline
Master and Commander
Master and Commander
User avatar

Joined: Thu May 20, 2004 10:46 pm
Posts: 1148
Location: London UK
I get the same crash with 1.77, so I reverted to 1.76.1 (which works fine) - Intel iMac OSX 10.8.2

I didn't want to mention it, because I assumed that someone would be fixing this rapidly.


Could someone please fix this rapidly.

_________________
"The planet Rear is scourged by well-intentioned OXZs."

Oolite models and gear? click here!


Top
   
 Post subject: Re: 1.77 crash
PostPosted: Fri Jan 25, 2013 9:17 am 
Offline
Intergalactic Spam Assassin
Intergalactic Spam Assassin
User avatar

Joined: Thu Dec 14, 2006 9:08 am
Posts: 9520
Location: a Hacker Outpost in a moderately remote area
I don't get a crash with the 1.77 test version on OS X 10.6.8. Are the crashes happening with the deployment version or the test version? Perhaps this could point to a problem between the two versions.

_________________
The Story — The Career — The OXPs


Top
   
 Post subject: Re: 1.77 crash
PostPosted: Fri Jan 25, 2013 9:36 am 
Offline
Deadly
Deadly
User avatar

Joined: Tue Sep 07, 2004 8:54 pm
Posts: 193
Location: The Greatest City in the Ooniverse
As a datum, I'm running OS 10.7.latest and 1.77. I've had one random crash in the middle of a furball, and twice a Coriolis station has been somehow fucked on approach: the first time it appeared to start spinning remarkably quickly, and the second the decoration around the docking port seemed to have closed in, a little like the shutter on a camera. In neither case was I able to dock successfully! :roll:

I've been playing it reasonably full on for the last two days as I've been off sick, but I'm back at work now so can't destruct test quite as thoroughly. Still, while those three niggles were a tad annoying (I 'lost' maybe 12 kills and a few thousand Cr in captured cargo) this version is pretty darned good.

I'll upload a log if it happens again.

_________________
Master of Mayhem

"The name's derived from Object Oriented eLite so you could say "Oh! Oh! Leet!", but that might sound too much like g33k sex."


Top
   
 Post subject: Re: 1.77 crash
PostPosted: Fri Jan 25, 2013 9:52 am 
Offline
Above Average
Above Average
User avatar

Joined: Mon Nov 06, 2006 9:02 am
Posts: 22
Location: Italy
Quote:
I don't get a crash with the 1.77 test version on OS X 10.6.8. Are the crashes happening with the deployment version or the test version? Perhaps this could point to a problem between the two versions.
I installed the "Latest edition" from this page.

_________________
Macbook Pro 1,3 (2.4 GHz Intel Core 2 Duo) - Mac Os X 10.6.8


Top
   
 Post subject: Re: 1.77 crash
PostPosted: Fri Jan 25, 2013 10:40 am 
Offline
Master and Commander
Master and Commander
User avatar

Joined: Thu May 20, 2004 10:46 pm
Posts: 1148
Location: London UK
Quote:
Quote:
I don't get a crash with the 1.77 test version on OS X 10.6.8. Are the crashes happening with the deployment version or the test version? Perhaps this could point to a problem between the two versions.
I installed the "Latest edition" from this page.
Yup, me too.

_________________
"The planet Rear is scourged by well-intentioned OXZs."

Oolite models and gear? click here!


Top
   
 Post subject: Re: 1.77 crash
PostPosted: Fri Jan 25, 2013 10:55 am 
Offline
Intergalactic Spam Assassin
Intergalactic Spam Assassin
User avatar

Joined: Thu Dec 14, 2006 9:08 am
Posts: 9520
Location: a Hacker Outpost in a moderately remote area
Quote:
Quote:
Quote:
I don't get a crash with the 1.77 test version on OS X 10.6.8. Are the crashes happening with the deployment version or the test version? Perhaps this could point to a problem between the two versions.
I installed the "Latest edition" from this page.
Yup, me too.
That would be the deployment version. Eric has the test version like me, I assume.

_________________
The Story — The Career — The OXPs


Top
   
 Post subject: Re: 1.77 crash
PostPosted: Fri Jan 25, 2013 12:23 pm 
Offline
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
User avatar

Joined: Sat Jun 16, 2007 3:48 pm
Posts: 5536
Location: Netherlands
Quote:
That would be the deployment version. Eric has the test version like me, I assume.
Both versions are compiled on my OSX 10.7 laptop. And both run correct on both my 10.6.8 machines.
The nighties are compiled elsewhere, but I suspect they behave the same. You could check it though by downloading them from the nighties page. This will give the version with the latest bugfixes. At least until we start with 1.78, than new features and new bugs will be added. :)

EDIT: I also started Oolite with the OSX 1.6.8 mac in Guest Account. That will be the same as a virgin install without any oxp (because I put all my oxps in the user area) and with all settings to default.

_________________
UPS-Courier & DeepSpacePirates & others at the box and some older versions


Last edited by Eric Walch on Fri Jan 25, 2013 1:00 pm, edited 1 time in total.

Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 28 posts ]  Go to page 1 2 Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited