More Mac Newbie problems - OXPs not working

Discussion and announcements regarding the Mac port… er, original version of Oolite.

Moderators: winston, another_commander

Post Reply
tenorman1971
Above Average
Above Average
Posts: 24
Joined: Wed May 04, 2011 5:32 pm
Location: Newark-on-Trent, UK - Poor Agricultural Anarchy

More Mac Newbie problems - OXPs not working

Post by tenorman1971 » Tue Apr 23, 2019 11:59 am

Hi

I'm running Oolite 1.88 under Mojave. When I downloaded it, I dragged the Oolite folder into my Applications folder. There was no AddOns folder in it, so I created one. I've put OXPs in there as I did when I used to use Linux, but they don't do anything. I can use the expansion pack manager as before, but there were some OXPs that I was using that are not there as OXZs so I wanted to add them manually. Does version 1.88 on Mac still support manually adding OXPs like this? Has anyone else had this problem?

User avatar
Disembodied
Jedi Spam Assassin
Jedi Spam Assassin
Posts: 6205
Joined: Thu Jul 12, 2007 10:54 pm
Location: Carter's Snort

Re: More Mac Newbie problems - OXPs not working

Post by Disembodied » Wed Apr 24, 2019 9:13 am

I think, on the Mac, you need to create the AddOns folder at

~/Library/Application Support/Oolite/AddOns/

There should be a folder there already called Managed AddOns - I think you need to create a separate AddOns folder alongside this.

(If you need to find the Library folder, go to the Go menu in Finder and hold down the ALT key.)

Post Reply