Building with XCode 10 ... tweaks needed

Discussion and announcements regarding the Mac port… er, original version of Oolite.

Moderators: winston, another_commander

Post Reply
zevans
---- E L I T E ----
---- E L I T E ----
Posts: 322
Joined: Mon Jul 06, 2009 11:12 pm
Location: Uncharted backwaters of the unfashionable end of the western spiral arm

Building with XCode 10 ... tweaks needed

Post by zevans » Mon Sep 10, 2018 7:32 pm

I had a go building with XCode 10. 10 finally removes support for the long-deprecated libstdc++.

I am surprised to find that if you switch the Frameworks/libjs target, libjs will build - BUT you have to change the build target to MacOS 10.7 minimum.

Unfortunately there's another setting somewhere which stops the Oolite target from building... trying to track that down now, unless anyone has any suggestions.

I am quite sure there are Oolite pilots out there still using Snow Leopard as quite a few popular generations of Mac are now stuck on SL but still around. So someone smarter than me will have to wrap this in some build / config logic, so it will either use libstdc++ with SL or libc++ with 10.7 onwards.

zevans
---- E L I T E ----
---- E L I T E ----
Posts: 322
Joined: Mon Jul 06, 2009 11:12 pm
Location: Uncharted backwaters of the unfashionable end of the western spiral arm

Re: Building with XCode 10 ... tweaks needed

Post by zevans » Mon Sep 10, 2018 7:54 pm

Aha.

Code: Select all

src/Cocoa/oolite-targets.xcconfig
had it hard-wired. (Found it by looking at the "levels" instead of "combined" in the Build Settings.

Now can we have a little chat about the 1413 warnings... :-)

Post Reply