Oolite Bulletins

For information and discussion about Oolite.
It is currently Thu Apr 18, 2019 4:15 pm

All times are UTC




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon Sep 10, 2018 7:32 pm 
Offline
---- E L I T E ----
---- E L I T E ----

Joined: Mon Jul 06, 2009 11:12 pm
Posts: 322
Location: Uncharted backwaters of the unfashionable end of the western spiral arm
I had a go building with XCode 10. 10 finally removes support for the long-deprecated libstdc++.

I am surprised to find that if you switch the Frameworks/libjs target, libjs will build - BUT you have to change the build target to MacOS 10.7 minimum.

Unfortunately there's another setting somewhere which stops the Oolite target from building... trying to track that down now, unless anyone has any suggestions.

I am quite sure there are Oolite pilots out there still using Snow Leopard as quite a few popular generations of Mac are now stuck on SL but still around. So someone smarter than me will have to wrap this in some build / config logic, so it will either use libstdc++ with SL or libc++ with 10.7 onwards.


Top
   
PostPosted: Mon Sep 10, 2018 7:54 pm 
Offline
---- E L I T E ----
---- E L I T E ----

Joined: Mon Jul 06, 2009 11:12 pm
Posts: 322
Location: Uncharted backwaters of the unfashionable end of the western spiral arm
Aha.
Code:
src/Cocoa/oolite-targets.xcconfig
had it hard-wired. (Found it by looking at the "levels" instead of "combined" in the Build Settings.

Now can we have a little chat about the 1413 warnings... :-)


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited