Building with XCode 10 ... tweaks needed

Discussion and announcements regarding the Mac port… er, original version of Oolite.

Moderators: winston, another_commander

Post Reply
zevans
---- E L I T E ----
---- E L I T E ----
Posts: 322
Joined: Mon Jul 06, 2009 11:12 pm
Location: Uncharted backwaters of the unfashionable end of the western spiral arm

Building with XCode 10 ... tweaks needed

Post by zevans » Mon Sep 10, 2018 7:32 pm

I had a go building with XCode 10. 10 finally removes support for the long-deprecated libstdc++.

I am surprised to find that if you switch the Frameworks/libjs target, libjs will build - BUT you have to change the build target to MacOS 10.7 minimum.

Unfortunately there's another setting somewhere which stops the Oolite target from building... trying to track that down now, unless anyone has any suggestions.

I am quite sure there are Oolite pilots out there still using Snow Leopard as quite a few popular generations of Mac are now stuck on SL but still around. So someone smarter than me will have to wrap this in some build / config logic, so it will either use libstdc++ with SL or libc++ with 10.7 onwards.

zevans
---- E L I T E ----
---- E L I T E ----
Posts: 322
Joined: Mon Jul 06, 2009 11:12 pm
Location: Uncharted backwaters of the unfashionable end of the western spiral arm

Re: Building with XCode 10 ... tweaks needed

Post by zevans » Mon Sep 10, 2018 7:54 pm

Aha.

Code: Select all

src/Cocoa/oolite-targets.xcconfig
had it hard-wired. (Found it by looking at the "levels" instead of "combined" in the Build Settings.

Now can we have a little chat about the 1413 warnings... :-)

Bogatyr
Deadly
Deadly
Posts: 207
Joined: Sun Feb 24, 2013 11:52 am

Re: Building with XCode 10 ... tweaks needed

Post by Bogatyr » Tue Jun 25, 2019 10:53 am

I'm running Xcode 10.2.1 on OS X 10.14.3 and can't get oolite (TOT master branch from github) to build.

I tried various values for the minimum deployment target in src/Cocoa/oolite-targets.xcconfig, including removing the line altogether. In each of the variants I tried, the issue with libstdc++ goes away but is replaced by build failures due to other deprecated SDK functions sprinkled throughout the oolite source. It seems the best approach is to leave in the 10.6 minimum deploy target and to adjust the C++ library to use libc++, but I haven't had any luck in that (just trying to get it to build for my system, 10.14.3, at this point).

Has anybody gotten oolite to build & run with Xcode 10?

User avatar
phkb
Commodore
Commodore
Posts: 2369
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Building with XCode 10 ... tweaks needed

Post by phkb » Tue Jun 25, 2019 11:12 am

There's a PR on GitHub that says is fixes mac Builds for xcode 10, Link here: https://github.com/OoliteProject/oolite/pull/318. I don't have Mac so I can't confirm anything but it might be worth examining.

Bogatyr
Deadly
Deadly
Posts: 207
Joined: Sun Feb 24, 2013 11:52 am

Re: Building with XCode 10 ... tweaks needed

Post by Bogatyr » Tue Jun 25, 2019 12:07 pm

phkb wrote:
Tue Jun 25, 2019 11:12 am
There's a PR on GitHub that says is fixes mac Builds for xcode 10, Link here: https://github.com/OoliteProject/oolite/pull/318. I don't have Mac so I can't confirm anything but it might be worth examining.
Thanks, from there I found the "fix-mac-builds" branch, which built for me.

Post Reply