[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4280: ob_start(): output handler 'ob_gzhandler' conflicts with 'zlib output compression'
Oolite Bulletins • Building with XCode 10 ... tweaks needed
Page 1 of 1

Building with XCode 10 ... tweaks needed

Posted: Mon Sep 10, 2018 7:32 pm
by zevans
I had a go building with XCode 10. 10 finally removes support for the long-deprecated libstdc++.

I am surprised to find that if you switch the Frameworks/libjs target, libjs will build - BUT you have to change the build target to MacOS 10.7 minimum.

Unfortunately there's another setting somewhere which stops the Oolite target from building... trying to track that down now, unless anyone has any suggestions.

I am quite sure there are Oolite pilots out there still using Snow Leopard as quite a few popular generations of Mac are now stuck on SL but still around. So someone smarter than me will have to wrap this in some build / config logic, so it will either use libstdc++ with SL or libc++ with 10.7 onwards.

Re: Building with XCode 10 ... tweaks needed

Posted: Mon Sep 10, 2018 7:54 pm
by zevans
Aha.

Code: Select all

src/Cocoa/oolite-targets.xcconfig
had it hard-wired. (Found it by looking at the "levels" instead of "combined" in the Build Settings.

Now can we have a little chat about the 1413 warnings... :-)

Re: Building with XCode 10 ... tweaks needed

Posted: Tue Jun 25, 2019 10:53 am
by Bogatyr
I'm running Xcode 10.2.1 on OS X 10.14.3 and can't get oolite (TOT master branch from github) to build.

I tried various values for the minimum deployment target in src/Cocoa/oolite-targets.xcconfig, including removing the line altogether. In each of the variants I tried, the issue with libstdc++ goes away but is replaced by build failures due to other deprecated SDK functions sprinkled throughout the oolite source. It seems the best approach is to leave in the 10.6 minimum deploy target and to adjust the C++ library to use libc++, but I haven't had any luck in that (just trying to get it to build for my system, 10.14.3, at this point).

Has anybody gotten oolite to build & run with Xcode 10?

Re: Building with XCode 10 ... tweaks needed

Posted: Tue Jun 25, 2019 11:12 am
by phkb
There's a PR on GitHub that says is fixes mac Builds for xcode 10, Link here: https://github.com/OoliteProject/oolite/pull/318. I don't have Mac so I can't confirm anything but it might be worth examining.

Re: Building with XCode 10 ... tweaks needed

Posted: Tue Jun 25, 2019 12:07 pm
by Bogatyr
phkb wrote:
Tue Jun 25, 2019 11:12 am
There's a PR on GitHub that says is fixes mac Builds for xcode 10, Link here: https://github.com/OoliteProject/oolite/pull/318. I don't have Mac so I can't confirm anything but it might be worth examining.
Thanks, from there I found the "fix-mac-builds" branch, which built for me.