sound disables in game

General discussion for players of Oolite.

Moderators: winston, another_commander

User avatar
Pirate World MK
Above Average
Above Average
Posts: 17
Joined: Fri Nov 30, 2018 3:01 pm

sound disables in game

Post by Pirate World MK » Tue Dec 11, 2018 11:23 am

Howdy fellow commanders . Absolutely delighted to be playing this amazing game , previous experience was solely playing on the zx spectrum with a school friend achieving dangerous after goodness knows how long . Totally hooked & love the game to bits but anyway I wont witter too much & get to the point . Playing on an IMAC and for some reason possibly during a frantic pirate battle the sound disabled (this has happened numerous times) it is really frustrating and I don't know how to rectify it other than closing game and starting again . Maybe I have inadvertently pressed an incorrect key but I cannot find any reference to sound on/off . Hopefully someone may know & thanks in advance
Finally I feel I need to come clean due to a minor tinge of guilt . I am a cowardly pirate that tends to pick on lone ships whatever they are irrespective of potential cargo , I rarely take on two friends . I know , I am a bad person but I hope I'm not alone
Great game , thanks again
MKW - Competent :)

another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5397
Joined: Wed Feb 28, 2007 7:54 am

Re: sound disables in game

Post by another_commander » Tue Dec 11, 2018 2:24 pm

Hi and welocme. Not sure what to tell you about the sound issue. We will probably need a log after a slience event has occurred. Just before sound getting disabled, was there a long pause in the game or something? If it happens again, try to pause the game and go to opitions to see what sound level it reports. Other than that, I am not sure what exactly is happening on Mac, but I don't think it is a case of disabling sound accidentally.

User avatar
montana05
---- E L I T E ----
---- E L I T E ----
Posts: 279
Joined: Mon May 30, 2016 3:54 am

Re: sound disables in game

Post by montana05 » Tue Dec 11, 2018 2:30 pm

Pirate World MK wrote:
Tue Dec 11, 2018 11:23 am
Finally I feel I need to come clean due to a minor tinge of guilt . I am a cowardly pirate that tends to pick on lone ships whatever they are irrespective of potential cargo , I rarely take on two friends . I know , I am a bad person but I hope I'm not alone
Welcome on board commander,
since my current path is the one of a mercenary and assassin I wouldn't consider you as a bad person. :lol:
The great feature of Ooolite is that, thanks to a lot of OXP's/OXZ's, every player is able to create a personal universe. I could think of a number of them probably will be interesting for you if you intend to follow the carrier of a pirate. :wink:
Trying to survive behind the controls of a Caduceus Psi XT in Alpha test :lol:

User avatar
Pirate World MK
Above Average
Above Average
Posts: 17
Joined: Fri Nov 30, 2018 3:01 pm

Re: sound disables in game

Post by Pirate World MK » Tue Dec 11, 2018 4:40 pm

another_commander wrote:
Tue Dec 11, 2018 2:24 pm
Hi and welocme. Not sure what to tell you about the sound issue. We will probably need a log after a slience event has occurred. Just before sound getting disabled, was there a long pause in the game or something? If it happens again, try to pause the game and go to opitions to see what sound level it reports. Other than that, I am not sure what exactly is happening on Mac, but I don't think it is a case of disabling sound accidentally.
Ok many thanks , I can grab a log file as soon as sound goes off & post it . I'm pretty sure it goes off during combat rather than a meandering mid travel pause but will clarify that at next instance .
I've eaten enough monkey poetry Thargoids .....now do one !

User avatar
Pirate World MK
Above Average
Above Average
Posts: 17
Joined: Fri Nov 30, 2018 3:01 pm

Re: sound disables in game

Post by Pirate World MK » Tue Dec 11, 2018 4:43 pm

montana05 wrote:
Tue Dec 11, 2018 2:30 pm
Pirate World MK wrote:
Tue Dec 11, 2018 11:23 am
Finally I feel I need to come clean due to a minor tinge of guilt . I am a cowardly pirate that tends to pick on lone ships whatever they are irrespective of potential cargo , I rarely take on two friends . I know , I am a bad person but I hope I'm not alone
Welcome on board commander,
since my current path is the one of a mercenary and assassin I wouldn't consider you as a bad person. :lol:
The great feature of Ooolite is that, thanks to a lot of OXP's/OXZ's, every player is able to create a personal universe. I could think of a number of them probably will be interesting for you if you intend to follow the carrier of a pirate. :wink:
:) still playing the vanilla version but as I get more adventurous I will hit the oxp market . I'm glad I am not on my way to Coventry over the piracy path !
I've eaten enough monkey poetry Thargoids .....now do one !

User avatar
stranger
Deadly
Deadly
Posts: 147
Joined: Thu Apr 05, 2018 5:31 am
Location: Vladivostok, Russia

Re: sound disables in game

Post by stranger » Thu Dec 13, 2018 12:42 am

Try to remove obsolete custom sound OXPs such as Halsis.oxp if you have any. I has the same problem on Mac - sound abruptly disabled during the battle and after 10...15 min game freezing.
Now game seems OK. I don't know real reason - removing obsolete problem OXPs, improved game engine or upgrading from OS X version 10.6 to version 10.9.

User avatar
Pirate World MK
Above Average
Above Average
Posts: 17
Joined: Fri Nov 30, 2018 3:01 pm

Re: sound disables in game

Post by Pirate World MK » Mon Dec 17, 2018 11:05 am

howdy , still having the sound issues , I'm not overly computer literate , how do I access the log file so I can post it . All F2 seems to do is +- the brightness of the display . I have no oxps installed at all & really want to rid my MAC of this bug for total oolite enjoyment .

on a side note , other than press space commander (which is now happening rarely I am pleased to announce) I keep getting the soul destroying message "Military Shield Enhancement damaged" NOOOOOOOOOOOOOOOOOOO ! Jeez that is an expensive beast to maintain . Every battle that is the first thing to go :( it's why I am always skint lol) 50 kills until dangerous :)
I've eaten enough monkey poetry Thargoids .....now do one !

User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 13680
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: sound disables in game

Post by Cody » Mon Dec 17, 2018 2:10 pm

Pirate World MK wrote:
Mon Dec 17, 2018 11:05 am
... how do I access the log file so I can post it .
On a Mac? The Wiki says:
Alternatively, in the Finder, select “Go to Folder…” from the Go menu, and enter “~/Library/Logs/Oolite/”, and find Latest.log
Being a Windows user, I've no idea if that's correct.
Their dreams a tattered sail in the wind

User avatar
Pirate World MK
Above Average
Above Average
Posts: 17
Joined: Fri Nov 30, 2018 3:01 pm

Re: sound disables in game

Post by Pirate World MK » Mon Dec 17, 2018 2:16 pm

Cody wrote:
Mon Dec 17, 2018 2:10 pm
Pirate World MK wrote:
Mon Dec 17, 2018 11:05 am
... how do I access the log file so I can post it .
On a Mac? The Wiki says:
Alternatively, in the Finder, select “Go to Folder…” from the Go menu, and enter “~/Library/Logs/Oolite/”, and find Latest.log
Being a Windows user, I've no idea if that's correct.
Many thanks sir , I will give that a try this evening :)
I've eaten enough monkey poetry Thargoids .....now do one !

User avatar
Pirate World MK
Above Average
Above Average
Posts: 17
Joined: Fri Nov 30, 2018 3:01 pm

Re: sound disables in game

Post by Pirate World MK » Tue Dec 18, 2018 11:14 am

Pirate World MK wrote:
Mon Dec 17, 2018 2:16 pm
Cody wrote:
Mon Dec 17, 2018 2:10 pm
Pirate World MK wrote:
Mon Dec 17, 2018 11:05 am
... how do I access the log file so I can post it .
On a Mac? The Wiki says:
Alternatively, in the Finder, select “Go to Folder…” from the Go menu, and enter “~/Library/Logs/Oolite/”, and find Latest.log
Being a Windows user, I've no idea if that's correct.
Many thanks sir , I will give that a try this evening :)
not sure how to post the photo I took of the log file but to summarise there are about 50 entries which are all either :-
15:16:02.311 (sound load error) :could not create openAL buffer :- or
15:16:02.311 (ov.debug) Error -50 queueing buffers

it happens during most major tussles now & is destroying my enjoyment & renders it unplayable in those instances as I cant hear my shields getting hit (yet again the bleeding Mil shield enhancement went for a burton) & to say I was livid is an understatement :/

I/m guessing this is a glitch relating to my MAC but if anyone has a brainwave I'm willing to try most things
I've eaten enough monkey poetry Thargoids .....now do one !

User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 13680
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: sound disables in game

Post by Cody » Tue Dec 18, 2018 12:27 pm

Pirate World MK wrote:
Tue Dec 18, 2018 11:14 am
...not sure how to post the photo I took of the log file...
Copy the log contents and paste it into a post.
Their dreams a tattered sail in the wind

another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5397
Joined: Wed Feb 28, 2007 7:54 am

Re: sound disables in game

Post by another_commander » Tue Dec 18, 2018 1:54 pm

Apparently your OpenAL fails while trying to queue sound buffers, but the info seen so far is too little to be conclusive. Later on I'm going to commit a couple of debug changes to try and extract more information about what is going on. You will have to test tomorrow's nightly and see how that behaves and what log gets produced when the error happens.

User avatar
Pirate World MK
Above Average
Above Average
Posts: 17
Joined: Fri Nov 30, 2018 3:01 pm

Re: sound disables in game

Post by Pirate World MK » Tue Dec 18, 2018 2:15 pm

another_commander wrote:
Tue Dec 18, 2018 1:54 pm
Apparently your OpenAL fails while trying to queue sound buffers, but the info seen so far is too little to be conclusive. Later on I'm going to commit a couple of debug changes to try and extract more information about what is going on. You will have to test tomorrow's nightly and see how that behaves and what log gets produced when the error happens.
Will do , many thanks in advance , much appreciated
I've eaten enough monkey poetry Thargoids .....now do one !

User avatar
Pirate World MK
Above Average
Above Average
Posts: 17
Joined: Fri Nov 30, 2018 3:01 pm

Re: sound disables in game

Post by Pirate World MK » Fri Dec 21, 2018 5:37 pm

Pirate World MK wrote:
Tue Dec 18, 2018 2:15 pm
another_commander wrote:
Tue Dec 18, 2018 1:54 pm
Apparently your OpenAL fails while trying to queue sound buffers, but the info seen so far is too little to be conclusive. Later on I'm going to commit a couple of debug changes to try and extract more information about what is going on. You will have to test tomorrow's nightly and see how that behaves and what log gets produced when the error happens.
Will do , many thanks in advance , much appreciated
Opening log for Oolite version 1.86 (x86-64) under Mac OS X Version 10.12.6 (Build 16G1618) at 2018-12-18 21:38:59 +0000.
Machine type: iMac18,2, 8192 MiB memory, 4 x x86 (family 0xf817246) @ 3000 MHz.
Build options: OpenAL, new planets.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

21:39:00.018 [dataCache.rebuild.pathsChanged]: Cache is stale (search paths have changed). Rebuilding from scratch.
21:39:00.516 [rendering.opengl.version]: OpenGL renderer version: 2.1.0 ("2.1 ATI-1.51.8"). Vendor: "ATI Technologies Inc.". Renderer: "AMD Radeon Pro 555 OpenGL Engine".
21:39:00.516 [rendering.opengl.extensions]: OpenGL extensions (136):
GL_EXT_texture_compression_dxt1, GL_EXT_rescale_normal, GL_EXT_transform_feedback, GL_EXT_blend_func_separate, GL_EXT_framebuffer_sRGB, GL_ATI_texture_env_combine3, GL_ATI_blend_weighted_minmax, GL_ARB_draw_elements_base_vertex, GL_EXT_debug_label, GL_EXT_geometry_shader4, GL_EXT_secondary_color, GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_NV_texgen_reflection, GL_NV_blend_square, GL_ARB_texture_compression_rgtc, GL_EXT_stencil_wrap, GL_ARB_texture_env_crossbar, GL_EXT_framebuffer_blit, GL_EXT_bindable_uniform, GL_ATI_separate_stencil, GL_APPLE_vertex_point_size, GL_EXT_texture_rectangle, GL_APPLE_specular_vector, GL_EXT_packed_depth_stencil, GL_EXT_blend_color, GL_ARB_fragment_program_shadow, GL_EXT_texture_env_add, GL_ARB_imaging, GL_EXT_provoking_vertex, GL_EXT_texture_array, GL_ARB_texture_env_combine, GL_ARB_point_sprite, GL_ARB_multisample, GL_EXT_framebuffer_object, GL_ARB_framebuffer_sRGB, GL_EXT_texture_lod_bias, GL_APPLE_pixel_buffer, GL_ARB_vertex_program, GL_EXT_bgra, GL_APPLE_fence, GL_APPLE_ycbcr_422, GL_EXT_timer_query, GL_EXT_vertex_array_bgra, GL_ARB_depth_clamp, GL_IBM_rasterpos_clip, GL_ARB_pixel_buffer_object, GL_SGIS_generate_mipmap, GL_ARB_shader_texture_lod, GL_ARB_texture_float, GL_ARB_texture_rectangle, GL_ARB_vertex_shader, GL_NV_texture_barrier, GL_ARB_provoking_vertex, GL_ARB_texture_env_add, GL_APPLE_object_purgeable, GL_ARB_texture_env_dot3, GL_APPLE_rgb_422, GL_NV_depth_clamp, GL_ARB_texture_mirrored_repeat, GL_ARB_texture_cube_map, GL_APPLE_element_array, GL_ATI_texture_float, GL_ARB_window_pos, GL_ARB_sync, GL_ARB_vertex_buffer_object, GL_APPLE_texture_range, GL_ATI_blend_equation_separate, GL_EXT_stencil_two_side, GL_ARB_texture_compression, GL_ARB_instanced_arrays, GL_EXT_blend_minmax, GL_ARB_texture_border_clamp, GL_EXT_draw_buffers2, GL_ARB_shading_language_100, GL_EXT_blend_equation_separate, GL_ARB_vertex_blend, GL_EXT_blend_subtract, GL_EXT_packed_float, GL_APPLE_aux_depth_stencil, GL_APPLE_row_bytes, GL_ATI_texture_compression_3dc, GL_NV_conditional_render, GL_NV_light_max_exponent, GL_EXT_abgr, GL_EXT_texture_filter_anisotropic, GL_ARB_vertex_array_bgra, GL_ARB_draw_buffers, GL_ARB_transpose_matrix, GL_ARB_color_buffer_float, GL_EXT_gpu_program_parameters, GL_APPLE_client_storage, GL_ARB_texture_non_power_of_two, GL_ARB_multitexture, GL_EXT_gpu_shader4, GL_APPLE_flush_render, GL_ARB_framebuffer_object, GL_APPLE_vertex_program_evaluators, GL_APPLE_transform_hint, GL_EXT_texture_compression_s3tc, GL_APPLE_flush_buffer_range, GL_EXT_texture_integer, GL_SGIS_texture_edge_clamp, GL_EXT_texture_mirror_clamp, GL_ARB_occlusion_query, GL_ARB_fragment_shader, GL_ARB_texture_rg, GL_NV_fog_distance, GL_ARB_fragment_program, GL_ARB_seamless_cube_map, GL_ARB_shader_objects, GL_EXT_draw_range_elements, GL_APPLE_vertex_array_object, GL_ARB_depth_texture, GL_EXT_texture_sRGB, GL_ARB_half_float_vertex, GL_SGI_color_matrix, GL_APPLE_vertex_array_range, GL_ARB_shadow, GL_EXT_multi_draw_arrays, GL_ARB_half_float_pixel, GL_APPLE_packed_pixels, GL_ARB_point_parameters, GL_EXT_debug_marker, GL_EXT_texture_sRGB_decode, GL_EXT_clip_volume_hint, GL_EXT_depth_bounds_test, GL_SGIS_texture_lod, GL_EXT_fog_coord, GL_EXT_texture_shared_exponent, GL_ATI_texture_mirror_once, GL_ARB_shadow_ambient, GL_EXT_framebuffer_multisample, GL_APPLE_float_pixels, GL_ARB_depth_buffer_float, GL_ARB_draw_instanced
21:39:00.527 [rendering.opengl.shader.support]: Shaders are supported.
21:39:00.591 [dataCache.rebuild.pathsChanged]: Cache is stale (search paths have changed). Rebuilding from scratch.
21:39:00.591 [searchPaths.dumpAll]: Resource paths:
/var/folders/47/1dkx5nm55mz67p4r5wj9tssw0000gn/T/AppTranslocation/64FAC6C2-8B82-4875-A560-8DE6CF9AE4C8/d/Oolite.app/Contents/Resources
21:39:00.599 [shipData.load.begin]: Loading ship data.
21:39:01.014 [shipData.load.begin]: Loading ship data.
21:39:01.345 [script.load.world.listAll]: Loaded 16 world scripts:
Oolite Equipment Control 1.86
Oolite Ship Library 1.86
oolite-cloaking-device 1.86
oolite-constrictor-hunt 1.86
oolite-contracts-cargo 1.86
oolite-contracts-helpers 1.86
oolite-contracts-parcels 1.86
oolite-contracts-passengers 1.86
oolite-libPriorityAI 1.86
oolite-nova 1.86
oolite-populator 1.86
oolite-primable-equipment-register 1.86
oolite-registership 1.86
oolite-thargoid-plans 1.86
oolite-trumbles 1.86
oolite-tutorial 1.86
21:39:02.175 [startup.complete]: ========== Loading complete in 1.94 seconds. ==========
17:13:00.999 [sound.load.error]: Could not create OpenAL buffer
17:13:01.016 [sound.load.error]: Could not create OpenAL buffer
17:13:01.016 [ov.debug]: Error -1 playing source
17:13:01.047 [sound.load.error]: Could not create OpenAL buffer
17:13:01.047 [ov.debug]: Error -1 playing source
17:13:01.096 [sound.load.error]: Could not create OpenAL buffer
17:13:01.097 [ov.debug]: Error -50 queueing buffers
17:13:01.207 [sound.load.error]: Could not create OpenAL buffer
17:13:01.978 [sound.load.error]: Could not create OpenAL buffer
17:13:02.086 [sound.load.error]: Could not create OpenAL buffer
17:13:02.087 [ov.debug]: Error -1 playing source
17:13:02.197 [sound.load.error]: Could not create OpenAL buffer
17:13:02.641 [sound.load.error]: Could not create OpenAL buffer
17:13:02.641 [ov.debug]: Error -1 playing source
17:14:48.637 [sound.load.error]: Could not create OpenAL buffer
17:14:48.637 [ov.debug]: Error -1 playing source
17:14:48.807 [sound.load.error]: Could not create OpenAL buffer
17:14:48.807 [ov.debug]: Error -1 playing source
17:14:48.901 [sound.load.error]: Could not create OpenAL buffer
17:14:48.901 [ov.debug]: Error -1 playing source
17:14:49.157 [sound.load.error]: Could not create OpenAL buffer
17:14:49.286 [sound.load.error]: Could not create OpenAL buffer
17:14:49.286 [ov.debug]: Error -1 playing source
17:14:49.401 [sound.load.error]: Could not create OpenAL buffer
17:14:49.401 [ov.debug]: Error -50 queueing buffers
17:14:49.551 [sound.load.error]: Could not create OpenAL buffer
17:14:49.551 [ov.debug]: Error -50 queueing buffers
17:14:49.551 [sound.load.error]: Could not create OpenAL buffer
17:14:49.551 [ov.debug]: Error -50 queueing buffers
17:14:49.807 [sound.load.error]: Could not create OpenAL buffer
17:14:49.922 [sound.load.error]: Could not create OpenAL buffer
17:14:49.922 [ov.debug]: Error -1 playing source
17:14:50.056 [sound.load.error]: Could not create OpenAL buffer
17:14:50.056 [ov.debug]: Error -50 queueing buffers
17:14:50.057 [sound.load.error]: Could not create OpenAL buffer
17:14:50.057 [ov.debug]: Error -50 queueing buffers
17:14:50.186 [sound.load.error]: Could not create OpenAL buffer
17:14:50.186 [ov.debug]: Error -50 queueing buffers
17:14:50.322 [sound.load.error]: Could not create OpenAL buffer
17:14:50.322 [ov.debug]: Error -50 queueing buffers
17:14:50.471 [sound.load.error]: Could not create OpenAL buffer
17:14:50.471 [ov.debug]: Error -50 queueing buffers
17:14:50.557 [sound.load.error]: Could not create OpenAL buffer
17:14:50.557 [ov.debug]: Error -50 queueing buffers
17:14:50.622 [sound.load.error]: Could not create OpenAL buffer
17:14:50.622 [ov.debug]: Error -50 queueing buffers
17:14:50.736 [sound.load.error]: Could not create OpenAL buffer
17:14:50.736 [ov.debug]: Error -50 queueing buffers
17:14:50.858 [sound.load.error]: Could not create OpenAL buffer
17:14:50.858 [ov.debug]: Error -50 queueing buffers
17:14:51.038 [sound.load.error]: Could not create OpenAL buffer
17:14:51.038 [ov.debug]: Error -50 queueing buffers
17:14:51.074 [sound.load.error]: Could not create OpenAL buffer
17:14:51.074 [ov.debug]: Error -50 queueing buffers
17:14:51.192 [sound.load.error]: Could not create OpenAL buffer
17:14:51.192 [ov.debug]: Error -50 queueing buffers
17:14:51.356 [sound.load.error]: Could not create OpenAL buffer
17:14:51.356 [ov.debug]: Error -50 queueing buffers
17:14:51.557 [sound.load.error]: Could not create OpenAL buffer
17:14:51.557 [ov.debug]: Error -50 queueing buffers
17:14:58.276 [sound.load.error]: Could not create OpenAL buffer
17:14:58.276 [ov.debug]: Error -50 queueing buffers
17:14:58.376 [sound.load.error]: Could not create OpenAL buffer
17:14:58.376 [ov.debug]: Error -50 queueing buffers
17:15:01.226 [sound.load.error]: Could not create OpenAL buffer
17:15:01.226 [ov.debug]: Error -50 queueing buffers
17:15:03.567 [sound.load.error]: Could not create OpenAL buffer
17:15:03.567 [ov.debug]: Error -50 queueing buffers
17:15:03.931 [sound.load.error]: Could not create OpenAL buffer
17:15:03.931 [ov.debug]: Error -50 queueing buffers

Closing log at 2018-12-21 17:28:49 +0000.

here is my latest log
hope this can help
I've eaten enough monkey poetry Thargoids .....now do one !

another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5397
Joined: Wed Feb 28, 2007 7:54 am

Re: sound disables in game

Post by another_commander » Fri Dec 21, 2018 5:54 pm

Something is wrong here. You seem to be running version 1.86.

Post Reply