Too many ships spawned

For test results, bug reports, announcements of new builds etc.

Moderators: another_commander, winston, Getafix

Post Reply
User avatar
Galileo
Dangerous
Dangerous
Posts: 103
Joined: Tue Nov 15, 2005 1:55 am
Location: Tasmania, Australia

Too many ships spawned

Post by Galileo »

Just upgraded to svn r335 on Linux and in the first system I jumped to I had about 50-60 ships spawn at the witchpoint. I reloaded the game and jumped to the same system and again, ~50 ships spawned. So I energy bombed them and skimmed some fuel and jumped out of the system then jumped back to the 'problem' system and the same thing happened, much less ships this time, although I counted them and there were 19 of them but the console says:

2006-03-16 13:16:50.000 oolite[9889] ... for a total of 9 ships

The system it happened in was Ramaza which had been altered by my OXP. It is supposed to make all ships jump out of the system right after it is created and it always worked before.

User avatar
aegidian
Master and Commander
Master and Commander
Posts: 1152
Joined: Thu May 20, 2004 10:46 pm
Location: London UK
Contact:

Post by aegidian »

It'd help (in this case) to see a little bit more of the console.log

In particular the "---> searching paths:" section - to check that you aren't loading the same OXPs more than once (which might happen).

Also I'd need to see the scripts concerned, then I can see if I can understand or replicate the problem.
"The planet Rear is scourged by well-intentioned OXZs."

Oolite models and gear? click here!

User avatar
Rxke
Retired Assassin
Retired Assassin
Posts: 1743
Joined: Thu Aug 12, 2004 4:54 pm
Location: Belgium

Post by Rxke »

I just had this happening too, after installing the new patch. On OS X. No coincidence, probably?

AFAICT, It were all Asps and 5-6 Galcops (or other systemvessels, not sure, my game practically froze, old hardware seemingly incapable to keep up, so I didn't really succeed in navigating so I could visually ascertain the latter ones...

Now, in 99% of all jumps prior using the patch there was an offender status Asp being spawned near where I entered, but very rarely it attacked, so that's maybe a pointer? (being spawned by a certain OXP or standard behaviour...)

User avatar
aegidian
Master and Commander
Master and Commander
Posts: 1152
Joined: Thu May 20, 2004 10:46 pm
Location: London UK
Contact:

Post by aegidian »

Mmm. I really need more to go on - especially as I've not seen this problem yet.

Yes, pirates do occasionally jump in soon after exiting witchspace, but a one or three is normal - fifty is damn odd.

If it happens again could you please e-mail me a full report: Pause the game and press 0 (zero) then open console.log and send me the last hundred lines or so (from the point where Oolite populates the system). And include a list of OXPs you're using, and the OS you're running Oolite on.
"The planet Rear is scourged by well-intentioned OXZs."

Oolite models and gear? click here!

User avatar
Rxke
Retired Assassin
Retired Assassin
Posts: 1743
Joined: Thu Aug 12, 2004 4:54 pm
Location: Belgium

Post by Rxke »

I will try to recreate it, but so far unsuccessful

Post Reply