AI's fuel injectors usage

For test results, bug reports, announcements of new builds etc.

Moderators: winston, another_commander, Getafix

Post Reply
Astrobe
---- E L I T E ----
---- E L I T E ----
Posts: 580
Joined: Sun Jul 21, 2013 12:26 pm

AI's fuel injectors usage

Post by Astrobe » Tue Oct 18, 2016 4:57 pm

I've played a bit with the injectorSpeedFactor. It seems that when an AI foe chases you and you engage your fuel injectors, the AI uses its injectors as well. But it seems that its injector speed is the same as the player's. I could observe this by switching the injectorSpeedFactor between 4X and 7X with the weapons online toggle.

For instance, I was chased by a fer-de-lance with a lower base speed than mine, so it was losing ground both at normal speed and at full injector speed (X7). However, when I switched to X4 injector speed, it was also losing ground at more or less the same rate.

PS:
Well there's one case when the AI uses its injectors to catch up: when you're not looking :shock: . Just now, I was being chased by a pack of pirates and was looking at them, waiting for them to come in range, when a yellow dot appeared ahead on the scanner. I switch back to the forward view in order to ID it, and noticed that the chasers are closing in quickly on the scanner.
Switching back and forth views, I can see them losing ground when I'm looking at them, and catching up on the scanner as soon as I don't.

I think this behaviour could advantageously be replaced by something like (if it doesn't exist already): use injectors when about to lose the target, until the ship is in weapon range.

Post Reply