[Invalid] Interstellar links not displayed on CUSTOM_CHART_* when the ANA is not activated

For test results, bug reports, announcements of new builds etc.

Moderators: winston, another_commander, Getafix

Post Reply
User avatar
Day
---- E L I T E ----
---- E L I T E ----
Posts: 518
Joined: Tue Mar 03, 2015 11:35 am
Location: Paris

[Invalid] Interstellar links not displayed on CUSTOM_CHART_* when the ANA is not activated

Post by Day » Mon Apr 08, 2019 11:13 am

Hi everybody,

when setting a F4 mission interface with a "backgroundSpecial" property set to "CUSTOM_CHART_QUICKEST" or "CUSTOM_CHART_SHORTEST", if the ANA is not in "shortest" or "quickest" mode on the F6 screen, then the custom links are not displayed.

I'm speaking about the links set this way:

Code: Select all

SystemInfo.setInterstellarProperty(galaxyNb, from, to, 2, "link_color", color);
Oolite version: 1.89, last commit of today.

Any idea?

Day
Last edited by Day on Tue Apr 09, 2019 4:21 pm, edited 2 times in total.

User avatar
phkb
Commodore
Commodore
Posts: 2414
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Interstellar links not displayed on CUSTOM_CHART_* when the ANA is not activated

Post by phkb » Mon Apr 08, 2019 10:58 pm

I think this one is by design. Custom links aren't shown on any backgroundSpecial screen when the ANA is not in shortest or quickest mode. In fact, no links of any sort are shown if the mode is not one of those two.

Your best bet is to make sure one of those two modes is selected whenever you display a screen that needs to show links, and then revert back to the previous setting when your screen is finished.

User avatar
Day
---- E L I T E ----
---- E L I T E ----
Posts: 518
Joined: Tue Mar 03, 2015 11:35 am
Location: Paris

Re: Interstellar links not displayed on CUSTOM_CHART_* when the ANA is not activated

Post by Day » Tue Apr 09, 2019 7:48 am

phkb wrote:
Mon Apr 08, 2019 10:58 pm
I think this one is by design. Custom links aren't shown on any backgroundSpecial screen when the ANA is not in shortest or quickest mode. In fact, no links of any sort are shown if the mode is not one of those two.
Well yes, that's what I thought.

It breaks a little the immersion, when being in a F4 interface, to have to go to the F6 interface to set the ANA mode, before going back to the F4 interface.

It would be useful to be able to modify the ANA mode through javascript, or maybe simpler to set the ANA in the adequate mode depending on the requested backgroundSpecial option.

User avatar
phkb
Commodore
Commodore
Posts: 2414
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Interstellar links not displayed on CUSTOM_CHART_* when the ANA is not activated

Post by phkb » Tue Apr 09, 2019 8:24 am

I think I might have misunderstood the issue. Apologies! I'll report back shortly.

User avatar
phkb
Commodore
Commodore
Posts: 2414
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Interstellar links not displayed on CUSTOM_CHART_* when the ANA is not activated

Post by phkb » Tue Apr 09, 2019 8:37 am

OK, I just did some tests by hacking on the Galactic Registry OXP. In a brand new ship (ie with no ANA at all) and with the ANA equipment installed but set to no route mode, I got space regions to show on a custom chart. Could I trouble you for a sample OXP to demonstrate the problem you're having?

User avatar
Day
---- E L I T E ----
---- E L I T E ----
Posts: 518
Joined: Tue Mar 03, 2015 11:35 am
Location: Paris

Re: Interstellar links not displayed on CUSTOM_CHART_* when the ANA is not activated

Post by Day » Tue Apr 09, 2019 2:00 pm

Oh?
Yes, I'll prepare one :)

User avatar
Day
---- E L I T E ----
---- E L I T E ----
Posts: 518
Joined: Tue Mar 03, 2015 11:35 am
Location: Paris

Re: Interstellar links not displayed on CUSTOM_CHART_* when the ANA is not activated

Post by Day » Tue Apr 09, 2019 4:14 pm

I don't reproduce it anymore, and really don't see why.
I'm sorry to have made you lose time, phkb :oops:

The good part is that now, that part of my oxp works perfectly.

Post Reply