Warnings in Event Viewer

For test results, bug reports, announcements of new builds etc.

Moderators: winston, another_commander, Getafix

Post Reply
Chaky
Deadly
Deadly
Posts: 213
Joined: Sat Aug 15, 2009 6:15 am

Warnings in Event Viewer

Post by Chaky » Thu Nov 19, 2009 8:36 am

Every time I start up Oolite, there is a warning logged in event viewer.

This is what it says:

Code: Select all

The description for Event ID ( 0 ) in Source ( oolite ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: 2009-11-19 09:16:35.812 oolite[2672] File NSUserDefaults.m: 626. In [NSUserDefaults +standardUserDefaults] Improper installation: No language locale found.
It doesn't matter whether I try with trunks or 1.73.4.
(32bit XP)

Other than that, the game runs normally. It clogged my event logs, though.

another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5398
Joined: Wed Feb 28, 2007 7:54 am

Post by another_commander » Thu Nov 19, 2009 11:17 am

The easy solution to that is recompile the gnustep-base dll to not produce the "No language locale found message". The message is intended for complete gnustep-base installations only, whereas we knowingly distribute Oolite with a minimal GNUstep configuration. I just tried this and can confirm it works.

The harder but cleaner way would be to actually find why the message is produced and see if we can suppress or bypass it within Oolite's code instead of GNUstep's.

Chaky
Deadly
Deadly
Posts: 213
Joined: Sat Aug 15, 2009 6:15 am

Post by Chaky » Thu Nov 19, 2009 11:29 am

I've never compiled Oolite, so both ways are a blur to me.

"No language local found".. seems trivial, I must say. Only, I don't know does that mean that some language file is missing, or does it imply regional settings.

User avatar
Kaks
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 3009
Joined: Mon Jan 21, 2008 11:41 pm
Location: The Big Smoke

Post by Kaks » Thu Nov 19, 2009 11:34 am

Chaky wrote:Only, I don't know does that mean that some language file is missing, or does it imply regional settings.
It means the version of GNUStep shipped with Oolite can't figure out your regional settings.
Hey, free OXPs: farsun v1.05 & tty v0.5! :0)

another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5398
Joined: Wed Feb 28, 2007 7:54 am

Post by another_commander » Thu Nov 19, 2009 11:37 am

Chaky wrote:"No language local found".. seems trivial, I must say. Only, I don't know does that mean that some language file is missing, or does it imply regional settings.
If I understand correctly what GNUstep tries to do on startup, it looks for a specific file within a very specific and deeply nested folder structure. Other parameters might be required as well, I have not investigated in too much detail. It is actually more convoluted than it looks, but all this is not required for our intents and purposes.

Chaky
Deadly
Deadly
Posts: 213
Joined: Sat Aug 15, 2009 6:15 am

Post by Chaky » Thu Nov 19, 2009 11:39 am

One way or another, you should see my event log when I batch-OXP-verify 50 or so OXPs with 3 different versions of Oolite.

Chaky
Deadly
Deadly
Posts: 213
Joined: Sat Aug 15, 2009 6:15 am

Post by Chaky » Thu Nov 19, 2009 12:50 pm

Could this be related to SDL-originated qwertz-qwerty bug?

User avatar
Kaks
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 3009
Joined: Mon Jan 21, 2008 11:41 pm
Location: The Big Smoke

Post by Kaks » Thu Nov 19, 2009 1:30 pm

No.

SDL 1.2 explicitly ignores localisation, and it's a totally unrelated piece of software.

For the curious, the next version of SDL (1.3) is meant to work with localisation, but we just don't know when it's going to come out

And it won't depend on GNUStep either.
Last edited by Kaks on Thu Nov 19, 2009 1:32 pm, edited 1 time in total.
Hey, free OXPs: farsun v1.05 & tty v0.5! :0)

another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5398
Joined: Wed Feb 28, 2007 7:54 am

Post by another_commander » Thu Nov 19, 2009 1:31 pm

Even easier way to resolve:
Start the game with the command line switch --GNU-Debug=NoWarn.

Chaky
Deadly
Deadly
Posts: 213
Joined: Sat Aug 15, 2009 6:15 am

Post by Chaky » Fri Nov 20, 2009 11:38 am

Thanks allot AC.

I just used that command line switch in .GNUstepDefaults and the logs are not bloating any more.

This is not just "one annoyance less".

One of these days (this line is getting really old...) when I release this tool, ppl will start batch-verifying, and I don't want to be responsable for their event logs bloating with junk-reports.

Before you ask, I'll pack it with its own .GNUstepDefaults that would be switched for Oolite's one while verifying (to supress the log-popups and these event log reports).

Post Reply