[UPDATED RELEASE] Furball 1.8

Discussion and information relevant to creating special missions, new ships, skins etc.

Moderators: winston, another_commander

m4r35n357
---- E L I T E ----
---- E L I T E ----
Posts: 296
Joined: Wed Jan 19, 2011 4:00 pm

[UPDATED RELEASE] Furball 1.8

Post by m4r35n357 » Mon Jun 06, 2011 11:22 am

NEW RELEASE

Furball OXP by m4r35n357, Version 1.8

Dependencies:

* Oolite 1.77 or later
* Cabal Common Library v1.6+ or later (for random integer fuction)

Optional:
* OXPCOnfig

Changes:

Version 1.8
- Changed activation conditions, should be much rarer at higher TL systems
- Brawlers now have escape pods, and will bail out if they can ;)
- Accuracy set to 5, not yet sure how much effect this has on the way I use the AI
Last edited by m4r35n357 on Wed Feb 13, 2013 8:41 pm, edited 7 times in total.

User avatar
Fatleaf
Intergalactic Spam Assassin
Intergalactic Spam Assassin
Posts: 1988
Joined: Tue Jun 08, 2010 5:11 am
Location: In analysis mode on Phaelon
Contact:

Re: Furball

Post by Fatleaf » Mon Jun 06, 2011 12:39 pm

Thanks for releasing this updated version. Most entertaining! :D
Find out about the early influences of Fatleaf here. Also his OXP's!
Holds the Ooniversal record for "Thread Necromancy"

User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 13652
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: Furball

Post by Cody » Mon Jun 06, 2011 12:56 pm

Yes... 'most entertaining', certainly... a very good OXP.

User avatar
Staer9
---- E L I T E ----
---- E L I T E ----
Posts: 570
Joined: Fri Feb 18, 2011 4:53 pm
Location: Hatfield, Hertfordshire (poor industrial)

Re: Furball

Post by Staer9 » Mon Jun 06, 2011 3:06 pm

now to change chance to 1.0 and kill some things :twisted:

one typo in the readme, it says at the top version 1.2 but further down says 1.3, you should probably change that before someone else notices :wink:
Image

m4r35n357
---- E L I T E ----
---- E L I T E ----
Posts: 296
Joined: Wed Jan 19, 2011 4:00 pm

Re: Furball

Post by m4r35n357 » Mon Jun 06, 2011 3:23 pm

Staer9 wrote:now to change chance to 1.0 and kill some things :twisted:

one typo in the readme, it says at the top version 1.2 but further down says 1.3, you should probably change that before someone else notices :wink:
yeah that was a mistake, but the 1.3 is in the changelog, so I'm hoping no-one else notices ;)

m4r35n357
---- E L I T E ----
---- E L I T E ----
Posts: 296
Joined: Wed Jan 19, 2011 4:00 pm

Re: Furball

Post by m4r35n357 » Mon Jul 11, 2011 7:52 pm

New version 1.4

Changes:
- tweak activation probabilities (re. gov type)
- slash bounties

http://www.box.net/shared/zljfisgtmit0ngyqu05h

User avatar
Oathbreaker
Dangerous
Dangerous
Posts: 85
Joined: Sun Jul 10, 2011 4:37 am
Location: San Diego, CA
Contact:

Re: Furball (updated to 1.4)

Post by Oathbreaker » Mon Jul 11, 2011 8:40 pm

Does Furball still need the Cabal Common Library?

And are the prior wiki instructions for setting the "Chance to Furball" still valid? I like my random crazy events to be fairly notable, i.e. very uncommon...

m4r35n357
---- E L I T E ----
---- E L I T E ----
Posts: 296
Joined: Wed Jan 19, 2011 4:00 pm

Re: Furball (updated to 1.4)

Post by m4r35n357 » Mon Jul 11, 2011 9:17 pm

Oathbreaker wrote:Does Furball still need the Cabal Common Library?
Yes, it uses the real-valued random number generator
Oathbreaker wrote:And are the prior wiki instructions for setting the "Chance to Furball" still valid? I like my random crazy events to be fairly notable, i.e. very uncommon...
No, not any more, but I think it's easy to change if you are used to modifying the original versions. If you look in the this.$active function in Config/script.js, you will see a probability assigned to each government type, so you can either change it at that granularity, or just rewrite the this.$active function to return a single global probability, depending on your skillz level.

BTW since updating the activation method I've realised the probability code is "backwards", this is a historical thing and I will change it to make more sense in the next release

User avatar
Oathbreaker
Dangerous
Dangerous
Posts: 85
Joined: Sun Jul 10, 2011 4:37 am
Location: San Diego, CA
Contact:

Re: Furball (updated to 1.4)

Post by Oathbreaker » Thu Jul 21, 2011 4:17 am

I'm really loving this addon. As a newbie it's nice to be able to 'get some' right next to the station.

Problem though: on my 5-year-old iMac (with 4GB Ram) I'm seeing some serious FPS lag during furballs. Zooming in the radar may help, but honestly I'm guessing it's the graphics I've got going on with all of Griff's fancy paintjobs and updated models.

Gonna try Neolite to see if there's a positive difference, if not I might just go back to stock models since Furballs > eyecandy imo.

User avatar
Gimi
Intergalactic Spam Assassin
Intergalactic Spam Assassin
Posts: 2073
Joined: Tue Aug 29, 2006 5:02 pm
Location: Norway

Re: Furball (updated to 1.4)

Post by Gimi » Thu Jul 21, 2011 6:27 am

Oathbreaker wrote:I'm really loving this addon. As a newbie it's nice to be able to 'get some' right next to the station.
Problem though: on my 5-year-old iMac (with 4GB Ram) I'm seeing some serious FPS lag during furballs. Zooming in the radar may help, but honestly I'm guessing it's the graphics I've got going on with all of Griff's fancy paintjobs and updated models.
Gonna try Neolite to see if there's a positive difference, if not I might just go back to stock models since Furballs > eyecandy imo.
I play on a laptop with all the Griff bells and whistles. Now, if I need to play on battery (On a train ride for example) I have a quick change to a Smivs Ooniverse ready. Much easier on resources and so on. Totally different look, clean and sharp, but worth a look if your computer struggles with Griffs.
"A brilliant game of blasting and trading... Truly a mega-game... The game of a lifetime."
(Gold Medal Award, Zzap!64 May 1985).

m4r35n357
---- E L I T E ----
---- E L I T E ----
Posts: 296
Joined: Wed Jan 19, 2011 4:00 pm

Re: Furball (updated to 1.4)

Post by m4r35n357 » Thu Jul 21, 2011 8:59 am

Gimi wrote: I play on a laptop with all the Griff bells and whistles. Now, if I need to play on battery (On a train ride for example) I have a quick change to a Smivs Ooniverse ready. Much easier on resources and so on. Totally different look, clean and sharp, but worth a look if your computer struggles with Griffs.
Good point Gimi. I run Oolite and develop my OXPs on a 1.6GHz Atom 230 PC, so I would consider this the "minimum requirement" for my multi-ship OXPs. I also use Smivs' ships, and my frame rates are 20-25 in relatively clear space.

User avatar
Capt. Murphy
Commodore
Commodore
Posts: 1127
Joined: Fri Feb 25, 2011 8:46 am
Location: UK South Coast.

Re: Furball (updated to 1.4)

Post by Capt. Murphy » Fri Nov 18, 2011 10:04 pm

Updated Furball's wiki page with link to download version 1.4.
[EliteWiki] Capt. Murphy's OXPs
External JavaScript resources - W3Schools & Mozilla Developer Network
Win 7 64bit, Intel Core i5 with HD3000 (driver rev. 8.15.10.2696 - March 2012), Oolite 1.76.1

m4r35n357
---- E L I T E ----
---- E L I T E ----
Posts: 296
Joined: Wed Jan 19, 2011 4:00 pm

Re: [UPDATED RELEASE] Furball 1.5

Post by m4r35n357 » Tue Dec 20, 2011 9:40 am

Update, bumping thread to top . . .

User avatar
snork
---- E L I T E ----
---- E L I T E ----
Posts: 551
Joined: Sat Jan 30, 2010 4:21 am
Location: northern Germany

Re: [UPDATED RELEASE] Furball 1.5

Post by snork » Wed Jan 25, 2012 3:52 pm

hej,

all of the d/l links on the wiki other than for Caracal's version 1.0.1 (for Oolite 1.74.1) are dead.

So, is there anything wrong with that version 1.0.1 combined with Oolite 1.76 ?
If so, would someone have an alternative d/l link for a Oolite 1.76 compatible version, please ?

User avatar
Eric Walch
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
Posts: 5536
Joined: Sat Jun 16, 2007 3:48 pm
Location: Netherlands

Re: [UPDATED RELEASE] Furball 1.5

Post by Eric Walch » Wed Jan 25, 2012 5:02 pm

snork wrote:hej,

all of the d/l links on the wiki other than for Caracal's version 1.0.1 (for Oolite 1.74.1) are dead.
I think they are dead because they were replaced witch newer versions. The highest on the wiki was 1.4 but the current version is 1.5. (link was in the first page of this topic.) Updated the wiki page now with the correct link.

Post Reply