[Wip] No shaders extra and alternative ships...

Discussion and information relevant to creating special missions, new ships, skins etc.

Moderators: winston, another_commander

User avatar
Norby
---- E L I T E ----
---- E L I T E ----
Posts: 2544
Joined: Mon May 20, 2013 9:53 pm
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Contact:

Re: [Wip] No shaders extra and alternative ships...

Post by Norby » Sat Dec 12, 2015 1:42 am

phkb wrote:I just purchased a Chopped Cobra, standard customer model, and ended up with an "Aft Pulse laser", and no front laser at all. So it appears to apply to the player as well.
True, but sounds like a bug due to in this case this entry in shipyard.plist is useless.

User avatar
Amah
---- E L I T E ----
---- E L I T E ----
Posts: 485
Joined: Tue Aug 28, 2012 8:05 pm
Location: aboard the Laenina Crowne - Yasen-N class space freighter
Contact:

Re: [Wip] No shaders extra and alternative ships...

Post by Amah » Sat Dec 12, 2015 9:11 am

I'll plan to change stear9's subent gun to be a mere cosmetics and set the lasertype and laser position in the main shipdata definition. I think it should fix these annomalies and make tings for you easier concerning the ship comparison.

About the cargo space... I'm up to suggestions, should the chopped cobra (3.5) have a cargo extension at all?

Aegidian's cobra 3.5 hasn't... [18t]
Staer9 has... [18t +15t]
Smivs's S9 hasn't.. [15t].
Amah

User avatar
Amah
---- E L I T E ----
---- E L I T E ----
Posts: 485
Joined: Tue Aug 28, 2012 8:05 pm
Location: aboard the Laenina Crowne - Yasen-N class space freighter
Contact:

Re: [Wip] No shaders extra and alternative ships...

Post by Amah » Sun Dec 13, 2015 8:40 am

update and hopefully fixed the front laser problem with the Staer9 chopped cobra.

have fun

Amah
Amah

tenorman1971
Above Average
Above Average
Posts: 25
Joined: Wed May 04, 2011 5:32 pm
Location: Newark-on-Trent, UK - Poor Agricultural Anarchy

Re: August/September releases

Post by tenorman1971 » Thu Jan 07, 2016 5:26 pm

Amah wrote:Hi folks,

had some trouble accessing the site, due to some geo blocking so here's a late release announcement for the noshader version of Staer9's shipset. It should be more and less in sync with Spara's take on the shadered original Staer9's shipset. As you can read in the posts above the diffuse textures were combined so they look nice even on machines without powerful graphics hardware with shaders. And again, sorry for the long delay with the Cat and Ghavial...

Staer9/Smivs S9 [EliteWiki] Chopped Cobra is now also available in the ingame expansion manager. Shipdata was cleaned, it was rebalanced with Spara's help, and I worked a bit on the diffuse and emission textures and gave the cobra some small funky extra exhaust trails like Griffs's alternate Cobra3. ;-)

So, here's two of the now more than twenty different models flying now out in the Ooniverse:
ImageImage


Both the Staer9 Shipset and his Chopped Cobra are available as OXZ at the ingame expansion manager.If you find bugs and have suggestion just let me know.

hope you like it, have fun
Amah
When I updated fairly recently to v.1.82 I downloaded the new OXZ version of Chopped Cobra/S9 as I'd been flying an S9 for some time. However, if I take the original OXP out it just says OXP missing, and doesn't seem to recognise the ship I'm flying as being part of the OXZ version.

User avatar
Amah
---- E L I T E ----
---- E L I T E ----
Posts: 485
Joined: Tue Aug 28, 2012 8:05 pm
Location: aboard the Laenina Crowne - Yasen-N class space freighter
Contact:

Re: [Wip] No shaders extra and alternative ships...

Post by Amah » Thu Jan 07, 2016 6:25 pm

Old save game? I was adding a prefix to avoid clashes with the original chopped cobra and wasn't assuming anyone would use the oxz as an drop-in replacement for the oxp. Don't know what I was thinking.

Hmmh, you could try the follwoing. Could you add the follwoing lines to your "shipdata.plist":

Code: Select all

"cobra-S9-mercenary-player" =
	{
         like_ship="noshaders_Smivs_Cobra-S9-mercenary-player";
	}
... in the config folder of the oxz?

alternatively you could open your savegame in an editor and look for "cobra-S9-mercenary-player" and replace it with "noshaders_Smivs_Cobra-S9-mercenary-player"

Oh, and do a backup of the files first.
Amah

tenorman1971
Above Average
Above Average
Posts: 25
Joined: Wed May 04, 2011 5:32 pm
Location: Newark-on-Trent, UK - Poor Agricultural Anarchy

Re: [Wip] No shaders extra and alternative ships...

Post by tenorman1971 » Fri Jan 08, 2016 9:50 am

I'll give it a go - silly newbie question, but where do I find the config folders for the OXZ? I know where the old OXP files go, but since I use the in-game expansion manager I have no idea where they are now.

tenorman1971
Above Average
Above Average
Posts: 25
Joined: Wed May 04, 2011 5:32 pm
Location: Newark-on-Trent, UK - Poor Agricultural Anarchy

Re: [Wip] No shaders extra and alternative ships...

Post by tenorman1971 » Fri Jan 08, 2016 9:55 am

Don't worry - a second's thinking found them for me!

User avatar
Amah
---- E L I T E ----
---- E L I T E ----
Posts: 485
Joined: Tue Aug 28, 2012 8:05 pm
Location: aboard the Laenina Crowne - Yasen-N class space freighter
Contact:

Re: [Wip] No shaders extra and alternative ships...

Post by Amah » Fri Jan 08, 2016 10:08 pm

Say, a word if you run into problems.
Amah

tenorman1971
Above Average
Above Average
Posts: 25
Joined: Wed May 04, 2011 5:32 pm
Location: Newark-on-Trent, UK - Poor Agricultural Anarchy

Re: [Wip] No shaders extra and alternative ships...

Post by tenorman1971 » Sat Jan 09, 2016 3:59 pm

Didn't have any luck with adding the line to the shipdata.plist file, but changing the ship name in the save game file worked.

Cheers

Mikael
Poor
Poor
Posts: 7
Joined: Sat Jan 23, 2016 1:28 pm

Re: [Wip] No shaders extra and alternative ships...

Post by Mikael » Thu Jan 28, 2016 4:45 pm

Sorry for this but I'm having a problem with the extra stations addon:

Code: Select all

17:32:34.840 [plist.parse.failed]: Failed to parse /Users/mikael/Library/Application Support/Oolite/Managed AddOns/oolite.oxp.amah.noshaders_extra_stations_addon.oxz/Config/shipdata.plist as a property list.
Unexpected character { at line 1
17:32:36.934 [universe.setup.badStation]: Failed to set up a ship for role "coriolis" as system station, trying again with "(null)".
17:32:36.934 [universe.setup.badStation]: On retry, failed to set up a ship for role "(null)" as system station. Trying to fall back to built-in Coriolis station.
17:32:37.142 [universe.setup.badStation]: Could not create built-in Coriolis station! Generating a stationless system.
It's 1.82 on a Mac.

User avatar
Amah
---- E L I T E ----
---- E L I T E ----
Posts: 485
Joined: Tue Aug 28, 2012 8:05 pm
Location: aboard the Laenina Crowne - Yasen-N class space freighter
Contact:

Re: [Wip] No shaders extra and alternative ships...

Post by Amah » Thu Jan 28, 2016 9:23 pm

I'll see to it. Thanks for the bug report and info on the system you are running. I think it could be something similar to the problems with the Yasen and Lira.
Amah

Mikael
Poor
Poor
Posts: 7
Joined: Sat Jan 23, 2016 1:28 pm

Re: [Wip] No shaders extra and alternative ships...

Post by Mikael » Fri Jan 29, 2016 3:55 pm

Thanks for looking into this :)

You also mention the Yasen and the Lira - I didn't know there were any problems with them, for me at least they have worked without any issues.

User avatar
Amah
---- E L I T E ----
---- E L I T E ----
Posts: 485
Joined: Tue Aug 28, 2012 8:05 pm
Location: aboard the Laenina Crowne - Yasen-N class space freighter
Contact:

Re: [Wip] No shaders extra and alternative ships...

Post by Amah » Wed Feb 03, 2016 5:42 am

Hej Mikael,

I've not forgotten, but was just a bit sick. I'm now sifting through the shipdata.plist to find the culprit. a missing ";" to make the Mac happy. It's a bit troublesome to find because on my Linux machine I won't get any errors.

hang on,
Amah

User avatar
Svengali
---- E L I T E ----
---- E L I T E ----
Posts: 2365
Joined: Sat Oct 20, 2007 2:52 pm

Re: [Wip] No shaders extra and alternative ships...

Post by Svengali » Wed Feb 03, 2016 12:57 pm

Amah wrote:I've not forgotten, but was just a bit sick. I'm now sifting through the shipdata.plist to find the culprit. a missing ";" to make the Mac happy. It's a bit troublesome to find because on my Linux machine I won't get any errors.
Doesn't this kind of stuff gets catched by Oolites verifier?

Mikael
Poor
Poor
Posts: 7
Joined: Sat Jan 23, 2016 1:28 pm

Re: [Wip] No shaders extra and alternative ships...

Post by Mikael » Wed Feb 03, 2016 6:12 pm

@Amah: That's quite all right :) Let me know if I can help testing once you have a fix ready.

Post Reply