Please update OXPs for 1.80

Discussion and information relevant to creating special missions, new ships, skins etc.

Moderators: winston, another_commander

Post Reply
User avatar
harry747
Deadly
Deadly
Posts: 135
Joined: Mon Feb 23, 2009 8:57 pm
Location: England

Please update OXPs for 1.80

Post by harry747 » Sun Nov 16, 2014 3:24 pm

In an older version I used the following OXPs, but they are not available for 1.80
- supercobra
- deep space dredger

Any chance to get them updated so they are compatible with 1.80?

Also, i'd like to try out the AI trading assistant, but the current version (2.13) is also "incompatible with this version." any chance to get that fixed?
MacBook pro, OSX 10.8.5, Xcode 5

User avatar
Lone_Wolf
---- E L I T E ----
---- E L I T E ----
Posts: 545
Joined: Wed Aug 08, 2007 10:59 pm
Location: Netherlands

Re: Please update OXPs for 1.80

Post by Lone_Wolf » Sun Nov 16, 2014 3:59 pm

Supercobra is compatible with 1.80, you just have to install it manually in the Addons folder (as was normal for ALL oxps before the OXZ manager was introduced).

I don't know deep space dredeger, but there's a big chance it's the same for that one.
OS : Arch Linux 64-bit - rolling release

OXPs : My user page

I am subscribed to the threads for my oxps, if you need my attention just post in them or send a pm.

User avatar
Wildeblood
---- E L I T E ----
---- E L I T E ----
Posts: 2161
Joined: Sat Jun 11, 2011 6:07 am
Location: Western Australia
Contact:

Re: Please update OXPs for 1.80

Post by Wildeblood » Mon Nov 17, 2014 8:00 am

harry747 wrote:Also, i'd like to try out the AI trading assistant, but the current version (2.13) is also "incompatible with this version." any chance to get that fixed?
It definitely isn't. I think you've got Market Observer and the message you're seeing is that AI Trading Assistant is incompatible with an already installed OXZ, yes?

Potential Debris
Dangerous
Dangerous
Posts: 75
Joined: Tue Apr 19, 2011 10:42 am
Location: UK

Re: Please update OXPs for 1.80

Post by Potential Debris » Mon Nov 17, 2014 10:50 am

Deep space dredger works under 1.80, I have sold several wrecks to dredgers since upgrading.

User avatar
harry747
Deadly
Deadly
Posts: 135
Joined: Mon Feb 23, 2009 8:57 pm
Location: England

Re: Please update OXPs for 1.80

Post by harry747 » Mon Nov 17, 2014 12:47 pm

Wildeblood wrote: It definitely isn't. I think you've got Market Observer and the message you're seeing is that AI Trading Assistant is incompatible with an already installed OXZ, yes?
i think i also got the incompatibility message before i installed market observer. but i'll check it out…
edit: yep, i removed the market observer, and i still get the incompatibility message :-(

and the other 2… just drag them into the add-ons folder, right?
MacBook pro, OSX 10.8.5, Xcode 5

User avatar
Eric Walch
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
Posts: 5536
Joined: Sat Jun 16, 2007 3:48 pm
Location: Netherlands

Re: Please update OXPs for 1.80

Post by Eric Walch » Mon Nov 17, 2014 11:17 pm

Both should be compatible with 1.80, otherwise I had update them before 1.80 release. I think I created the current version for both.

Deep Space Dredgers is on my list to create an updated version with the new subentitie definitions as it throws warnings in current trunk.
There are also a few others that throw warnings that I plan to update. At the moment I updated Military Fiasco, but have not uploaded it yet.

User avatar
Wildeblood
---- E L I T E ----
---- E L I T E ----
Posts: 2161
Joined: Sat Jun 11, 2011 6:07 am
Location: Western Australia
Contact:

Re: Please update OXPs for 1.80

Post by Wildeblood » Tue Nov 18, 2014 1:41 am

harry747 wrote:
Wildeblood wrote:It definitely isn't. I think you've got Market Observer and the message you're seeing is that AI Trading Assistant is incompatible with an already installed OXZ, yes?
i think i also got the incompatibility message before i installed market observer. but i'll check it out…
edit: yep, i removed the market observer, and i still get the incompatibility message :-(
You're talking about Oolite 1.80, not trunk 1.81, yes?

You're looking at the main Trading Assistant OXZ, not one of the plug-ins, Purchase Book or Turbotrader?

Remove Market Observer, leave the OXZ manager so Oolite re-compiles its OXZ cache, go back to the OXZ manager and you should be able to download Trading Assistant. If not, some other OXZ is blocking it, and I've no idea which it would be or why. Possibly Commodity Markets or SellAll?

Post Reply