Page 1 of 1

Please update OXPs for 1.80

Posted: Sun Nov 16, 2014 3:24 pm
by harry747
In an older version I used the following OXPs, but they are not available for 1.80
- supercobra
- deep space dredger

Any chance to get them updated so they are compatible with 1.80?

Also, i'd like to try out the AI trading assistant, but the current version (2.13) is also "incompatible with this version." any chance to get that fixed?

Re: Please update OXPs for 1.80

Posted: Sun Nov 16, 2014 3:59 pm
by Lone_Wolf
Supercobra is compatible with 1.80, you just have to install it manually in the Addons folder (as was normal for ALL oxps before the OXZ manager was introduced).

I don't know deep space dredeger, but there's a big chance it's the same for that one.

Re: Please update OXPs for 1.80

Posted: Mon Nov 17, 2014 8:00 am
by Wildeblood
harry747 wrote:Also, i'd like to try out the AI trading assistant, but the current version (2.13) is also "incompatible with this version." any chance to get that fixed?
It definitely isn't. I think you've got Market Observer and the message you're seeing is that AI Trading Assistant is incompatible with an already installed OXZ, yes?

Re: Please update OXPs for 1.80

Posted: Mon Nov 17, 2014 10:50 am
by Potential Debris
Deep space dredger works under 1.80, I have sold several wrecks to dredgers since upgrading.

Re: Please update OXPs for 1.80

Posted: Mon Nov 17, 2014 12:47 pm
by harry747
Wildeblood wrote: It definitely isn't. I think you've got Market Observer and the message you're seeing is that AI Trading Assistant is incompatible with an already installed OXZ, yes?
i think i also got the incompatibility message before i installed market observer. but i'll check it out…
edit: yep, i removed the market observer, and i still get the incompatibility message :-(

and the other 2… just drag them into the add-ons folder, right?

Re: Please update OXPs for 1.80

Posted: Mon Nov 17, 2014 11:17 pm
by Eric Walch
Both should be compatible with 1.80, otherwise I had update them before 1.80 release. I think I created the current version for both.

Deep Space Dredgers is on my list to create an updated version with the new subentitie definitions as it throws warnings in current trunk.
There are also a few others that throw warnings that I plan to update. At the moment I updated Military Fiasco, but have not uploaded it yet.

Re: Please update OXPs for 1.80

Posted: Tue Nov 18, 2014 1:41 am
by Wildeblood
harry747 wrote:
Wildeblood wrote:It definitely isn't. I think you've got Market Observer and the message you're seeing is that AI Trading Assistant is incompatible with an already installed OXZ, yes?
i think i also got the incompatibility message before i installed market observer. but i'll check it out…
edit: yep, i removed the market observer, and i still get the incompatibility message :-(
You're talking about Oolite 1.80, not trunk 1.81, yes?

You're looking at the main Trading Assistant OXZ, not one of the plug-ins, Purchase Book or Turbotrader?

Remove Market Observer, leave the OXZ manager so Oolite re-compiles its OXZ cache, go back to the OXZ manager and you should be able to download Trading Assistant. If not, some other OXZ is blocking it, and I've no idea which it would be or why. Possibly Commodity Markets or SellAll?