Page 9 of 12

Re: Xenon UI OXP

Posted: Thu Nov 17, 2016 9:26 pm
by phkb
Hmm, that's odd. I'll check it out.

Re: Xenon UI OXP

Posted: Fri Nov 18, 2016 1:34 am
by phkb
Double "Hmm". I've tried to reproduce this but can't seem to find the right connections. I've tried with and without Svengali's Library OXP and BGS 2.0, but each time I get the right background on the details page. What OXP's are you running in this setup?

Re: Xenon UI OXP

Posted: Fri Nov 18, 2016 9:59 am
by Cody
Hmm, indeed!

Upon further testing, it only appears to be missing on one particular save - my main commander, which was fine the night before.
Very strange! <scratches head> The problem must be at my end, so I'll have a tinker - the only change was the new nightly.

My apologies for bothering you.

Re: Xenon UI OXP

Posted: Fri Nov 18, 2016 3:10 pm
by Cody
For the record, if I remove BGS 2.0 and keep Library 1.1, the problem disappears (perhaps unsurprisingly).

Edit to add: correction, it seems to affect all saves.

Re: Xenon UI OXP

Posted: Fri Nov 18, 2016 10:11 pm
by phkb
Ah, that helps. I'll give that a try.

Re: Xenon UI OXP

Posted: Tue Nov 22, 2016 10:20 am
by Svengali
@Cody: What happens if you switch to BGS (through Lib_Config, with Xenon and BGS installed)?

Re: Xenon UI OXP

Posted: Tue Nov 22, 2016 10:41 am
by Cody
If I switch to BGS, all is good.

Re: Xenon UI OXP

Posted: Wed Nov 23, 2016 2:05 am
by phkb
@Cody: I'm really sorry, but I can't reproduce your symptoms at my end. I've tried every combination I can think of, but no matter what I get the Xenon background on the parcel details page. The only way I can think this might be happening is if BGS ends up being loaded after Xenon UI Redux. In that scenario, the "lib_black.png" that BGS applies to the "long_range_chart_mission" and "short_range_chart_mission" settings via the screenbackground.plist file could take precedence over Xenon's entries for the same. One question: is Xenon UI Redux in the ManagedAddons folder, and BGS 2.0 in you Addons folder? If so, try moving Xenon UI Redux to the Addons and see if that helps.

Re: Xenon UI OXP

Posted: Wed Nov 23, 2016 2:15 am
by Cody
phkb wrote:I've tried every combination I can think of...
You and me both! <grins> Thanks for trying. I'll be doing a clean re-install of just about everything soon - perhaps that'll kick it into shape.

Re: Xenon UI OXP

Posted: Wed Nov 23, 2016 2:50 am
by phkb
So is Xenon UI Redux in ManagedAddons? Did you try moving it to Addons?

Re: Xenon UI OXP

Posted: Wed Nov 23, 2016 12:08 pm
by Cody
I've tried it every which way. What has me scratching my head is the fact that it was fine one day, then the next day it wasn't.
As I said, a full re-install (which includes Windows) is on the to-do list. I'll not start tinkering again 'til that's all done.

Re: Xenon UI OXP

Posted: Sun Nov 27, 2016 4:27 pm
by Cody
Cody wrote: ...perhaps that'll kick it into shape.
A clean install of Win7, trunk nightly, and relevant OXPs, has done the trick - all is well again. For the record: BGS, Library, and Xenon Redux (UI and Resources) are currently in the AddOns folder, which is where they were yesterday when I still had the problem. <scratches head>

I'll leave them where they are for the time being, as I don't wish to tempt fate.

Re: Xenon UI OXP

Posted: Tue Dec 06, 2016 10:05 am
by Svengali
Just as reminder. AddOns developers can't rely on loading order nor execution order of scripts. The may differ from system to system and specially the execution order may vary.

Re: Xenon UI OXP

Posted: Thu Feb 16, 2017 1:15 am
by phkb
A small update to version 2.0.2: a new title screen background, plus a fix for an issue when being used with Library GUI. The F5 Cmdr Profile and F5F5 Manifest screens were showing in the wrong order.

Re: [WIP] Bulletin Board system

Posted: Mon Mar 13, 2017 1:40 am
by Cody
phkb wrote:
Sun Mar 12, 2017 9:40 pm
If the issue persists, I really will be stumped!
Howzat!


I tried the ordinary Xenon UI instead, and apart from it being too wide, there was no issue with the background.