[WIP] GalCop Missions

Discussion and information relevant to creating special missions, new ships, skins etc.

Moderators: another_commander, winston

User avatar
Milo
---- E L I T E ----
---- E L I T E ----
Posts: 361
Joined: Mon Sep 17, 2018 5:01 pm

Re: [WIP] GalCop Missions

Post by Milo »

Mission briefing for a "Destroy satellites" mission type:

... The lives of some of our undefined hang in the balance, because some operational material has been captured by surveillance and communication satellites ...
User avatar
phkb
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 2856
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: [WIP] GalCop Missions

Post by phkb »

Milo wrote: Tue Jul 07, 2020 8:27 am is that specifically the thargoid type named warship?
Yes, as distinct from any other OXP-added Thargoid ship (although, so long as the OXP-added Thargoid vessel returns true for the "isThargoid" property and doesn't have the roles "tharglet", "thargon" or "EQ_THARGON" then it should still count)
User avatar
phkb
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 2856
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: [WIP] GalCop Missions

Post by phkb »

Milo wrote: Tue Jul 07, 2020 8:49 am After completing a slave repatriation mission that required purchasing slaves from the market and turning them in through the bulletin board interface, the Market Observer OXP did not detect the removal of the slaves so it still shows ##x (the purchase price) on the F8 screen.
This one is true for any OXP that fiddles with the manifest. I've got some code from another OXP I can apply here - I'll try to get it into the next release.
User avatar
Cholmondely
Wiki Wizard
Wiki Wizard
Posts: 1161
Joined: Tue Jul 07, 2020 11:00 am
Location: The Delightful Domains of Her Most Britannic Majesty
Contact:

Re: [WIP] GalCop Missions

Post by Cholmondely »

phkb wrote: Wed Jul 08, 2020 4:44 am
Milo wrote: Tue Jul 07, 2020 8:49 am After completing a slave repatriation mission that required purchasing slaves from the market and turning them in through the bulletin board interface, the Market Observer OXP did not detect the removal of the slaves so it still shows ##x (the purchase price) on the F8 screen.
This one is true for any OXP that fiddles with the manifest. I've got some code from another OXP I can apply here - I'll try to get it into the next release.
Thank you so much for taking the time and care to put this together! It does help make one feel that there is life going on elsewhere in the Galaxy!

1) I've found that when I ransom slaves, so to speak, the mission never completes, no matter what I do. Am I missing something obvious?

2) the continual amnesty offers for joining the Galactic Navy's behemoth several systems away - is this .oxp the source?
Denizen of the Dark and Dismal Deserts of Digebiti.

Milo wrote Dancing the Gavotte
User avatar
phkb
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 2856
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: [WIP] GalCop Missions

Post by phkb »

Re point 2: no, not this OXP. Might be Anarchies or Illegal Goods Tweak.

Re point 1: hmm that seems odd. I’ll do some tests and report back.
User avatar
Cholmondely
Wiki Wizard
Wiki Wizard
Posts: 1161
Joined: Tue Jul 07, 2020 11:00 am
Location: The Delightful Domains of Her Most Britannic Majesty
Contact:

Re: [WIP] GalCop Missions

Post by Cholmondely »

phkb wrote: Sat Feb 06, 2021 7:18 am Re point 2: no, not this OXP. Might be Anarchies or Illegal Goods Tweak.

Re point 1: hmm that seems odd. I’ll do some tests and report back.
Might it be an apple syntax issue?
Denizen of the Dark and Dismal Deserts of Digebiti.

Milo wrote Dancing the Gavotte
User avatar
phkb
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 2856
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: [WIP] GalCop Missions

Post by phkb »

Cholmondely wrote: Sat Feb 06, 2021 10:30 pm Might it be an apple syntax issue?
No, it was a pure bug, which I've now fixed. Although, as I can't upload it to the wiki, you'll have to manually install it from my Box account.

v0.6.2 available here in two formats:
GalCopMissions.oxz (which can be dropped directly into your AddOns folder)
GalCopMissions.zip (which will need the "GalCopMissions.oxp" folder to be extracted from the zip to the AddOns folder)

Once the wiki allows for >2mb uploads, I'll publish the changes to the download manager.
User avatar
Cholmondely
Wiki Wizard
Wiki Wizard
Posts: 1161
Joined: Tue Jul 07, 2020 11:00 am
Location: The Delightful Domains of Her Most Britannic Majesty
Contact:

Re: [WIP] GalCop Missions

Post by Cholmondely »

phkb wrote: Sun Feb 07, 2021 2:07 am
Cholmondely wrote: Sat Feb 06, 2021 10:30 pm Might it be an apple syntax issue?
No, it was a pure bug, which I've now fixed. Although, as I can't upload it to the wiki, you'll have to manually install it from my Box account.

v0.6.2 available here in two formats:
GalCopMissions.oxz (which can be dropped directly into your AddOns folder)
GalCopMissions.zip (which will need the "GalCopMissions.oxp" folder to be extracted from the zip to the AddOns folder)

Once the wiki allows for >2mb uploads, I'll publish the changes to the download manager.
Thank you, Sir!
Denizen of the Dark and Dismal Deserts of Digebiti.

Milo wrote Dancing the Gavotte
User avatar
phkb
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 2856
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: [WIP] GalCop Missions

Post by phkb »

Version 0.6.3 has been released. In this version, [EliteWiki] GNN has been made a requirement for the OXP, to reduce code duplication and OXP size.
applicant_255
Poor
Poor
Posts: 7
Joined: Fri May 07, 2021 8:34 pm

Re: [WIP] GalCop Missions

Post by applicant_255 »

Any way to get the previous version? I hit the button to update packages, and I'm running on a Raspberry PI, and the latest version available is only 1.84, and GNN requires 1.86, so Galcop Missions updated, then wouldn't load and gives a rather cryptic error "needed for the randomisation of text" that I found wants me to install GNN, but doesn't let met because of the version, so performs a noop and requests I install the needed again.

I did try to compile the latest version of oolite from source, but got stuck as a lot of people seem to on compiling the Firefox 4 derived spidermonkey dependancy. There was a gentoo patch that might fix the issue, but that's been removed from their site, and a different required patch to replace the ASM code I had to comment out to get the CPU string is also gone.

I also tried getting the previous version from history in the wiki, but it seems both downloads to the zip and oxp file just point to the most recent version.
User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 14502
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: [WIP] GalCop Missions

Post by Cody »

applicant_255 wrote: Fri May 07, 2021 8:44 pmI'm running on a Raspberry PI, and the latest version available is only 1.84, and GNN requires 1.86
If I understand you right, you can get the latest version of Oolite here. It's a self-contained package, but whether it works on a Raspberry Pi, I know not.

And welcome aboard!
Who was it that set up a system, a supposedly democratic system
Where you end up always voting for the lesser of two evils?
applicant_255
Poor
Poor
Posts: 7
Joined: Fri May 07, 2021 8:34 pm

Re: [WIP] GalCop Missions

Post by applicant_255 »

Cody wrote: Fri May 07, 2021 9:56 pm
applicant_255 wrote: Fri May 07, 2021 8:44 pmI'm running on a Raspberry PI, and the latest version available is only 1.84, and GNN requires 1.86
If I understand you right, you can get the latest version of Oolite here. It's a self-contained package, but whether it works on a Raspberry Pi, I know not.

And welcome aboard!
Thanks, but sadly no, those are for x86 systems, I'm using a Raspberry Pi 4 4GB, which uses an ARMv7 processor, the builds there are for linux x86 and x86_64. I did try to compile from source, but to get it to build a the package there are two rather complex problems that need to be solved for ARM to get the javascript engine to compile and link so that I can start to actually try debugging the finished program - even if I got that problem solved, it's unlikely the finished binary would run and work the way you'd expect it to on an x86 system.

The repos for Raspberry PI OS have a working copy of oolite, but only 1.84b2 from 2017:
  • Maintainer: Nicolas Boulenguez <nicolas@debian.org>
    Architecture: armhf
    Source: oolite (1.84-2)
    Version: 1.84-2+b2
I've spent about ten or fifteen hours these past few days working on getting it to compile, but come to the conclusion that it'd be easier just to fix the OXPs instead to work with 1.84, maybe strip out the requirements for GNN so that it enough runs under 1.84 to satisfy the requirement to generate text for this OXP, but then looking at the version history the only thing that has changed with GalCop Missions is the refactor to use GNN instead of the old code that worked with 1.84.

Honestly if I put a price on my own time invested I'd probably be better off just buying a state of the bottom of the barrel art x86 machine just to run oolite, but I'm a weird intersection of lazy, curious and stubborn that often prevents me from doing a practical thing when a highly impractical alternative is difficult but not impossible.
User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 14502
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: [WIP] GalCop Missions

Post by Cody »

Aye well... I kinda thought that'd be the way of it. It's good to know there's an Oolite for Arm/Pi though.
Who was it that set up a system, a supposedly democratic system
Where you end up always voting for the lesser of two evils?
User avatar
Cholmondely
Wiki Wizard
Wiki Wizard
Posts: 1161
Joined: Tue Jul 07, 2020 11:00 am
Location: The Delightful Domains of Her Most Britannic Majesty
Contact:

Re: [WIP] GalCop Missions

Post by Cholmondely »

applicant_255 wrote: Fri May 07, 2021 11:26 pm ... sadly no, those are for x86 systems, I'm using a Raspberry Pi 4 4GB, which uses an ARMv7 processor, the builds there are for linux x86 and x86_64. I did try to compile from source, but to get it to build a the package there are two rather complex problems that need to be solved for ARM to get the javascript engine to compile and link so that I can start to actually try debugging the finished program - even if I got that problem solved, it's unlikely the finished binary would run and work the way you'd expect it to on an x86 system.

The repos for Raspberry PI OS have a working copy of oolite, but only 1.84b2 from 2017:
  • Maintainer: Nicolas Boulenguez <nicolas@debian.org>
    Architecture: armhf
    Source: oolite (1.84-2)
    Version: 1.84-2+b2
I've spent about ten or fifteen hours these past few days working on getting it to compile, but come to the conclusion that it'd be easier just to fix the OXPs instead to work with 1.84, maybe strip out the requirements for GNN so that it enough runs under 1.84 to satisfy the requirement to generate text for this OXP, but then looking at the version history the only thing that has changed with GalCop Missions is the refactor to use GNN instead of the old code that worked with 1.84.
Gosh! Impressed!

Links to older versions are here: http://wiki.alioth.net/index.php/Oolite - see bottom of the page (also has links to some older OXPs).

And welcome to the motley crew! Enjoy!
... but I'm a weird intersection of lazy, curious and stubborn that often prevents me from doing a practical thing when a highly impractical alternative is difficult but not impossible.
Huumph! Join the club!
Denizen of the Dark and Dismal Deserts of Digebiti.

Milo wrote Dancing the Gavotte
another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5884
Joined: Wed Feb 28, 2007 7:54 am

Re: [WIP] GalCop Missions

Post by another_commander »

applicant_255 wrote: Fri May 07, 2021 8:44 pm I did try to compile the latest version of oolite from source, but got stuck as a lot of people seem to on compiling the Firefox 4 derived spidermonkey dependancy. There was a gentoo patch that might fix the issue, but that's been removed from their site, and a different required patch to replace the ASM code I had to comment out to get the CPU string is also gone.
The Spidermonkey currently in use in Oolite v1.90 is the same as that of v1.84. If there is already an libjs import library for ARM from the version of the game in the repository, you should in theory be able to use it verbatim for v1.90.
Post Reply