Known errors: a summary

Discussion and information relevant to creating special missions, new ships, skins etc.

Moderators: winston, another_commander

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Wed Jul 31, 2019 4:58 pm

With that in mind, I'm not entirely clear on the relationship between https://wiki.alioth.net/img_auth.php/8/ ... ts_1.1.oxz and https://wiki.alioth.net/img_auth.php/2/ ... giants.oxz. :?

If the fault is common to both, one may be masking the other.

User avatar
spara
---- E L I T E ----
---- E L I T E ----
Posts: 2553
Joined: Wed Aug 15, 2012 4:19 am
Location: Finland

Re: Known errors: a summary

Post by spara » Wed Aug 07, 2019 4:11 pm

Ok. Checked my catalog. Gas giants are not there. I only have the base package and demux + redux. That means the gas giant oxps are in Redspear's catalog.

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Wed Aug 07, 2019 4:50 pm

Ok, thanks.

8)

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Thu Aug 08, 2019 11:18 am

I haven't found any errors in the code for the new version of Liners Markets, but while trying to download it, my log noted the following:

"12:13:03.961 [oxz.manager.error]: Downloaded OXZ does not have the same identifer and version as expected. This might be due to your manifests list being out of date - try updating it."

Apart from the version number, the manifest.plist for both versions seem identical.

Any thoughts?

:?:

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Known errors: a summary

Post by phkb » Fri Aug 09, 2019 1:47 am

Fleurghber wrote:
Thu Aug 08, 2019 11:18 am
Any thoughts?
Thought - "Aw, dang."

I had another look, and the version number appears to be correct. I did do another correction to the manifest, so that the required OXP's are defined correctly, and I tested this on my computer which seemed to work. Can you try again now?

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Fri Aug 09, 2019 11:35 am

I'm still not sure. It works when I download it from http://wiki.alioth.net/img_auth.php/3/3 ... arkets.oxz but not when I try to download it from within Oolite. I've found at least 5 other threads reporting this error at some point:

http://oolite.aegidian.org/bb/viewtopic.php?t=19905
http://oolite.aegidian.org/bb/viewtopic ... &start=180
http://oolite.aegidian.org/bb/viewtopic.php?t=17553
http://oolite.aegidian.org/bb/viewtopic ... 8&start=30
http://oolite.aegidian.org/bb/viewtopic ... 9&start=15

However, I can't determine what the common factor was, if it existed, or how it was rectified.

:?

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Known errors: a summary

Post by phkb » Fri Aug 09, 2019 10:39 pm

I think in a majority of those instances there was a definite bug in the manifest file that was corrected. The issue with Ace/56 ships the issue is less clear, as I thought the issue was related to manifest file formatting, but we never reached a conclusion other than something on the Mac machine itself had changed (like a system upgrade). No issues were being reported for Windows or Linux.

I've uploaded a new version of Liners Markets, now at version 1.3. Only change is to the manifest file and the readme file. Can I get you to try this again and see if we've made any progress?

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Sat Aug 10, 2019 9:05 am

Sorry, I'm still getting the same error message.

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Known errors: a summary

Post by phkb » Sat Aug 10, 2019 10:44 am

Do you have an existing version you're upgrading, and have you tried removing the existing version and installing it fresh? You probably have, but I thought I'd ask anyway.

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Sat Aug 10, 2019 11:07 am

To put it simply, yes: I've tried both methods and it doesn't seem to make a difference.

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Known errors: a summary

Post by phkb » Sun Aug 11, 2019 2:09 am

Well, this is certainly perplexing. I'm not sure what the ultimate solution can be, but maybe we could start by defining what your current system spec is (System spec, OS, version). If you have access to an older Mac (OS/version) we could try recreating the issue there.

If there are other Mac users lurking on the boards, perhaps they could chime in with their experience trying to download Liners Markets via the download manager. That might help us narrow the problem down to something we can address.

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Sun Aug 11, 2019 12:14 pm

From About This Mac/Overview:
OSX El Capitan
Version 10.11.6
iMac (21.5-inch, Late 2013)
Processor 2.7 GHz Intel Core i5
Memory 8 GB 1600 MHz DDR3
Graphics Intel Iris Pro 1536.MB
Anything else that might be relevant?

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Sun Aug 11, 2019 6:35 pm

After further experimentation, I've found it's also happening with Display Current Course and Shipset Compatibility.

Does that help at all?

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Known errors: a summary

Post by phkb » Sun Aug 11, 2019 8:18 pm

Fleurghber wrote:
Sun Aug 11, 2019 6:35 pm
After further experimentation, I've found it's also happening with Display Current Course and Shipset Compatibility.

Does that help at all?
Maybe. Do any other of my OXP’s work?

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Sun Aug 11, 2019 8:25 pm

Correction: Shipset Compatibility doesn't download because (apparently) it doesn't have a valid manifest.plist file. Unfortunately, I've been unable to determine if that's actually the case, because I can't open what I received as a .zip file like I would normally. I'll need more help than usual with this one.

Post Reply