Known errors: a summary

Discussion and information relevant to creating special missions, new ships, skins etc.

Moderators: winston, another_commander

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Sun Aug 11, 2019 8:29 pm

phkb wrote:
Sun Aug 11, 2019 8:18 pm
Fleurghber wrote:
Sun Aug 11, 2019 6:35 pm
After further experimentation, I've found it's also happening with Display Current Course and Shipset Compatibility.

Does that help at all?
Maybe. Do any other of my OXP’s work?
These are the only problems I've found so far. Everything else seems to be downloading in a satisfactory manner.

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Known errors: a summary

Post by phkb » Sun Aug 11, 2019 10:16 pm

OK, I've tried something a bit different. Can you try downloading Liners Markets again? Version number is now 1.4 .

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Sun Aug 11, 2019 10:30 pm

I don't know what you did this time, but it seems to have worked. But can you do it for Display Current Course as well?

:)

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Known errors: a summary

Post by phkb » Mon Aug 12, 2019 12:30 am

OK, give that a go now. I've put a new version on the Wiki, although the version number itself (1.8 ) hasn't changed.

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Known errors: a summary

Post by phkb » Mon Aug 12, 2019 2:40 am

Re Shipset Compatibility, that’s one of cim’s older OXP’s, and is only of use if you’re using any old ship packs that haven’t been updated after Oolite 1.80. I’ll still check it out though.

Edit: OK, it looks like the download link for Shipset Compatibility in the manager is invalid. cim moved all his OXP's to a new server and it appears this one got missed in the cleanup. I'll let him know.

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Known errors: a summary

Post by phkb » Mon Aug 12, 2019 4:58 am

On the assumption that my change to Display Current Course is effective in resolving the problem, it's probably worth sharing what I did to fix it. My solution was to change the line endings on the manifest.plist file from "CRLF" to "LF". My code editor of choice, "VS Code", defaults to CRLF line endings, and 99% of the time this is fine (again, I'm assuming that all my other OXP's -- with CRLF line endings in the manifest file -- are downloading fine). I still can't explain why sometimes the download manager on a Mac has a problem reading a file with CRLF line endings, and I also can't explain why changing it resolves the issue. But at least this is a viable workaround.

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Mon Aug 12, 2019 8:28 am

Sorry, it's still not working.

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Known errors: a summary

Post by phkb » Mon Aug 12, 2019 9:08 am

Fleurghber wrote:
Mon Aug 12, 2019 8:28 am
Sorry, it's still not working.
Aw, man! Well, it was a nice theory while it lasted!

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Known errors: a summary

Post by phkb » Mon Aug 12, 2019 9:12 am

Actually, can you try again now?

I just found that I had a discrepancy between the version number in the manifest, and the version number in the download manager. This one really should be fixed now.

<calls optometrist to book in eye-test>

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Mon Aug 12, 2019 11:05 am

No, I'm still getting the same error message.

:(

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Known errors: a summary

Post by phkb » Mon Aug 12, 2019 12:49 pm

<sigh>

Curse.

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Mon Aug 12, 2019 12:54 pm

Sorry, but if I can't download it myself, I can't try to identify what's causing the problem.

User avatar
GearsNSuch
Above Average
Above Average
Posts: 17
Joined: Wed Jul 03, 2019 10:27 am

Re: Known errors: a summary

Post by GearsNSuch » Mon Aug 12, 2019 4:38 pm

Mac user here. I’ve had the same issue with a couple mods before, Death Comms and the Galactic Registry. They downloaded just fine in the manager, but later I was unable to download updates for the OXPS. Both gave the error mentioned above. Updates came out again and, ta-da!, the downloads worked.
The pattern seems rather random, but maybe it seems to affect smaller OXPS more.

The two paths I’d personally take are:
1. Pumping out a series of pointless updates that change nothing but the version number.
2. Temporarily expanding the file size with 5000 copies of “warandpeace.txt”
3. Not worrying about it. Grabbing a copy from the wiki is easy enough. This bug is more “mildly annoying” than “critical.”

Good luck, and thank you!

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Known errors: a summary

Post by phkb » Mon Aug 12, 2019 10:03 pm

Fleurghber wrote:
Mon Aug 12, 2019 12:54 pm
Sorry, but if I can't download it myself, I can't try to identify what's causing the problem.
My apologies. I wasn't meaning to suggest this is at all your fault. It was just my attempt at some light-hearted humour while expressing my frustration at not being able to identify the issue myself. I'm sorry if I didn't communicate that well.
GearsNSuch wrote:
Mon Aug 12, 2019 4:38 pm
Mac user here. I’ve had the same issue with a couple mods before, Death Comms and the Galactic Registry. They downloaded just fine in the manager, but later I was unable to download updates for the OXPS. Both gave the error mentioned above. Updates came out again and, ta-da!, the downloads worked.
Thanks for the information, GearsNSuch. Could I trouble you for your Mac specs, just for reference?

Fleurghber
Dangerous
Dangerous
Posts: 93
Joined: Sat Oct 07, 2017 1:24 pm

Re: Known errors: a summary

Post by Fleurghber » Mon Aug 12, 2019 10:13 pm

Well, in any case, I'm going to be away most of the week, so I won't be able to check any further developments until I get back.

Post Reply