[Solved] Sticking Oolite to the aplication bar-Ubuntu 11.04

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Post Reply
User avatar
Eldon
Dangerous
Dangerous
Posts: 68
Joined: Tue Jan 26, 2010 1:38 pm

[Solved] Sticking Oolite to the aplication bar-Ubuntu 11.04

Post by Eldon » Wed Jul 06, 2011 7:45 pm

I've just upgraded from 1.75.1 to trunk (1.75.3.4569 to be exact) and now I can't seem to pin Oolite to the application bar that runs down the left hand side. I've tried dragging and dropping it: no effect. I've run Oolite and selected "Keep in Launcher": It sticks, but clicking on it does nothing. In desperation I've tried dragging the icon to the desktop: this at least gets an error "There was an error getting information about "/". The specified location is not supported.".

Help?

Thanks in advance,
Eldorn.

User avatar
Mauiby de Fug
---- E L I T E ----
---- E L I T E ----
Posts: 824
Joined: Tue Sep 07, 2010 2:23 pm

Re: Sticking Oolite to the aplication bar - Ubuntu 11.04

Post by Mauiby de Fug » Wed Jul 06, 2011 8:09 pm

Okay, go to your Home folder and show hidden folders. Then, head to .local/share/applications
You should in this folder see something called "oolite-trunk.org.desktop".
Right click on it, select Properties, and go to Permissions. Then tick the Execute: "Allow executing file as program" checkbox.
The file should now appear to change - you should see the Oolite icon and it should be called "Oolite-trunk (oolite.org)".
Drag this file to the Launcher.
Hopefully this should work now; I've just got it working for me (although I'm now removing it from my Launcher as I prefer it to show running programs)!

User avatar
Eldon
Dangerous
Dangerous
Posts: 68
Joined: Tue Jan 26, 2010 1:38 pm

Re: Sticking Oolite to the aplication bar - Ubuntu 11.04

Post by Eldon » Wed Jul 06, 2011 9:57 pm

Got it fixed, thanks!

The file wasn't quite where you said, but having a file name to search for helped an awful lot. It turns out it was in /usr/local/share/applications, owned by root. Thinking about it, I probably should have just tried dropping onto the bar then, but working out how to change permissions from a terminal (to use sudo) was good practice.

Anyhow, all sorted now, Thanks again.

Post Reply