Unable to enter fullscreen mode

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Post Reply
Enverex
Poor
Poor
Posts: 5
Joined: Sun Aug 20, 2006 1:30 pm
Location: Worcester, UK
Contact:

Unable to enter fullscreen mode

Post by Enverex » Sat Jul 09, 2011 3:49 pm

I'm running OoLite 1.75.2 on a RadeonHD 6310 with the 11.6 FGLRX driver but I cannot get into fullscreen mode.
Pressing F12 or using the option in the F2 menu just causes the window to flash once as I press the button, it doesn't actually change to fullscreen mode.

Has anyone experienced this before and does anyone know the fix?

Distro is Arch Linux 64bit for reference.

User avatar
Lone_Wolf
---- E L I T E ----
---- E L I T E ----
Posts: 545
Joined: Wed Aug 08, 2007 10:59 pm
Location: Netherlands

Re: Unable to enter fullscreen mode

Post by Lone_Wolf » Sat Jul 09, 2011 4:23 pm

No problems with the open source radeon drivers, but there have been cases where the splash screen confuses the driver.

try starting oolite like this :

Code: Select all

$ oolite --nosplash
OS : Arch Linux 64-bit - rolling release

OXPs : My user page

I am subscribed to the threads for my oxps, if you need my attention just post in them or send a pm.

User avatar
Smivs
Retired Assassin
Retired Assassin
Posts: 8408
Joined: Tue Feb 09, 2010 11:31 am
Location: Disunited Kingdom
Contact:

Re: Unable to enter fullscreen mode

Post by Smivs » Sat Jul 09, 2011 4:34 pm

Have you tried pressing F12 several times? I usually have to press it three times to get to full screen mode, but I have no idea why.
Commander Smivs, the friendliest Gourd this side of Riedquat.

Enverex
Poor
Poor
Posts: 5
Joined: Sun Aug 20, 2006 1:30 pm
Location: Worcester, UK
Contact:

Re: Unable to enter fullscreen mode

Post by Enverex » Sat Jul 09, 2011 10:03 pm

Hammering F12 just makes the window flicker.

Weirdly starting the game with "oolite --nosplash" (or "oolite --no-splash" just in case) still shows the splashscreen so that doesn't seem to work.
Edit: Turns out the oolite in my path was actually a script, I found the real one and --nosplash worked as expected and didn't show the splash screen, but I still couldn't go into fullscreen mode. :(

Post Reply