Different results on different window managers?

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Post Reply
markusv
Mostly Harmless
Mostly Harmless
Posts: 2
Joined: Wed Nov 09, 2011 1:51 pm

Different results on different window managers?

Post by markusv » Wed Nov 09, 2011 2:03 pm

Hi there!

Today, I installed oolite 1.75.3 on Ubuntu Oneiric. It seems to work fine in the Unity window manager / desktop, but when I use XMonad (which I’d rather like), I get the splash screen and maybe a flash of the “Load previous commander?” screen, then only black. Could someone please point me to the stuff I have to configure for oolite to work in XMonad?

Thanks a lot :)
Markus.

User avatar
DaddyHoggy
Intergalactic Spam Assassin
Intergalactic Spam Assassin
Posts: 8501
Joined: Tue Dec 05, 2006 9:43 pm
Location: Newbury, UK
Contact:

Re: Different results on different window managers?

Post by DaddyHoggy » Wed Nov 09, 2011 2:11 pm

Hi Markus. I just wanted to say Welcome - but to say - unfortunately - I can't help - I've resisted upgrading my Ubuntu Box - I'm still on Karmic - so the new graphics environment is still a mystery to me.

However, there's a few Linux guru's on the board, so hopefully you'll get an answer soon.
Selezen wrote:Apparently I was having a DaddyHoggy moment.
Oolite Life is now revealed here

User avatar
Mauiby de Fug
---- E L I T E ----
---- E L I T E ----
Posts: 824
Joined: Tue Sep 07, 2010 2:23 pm

Re: Different results on different window managers?

Post by Mauiby de Fug » Wed Nov 09, 2011 2:35 pm

You're getting flickering and then black, yes? I used to have a similar problem on Ubuntu. Try resizing or maximising the window and you should hopefully manage to get it to work - that always worked for me when I was running Unity. I've found that Oneiric is worse for that than the Natty was for me.

Oddly enough, I get it when running Unity and Ubuntu, but not when I'm using Lubuntu, which I think uses Openbox as the window manager.

markusv
Mostly Harmless
Mostly Harmless
Posts: 2
Joined: Wed Nov 09, 2011 1:51 pm

Re: Different results on different window managers?

Post by markusv » Wed Nov 09, 2011 2:38 pm

Hi!

Thanks for your warm welcome, DaddyHoggy :)

And @M. de Fug: That did the trick :) strange… Thanks a lot.

Markus.

Post Reply