Debian, not really a bug, not sure where to post this.

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: another_commander, winston, Getafix

Post Reply
User avatar
Rxke
Retired Assassin
Retired Assassin
Posts: 1743
Joined: Thu Aug 12, 2004 4:54 pm
Location: Belgium

Debian, not really a bug, not sure where to post this.

Post by Rxke »

... So feel free to remove/retitle this entry.

On a macbook under Debian Squeeze Wheezy, Oolite installs and plays great but for one niggle:

right after exiting the station, the ship starts pitching up.

Solution:

P (Pause)
F2
game options
joystick settings
select pitch up and 'u' (unset)

Done :)

Not sure why it does that, though. I have no joystick attached.
Last edited by Rxke on Wed Feb 22, 2012 7:07 am, edited 1 time in total.

User avatar
fronclynne
Deadly
Deadly
Posts: 149
Joined: Sun Mar 01, 2009 5:36 am
Location: ::1

Re: Debian, not really a bug, not sure where to post this.

Post by fronclynne »

Your mouse being used as a joystick, perhaps?

User avatar
Rxke
Retired Assassin
Retired Assassin
Posts: 1743
Joined: Thu Aug 12, 2004 4:54 pm
Location: Belgium

Re: Debian, not really a bug, not sure where to post this.

Post by Rxke »

sorry, it was Wheezy (testing)

I have no mouse.


(EDIT: and no, track pad seemed not to interfere either)

But I have installed *a lot* of cruft *and* mercilessly yanked out stuff to 'see what happens if i push this button' :) the last few months, it is really a miracle my laptop stays stable

Doing a clean install now, KDE this time, but with nouveau (open NVIDIA drivers w/o accell 3D if I'm not mistaken...) drivers, so I guess Oolite won't run to begin with :(

User avatar
fronclynne
Deadly
Deadly
Posts: 149
Joined: Sun Mar 01, 2009 5:36 am
Location: ::1

Re: Debian, not really a bug, not sure where to post this.

Post by fronclynne »

Well, it could be a stray signal from your hardware, though that Apple junk is purported to be fairly good stuff, or it might be a driver issue. Do you even have a joystick driver installed? (I dunno if Debian ships it in kernel or as a module, honestly)

I guess you could try building a custom kernel with all the joystick drivers disabled and see if that helps. Or, you know, switch over to Gentoo and spend all of your time recompiling libjpeg instead of using your computer to download pictures of kittens.

User avatar
Rxke
Retired Assassin
Retired Assassin
Posts: 1743
Joined: Thu Aug 12, 2004 4:54 pm
Location: Belgium

Re: Debian, not really a bug, not sure where to post this.

Post by Rxke »

How do you know about my kitten collection??? :shock: :shock: :lol:

Okay, update: clean install Debian testing, KDE, nouveau driver.

Guess what: Oolite runs better (higher fps) with the open driver than with the closed one! Very, very impressed by that fact....

Still pitching up, though... :mrgreen:


I'm not overly bothered by it. Yet...

Got more pressing stuff to do, stuff like visiting lolcats!

User avatar
Rxke
Retired Assassin
Retired Assassin
Posts: 1743
Joined: Thu Aug 12, 2004 4:54 pm
Location: Belgium

Re: Debian, not really a bug, not sure where to post this.

Post by Rxke »

For the heck of it, tried a clean Testing Debian AMD64 xfce install, and...

No pitching! :o


Of course, with testing it's a moving target, so let's consider this semi-solved :)

Post Reply