Oolite Bulletins

For information and discussion about Oolite.
It is currently Mon Sep 01, 2014 11:10 am

All times are UTC




Post new topic Reply to topic  [ 11 posts ] 
Author Message
PostPosted: Tue Apr 17, 2012 10:13 am 
Offline
Poor
Poor

Joined: Thu Apr 05, 2012 8:33 pm
Posts: 4
Hey there, I downloaded Oolite off the Ubuntu soft-where center and installed it but when try to load up the game the operating system crashes and i have to restart the computer. so i uninstalled and tried installing the version from the developer website, same thing it gets to the spinning cobra screen, the screen flickers rapidly (meanwhile the cobra has not actually loaded) then the sidebar, icons and everything vanish from the desktop

I'm sure folk ask this a lot but is there a way to get it working?


Top
 Profile  
 
PostPosted: Tue Apr 17, 2012 11:12 am 
Offline
Retired Assassin
Retired Assassin
User avatar

Joined: Tue Feb 09, 2010 11:31 am
Posts: 6845
Location: In the klitchen pickling Tree Grubs
Hi Magnetgeek, and welcome to the Friendliest Board this side of Riedquat.
I have had a similar problem, and switching to fullscreen mode (F12 button) when the start-up gets to the spinning Cobra usually fixed it.
Also, are you using the current stable version (1.76)?

_________________
Commander Smivs, the friendliest Gourd this side of Riedquat.


Top
 Profile  
 
PostPosted: Tue Apr 17, 2012 11:14 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Aug 08, 2007 10:59 pm
Posts: 301
Location: Netherlands
please post the latest log file, it is in ~/.Oolite/Logs/Latest.log .

_________________
OS : Arch Linux 64-bit (rolling release, so always latest version)

OXPs :
Shield Cycler
[EliteWiki] Homing Beacon


Top
 Profile  
 
PostPosted: Tue Apr 17, 2012 4:21 pm 
Offline
Poor
Poor

Joined: Thu Apr 05, 2012 8:33 pm
Posts: 4
yeh im using the latest stable, ill post the log file asap


Top
 Profile  
 
PostPosted: Tue Apr 17, 2012 4:37 pm 
Offline
Poor
Poor

Joined: Thu Apr 05, 2012 8:33 pm
Posts: 4
Smivs your method seemed to work thanks

Lonewolf i cant find the logs directory for some reason


Top
 Profile  
 
PostPosted: Tue Apr 17, 2012 4:41 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Fri Nov 26, 2010 9:08 pm
Posts: 1044
Location: Help! I'm stranded down here on Earth!
Magnetgeek wrote:
I cant find the logs directory for some reason
~/.Oolite is a hidden directory

_________________
Flying a Cobra Mk I Cobbie 3 with nothing but Explorers Club.OXP and a beam laser 4 proper lasers for company :D
Dropbox referral link 2GB of free space online + 500 Mb for the referral: good for securing work-in-progress.


Top
 Profile  
 
PostPosted: Tue Apr 17, 2012 5:03 pm 
Offline
Retired Assassin
Retired Assassin
User avatar

Joined: Tue Feb 09, 2010 11:31 am
Posts: 6845
Location: In the klitchen pickling Tree Grubs
Magnetgeek wrote:
Smivs your method seemed to work thanks

Lonewolf i cant find the logs directory for some reason


Glad it worked :)

To find the logs (and the AddOns (OXP) folder) in Ubuntu :-

'Places' ->'Home Folder'

then in the Home Folder

'View' ->'Show Hidden Files' (or Ctl-H)

and that will show all the hidden files including '.Oolite'. This folder holds the logs and OXP folder.

_________________
Commander Smivs, the friendliest Gourd this side of Riedquat.


Top
 Profile  
 
PostPosted: Tue Apr 17, 2012 8:19 pm 
Offline
Poor
Poor

Joined: Thu Apr 05, 2012 8:33 pm
Posts: 4
Quote:
20:09:28.935 [log.header]: Opening log for Oolite version 1.76 (x86-32 test release) under Linux at 2012-04-17 20:09:28 +0000.
1 processor detected.
Build options: spoken messages, mass/fuel pricing, JavaScript console support, OXP verifier, localization tools, debug GraphViz support, JavaScript profiling.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

20:09:29.388 [display.mode.list.native]: X11 native resolution detected: 1280 x 800
20:09:29.615 [joystick.init]: Number of joysticks detected: 0
20:09:30.108 [searchPaths.dumpAll]: Unrestricted mode - resource paths:
~/GNUstep/Applications/Oolite/oolite.app/Resources
AddOns
AddOns/Basic-debug.oxp
20:09:30.108 [rendering.opengl.version]: OpenGL renderer version: 2.1.0 ("2.1 Mesa 7.11"). Vendor: "Tungsten Graphics, Inc". Renderer: "Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2".
20:09:30.108 [rendering.opengl.extensions]: OpenGL extensions (138):
GL_ARB_framebuffer_sRGB, GL_ARB_depth_texture, GL_ARB_texture_env_add, GL_EXT_pixel_buffer_object, GL_EXT_texture_compression_rgtc, GL_ARB_half_float_vertex, GL_IBM_multimode_draw_arrays, GL_EXT_texture3D, GL_EXT_compiled_vertex_array, GL_NV_vertex_program1_1, GL_ARB_framebuffer_object, GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_ARB_shader_texture_lod, GL_EXT_texture_cube_map, GL_EXT_rescale_normal, GL_ATI_draw_buffers, GL_ARB_transpose_matrix, GL_ARB_texture_compression_rgtc, GL_ARB_half_float_pixel, GL_EXT_stencil_two_side, GL_ARB_texture_border_clamp, GL_ARB_multisample, GL_ATI_separate_stencil, GL_ARB_texture_non_power_of_two, GL_INGR_blend_func_separate, GL_EXT_bgra, GL_ARB_sync, GL_EXT_texture_env_dot3, GL_EXT_provoking_vertex, GL_APPLE_packed_pixels, GL_NV_light_max_exponent, GL_ARB_sampler_objects, GL_SUN_multi_draw_arrays, GL_ARB_map_buffer_range, GL_ARB_vertex_shader, GL_ARB_shader_objects, GL_NV_texgen_reflection, GL_EXT_multi_draw_arrays, GL_ARB_vertex_program, GL_IBM_rasterpos_clip, GL_EXT_texture_object, GL_ATI_texture_env_combine3, GL_EXT_framebuffer_sRGB, GL_NV_texture_env_combine4, GL_ARB_fragment_coord_conventions, GL_EXT_stencil_wrap, GL_EXT_texture_swizzle, GL_EXT_framebuffer_blit, GL_MESA_pack_invert, GL_ARB_vertex_array_bgra, GL_NV_packed_depth_stencil, GL_ARB_texture_compression, GL_ARB_vertex_array_object, GL_EXT_blend_color, GL_EXT_blend_minmax, GL_ARB_texture_swizzle, GL_APPLE_vertex_array_object, GL_EXT_subtexture, GL_MESA_texture_signed_rgba, GL_ARB_point_sprite, GL_ARB_depth_clamp, GL_NV_depth_clamp, GL_EXT_vertex_array, GL_EXT_abgr, GL_ARB_vertex_buffer_object, GL_NV_blend_square, GL_EXT_framebuffer_multisample, GL_ATI_envmap_bumpmap, GL_NV_conditional_render, GL_NV_texture_rectangle, GL_ARB_multitexture, GL_EXT_texture, GL_ARB_seamless_cube_map, GL_EXT_vertex_array_bgra, GL_ARB_copy_buffer, GL_ARB_draw_elements_base_vertex, GL_APPLE_object_purgeable, GL_ARB_shadow, GL_EXT_blend_subtract, GL_EXT_separate_shader_objects, GL_ARB_fragment_program_shadow, GL_MESA_window_pos, GL_ARB_window_pos, GL_EXT_texture_lod_bias, GL_IBM_texture_mirrored_repeat, GL_EXT_texture_snorm, GL_ARB_texture_env_crossbar, GL_ARB_point_parameters, GL_EXT_texture_sRGB_decode, GL_ARB_robustness, GL_ARB_texture_rg, GL_EXT_texture_edge_clamp, GL_EXT_copy_texture, GL_EXT_texture_sRGB, GL_MESA_ycbcr_texture, GL_ARB_texture_env_combine, GL_ARB_fragment_program, GL_ARB_explicit_attrib_location, GL_EXT_texture_filter_anisotropic, GL_EXT_draw_range_elements, GL_EXT_blend_logic_op, GL_ARB_pixel_buffer_object, GL_EXT_packed_depth_stencil, GL_ARB_texture_rectangle, GL_EXT_fog_coord, GL_ARB_ES2_compatibility, GL_SGIS_texture_lod, GL_3DFX_texture_compression_FXT1, GL_EXT_gpu_program_parameters, GL_APPLE_client_storage, GL_ARB_fragment_shader, GL_OES_EGL_image, GL_EXT_polygon_offset, GL_ARB_shading_language_100, GL_SGIS_texture_border_clamp, GL_EXT_secondary_color, GL_EXT_point_parameters, GL_ARB_draw_buffers, GL_NV_vertex_program, GL_SGIS_generate_mipmap, GL_EXT_draw_buffers2, GL_EXT_texture_rectangle, GL_ATI_blend_equation_separate, GL_OES_read_format, GL_EXT_blend_func_separate, GL_ARB_texture_cube_map, GL_ARB_occlusion_query, GL_EXT_framebuffer_object, GL_EXT_packed_pixels, GL_ARB_texture_mirrored_repeat, GL_ARB_texture_env_dot3, GL_ARB_provoking_vertex, GL_EXT_blend_equation_separate, GL_ARB_color_buffer_float, GL_EXT_texture_env_add, GL_EXT_texture_env_combine, GL_SGIS_texture_edge_clamp
20:09:30.411 [rendering.opengl.shader.support]: Shaders are supported.
20:09:30.412 [speech.synthesis]: Spoken messages are off.
20:09:31.092 [script.javascript.init]: JavaScript reset successful.
20:09:31.172 [script.load.world.listAll]: Loaded 5 world scripts:
oolite-cloaking-device 1.76
oolite-constrictor-hunt 1.76
oolite-nova 1.76
oolite-thargoid-plans 1.76
oolite-trumbles 1.76
20:09:33.137 [debugTCP.disconnect]: No connection to debug console: "Connection to debug console failed: '' (outStream status: 7, inStream status: 7)."
20:09:33.137 [debugTCP.disconnect]: No connection to debug console: "Connection to debug console failed: 'unknown error.' (outStream status: 0, inStream status: 0)."
20:09:33.137 [debugTCP.connect.failed]: Failed to connect to debug console at address 127.0.0.1:8563.
20:09:33.262 [loading.complete]: ========== Loading complete. ==========

Closing log at 2012-04-17 20:09:40 +0000.


there you go


Top
 Profile  
 
PostPosted: Sat Apr 21, 2012 9:43 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Thu Apr 28, 2011 3:17 pm
Posts: 1357
Smivs method didn't work for me. My system has crashed three times straight, and those are the first three times I have tried to open the game in Ubuntu 11.10. It will sit looking innocent, twirling the Cobra III, until I do something to get it going, and then it just freezes, and the whole system goes down. I tried uninstalling it, and then reinstalling it, but it didn't make a difference. Any more suggestions?

_________________
Mandotech Industries Wiki Page.

http://wiki.alioth.net/index.php/User:Mandoman


Top
 Profile  
 
PostPosted: Sat Apr 21, 2012 10:20 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Thu Apr 28, 2011 3:17 pm
Posts: 1357
Update: I have succesfully run a session of Oolite, but then I accidently nudged the Oolite window, and it crashed. The problem seems to be something to do with moving the window, or changing it in any way. Other than that, I got right on, and played. Man it sure is a fun game. :D

_________________
Mandotech Industries Wiki Page.

http://wiki.alioth.net/index.php/User:Mandoman


Top
 Profile  
 
PostPosted: Sun Apr 22, 2012 2:05 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Aug 08, 2007 10:59 pm
Posts: 301
Location: Netherlands
Sounds like a problem with the videodriver.

I suggest you look for a PPA that has mesa 8.0.2 and try that out.

_________________
OS : Arch Linux 64-bit (rolling release, so always latest version)

OXPs :
Shield Cycler
[EliteWiki] Homing Beacon


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group