[Semi-Solved] Intel Graphics / Generic Monitor Issue

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: another_commander, winston, Getafix

User avatar
CommRLock78
---- E L I T E ----
---- E L I T E ----
Posts: 1132
Joined: Sat Apr 07, 2012 7:35 pm
Location: US
Contact:

[Semi-Solved] Intel Graphics / Generic Monitor Issue

Post by CommRLock78 »

So, I added some RAM to my old machine, a Dell 4600, bringing the machine up to 1GB of RAM. I also upgraded it from Ubuntu 11.10 to Xubuntu 12.04. I thought the lack of RAM was why Oolite was crashing, but it is still crashing. Note that I am able to go to the long range scanner this time without crashing (see link below), but not to the planet information screen, and when I launch it crashes too.

This crash is a poof, now you see it, now you don't, kind of crash - there is no warning, Oolite just closes. There are a couple other games where this same kind of crash happens, too, and I can't help but think those are related to this crash.

I have tried the same fix that I used for the other machine (see http://aegidian.org/bb/viewtopic.php?f=9&t=11888) but to no avail. A friend of mine thinks it might be because I have a very ACME monitor which I guess Linux treats as though it where a legacy monitor (it says Micron, model AP150T on the back label, but otherwise no name anywhere on the thing), so consider this before racking your brain too hard. If that's the case then I'll probably just need to get a better monitor.

Here is the output from uname -a, the video hardware listing, and the latest log file:

uname -a
Linux xubuntu 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:52 UTC 2012 i686 i686 i386 GNU/Linux

sudo lshw -c video

*-display
description: VGA compatible controller
product: 82865G Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:16 memory:e8000000-efffffff memory:feb80000-febfffff ioport:ed98(size=8)
---------------------------------------------------------------------------------------------------------------
16:08:07.522 [log.header]: Opening log for Oolite version 1.76 (x86-32 test release) under Linux at 2012-05-08 16:08:07 -0700.
2 processors detected.
Build options: spoken messages, mass/fuel pricing, JavaScript console support, OXP verifier, localization tools, debug GraphViz support, JavaScript profiling.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

16:08:07.915 [display.mode.list.native]: X11 native resolution detected: 1024 x 768
16:08:08.181 [joystick.init]: Number of joysticks detected: 0
16:08:10.256 [searchPaths.dumpAll]: Unrestricted mode - resource paths:
/opt/Oolite/oolite.app/Resources
AddOns
~/.Oolite/AddOns
AddOns/Basic-debug.oxp
~/.Oolite/AddOns/Armoury 1.09.oxp
~/.Oolite/AddOns/tiger.oxp
~/.Oolite/AddOns/FTZ v0.15.oxp
~/.Oolite/AddOns/Flight Log 1.03.oxp
~/.Oolite/AddOns/neocaduceus.oxp
~/.Oolite/AddOns/Fuel Tank v2.2.oxp
~/.Oolite/AddOns/terrapin.oxp
~/.Oolite/AddOns/velocity.oxp
~/.Oolite/AddOns/Deep Horizons - Systems.oxp
~/.Oolite/AddOns/Escape_Capsule_Locator_1.4_2011-12-18.oxp
~/.Oolite/AddOns/Condor v1.1.oxp
~/.Oolite/AddOns/wormhole_restoration.oxp
~/.Oolite/AddOns/FarstarMurderer1.1.oxp
~/.Oolite/AddOns/ixianfreighter.oxp
~/.Oolite/AddOns/ixianfreighter.oxp/ixianfreighter.oxp
~/.Oolite/AddOns/Diso.oxp
~/.Oolite/AddOns/Galactic_Navy 5.4.3.oxp
~/.Oolite/AddOns/Anarchies2.6.oxp
~/.Oolite/AddOns/pagroove_Aurorav1.1.oxp
~/.Oolite/AddOns/accessoriesV2.0.oxp
~/.Oolite/AddOns/PlanetFall Link - Black Monks 1.0.oxp
~/.Oolite/AddOns/PlanetFall 1.41.oxp
~/.Oolite/AddOns/Famous_Planets_v2.5.oxp
~/.Oolite/AddOns/behemoth 2.6.oxp
~/.Oolite/AddOns/MildAudio.oxp
~/.Oolite/AddOns/MildAudio.oxp/MildAudio.oxp
~/.Oolite/AddOns/AsteroidStorm 4.02.oxp
~/.Oolite/AddOns/Illegal_goods_tweak_1.6_2012.02.05.oxp
~/.Oolite/AddOns/The_Feudal_States_v1.13.oxp
~/.Oolite/AddOns/Executive Spaceways v2.4.oxp
~/.Oolite/AddOns/Tianve1.3.oxp
~/.Oolite/AddOns/Fuel Station 1.34.oxp
~/.Oolite/AddOns/Factions-1.10.oxp
~/.Oolite/AddOns/Lave Academy 1.31.oxp
~/.Oolite/AddOns/BGS-A1.4.oxp
~/.Oolite/AddOns/BountyScannerv2.0.oxp
~/.Oolite/AddOns/adcks_eagles_v1.1.oxp
~/.Oolite/AddOns/DeepspaceHud.oxp
~/.Oolite/AddOns/xarik.oxp
~/.Oolite/AddOns/Ore_processor 1.58.oxp
~/.Oolite/AddOns/Shady_blackmonks.oxp
~/.Oolite/AddOns/PlanetFall Mission - Oo-Haul 1.11.oxp
~/.Oolite/AddOns/urutu_IV.oxp
~/.Oolite/AddOns/ClippersV1.2.oxp
~/.Oolite/AddOns/vendetta.oxp
~/.Oolite/AddOns/DeepspaceShip.oxp
~/.Oolite/AddOns/Lave.oxp
~/.Oolite/AddOns/Dictators v1.5.oxp
~/.Oolite/AddOns/thargoid_wars 4.5.4.oxp
~/.Oolite/AddOns/hOopyCasino1.2.oxp
~/.Oolite/AddOns/Escort_Contracts_1.5.1_2012-02-05.oxp
~/.Oolite/AddOns/Deep Horizons - Gas Giant Skimming.oxp
~/.Oolite/AddOns/BigShips 1.02.oxp
~/.Oolite/AddOns/RandomHits1.4.12oxp.oxp
~/.Oolite/AddOns/Basic-debug.oxp
~/.Oolite/AddOns/Cabal_Common_Library1.5.1.oxp
~/.Oolite/AddOns/PlanetFall Link - hOopy Casino 1.0.oxp
~/.Oolite/AddOns/Assassins.oxp
16:08:10.256 [rendering.opengl.version]: OpenGL renderer version: 1.3.0 ("1.3 Mesa 8.0.2"). Vendor: "Tungsten Graphics, Inc". Renderer: "Mesa DRI Intel(R) 865G x86/MMX/SSE2".
16:08:10.257 [rendering.opengl.extensions]: OpenGL extensions (100):
GL_ARB_texture_env_crossbar, GL_EXT_abgr, GL_EXT_texture, GL_IBM_texture_mirrored_repeat, GL_EXT_texture_edge_clamp, GL_EXT_separate_specular_color, GL_EXT_blend_minmax, GL_ARB_texture_env_add, GL_EXT_texture_object, GL_INGR_blend_func_separate, GL_EXT_texture_cube_map, GL_ARB_draw_elements_base_vertex, GL_ARB_sampler_objects, GL_EXT_texture_env_dot3, GL_IBM_rasterpos_clip, GL_EXT_framebuffer_blit, GL_ARB_texture_env_dot3, GL_EXT_framebuffer_object, GL_NV_light_max_exponent, GL_EXT_blend_subtract, GL_EXT_copy_texture, GL_EXT_separate_shader_objects, GL_3DFX_texture_compression_FXT1, GL_MESA_window_pos, GL_ARB_multitexture, GL_EXT_stencil_wrap, GL_ARB_texture_border_clamp, GL_ARB_texture_env_combine, GL_NV_vertex_program, GL_EXT_framebuffer_multisample, GL_EXT_texture_env_add, GL_SGIS_texture_edge_clamp, GL_EXT_packed_pixels, GL_SGIS_texture_lod, GL_ARB_transpose_matrix, GL_NV_packed_depth_stencil, GL_NV_texgen_reflection, GL_ARB_shading_language_100, GL_ARB_robustness, GL_OES_EGL_image, GL_EXT_gpu_program_parameters, GL_EXT_rescale_normal, GL_ARB_map_buffer_range, GL_ARB_provoking_vertex, GL_ARB_explicit_attrib_location, GL_ARB_pixel_buffer_object, GL_EXT_secondary_color, GL_ARB_copy_buffer, GL_OES_read_format, GL_ARB_texture_mirrored_repeat, GL_SUN_multi_draw_arrays, GL_EXT_blend_equation_separate, GL_ARB_half_float_pixel, GL_EXT_draw_range_elements, GL_EXT_polygon_offset, GL_EXT_texture_lod_bias, GL_EXT_texture_filter_anisotropic, GL_SGIS_texture_border_clamp, GL_SGIS_generate_mipmap, GL_APPLE_object_purgeable, GL_ARB_texture_rectangle, GL_NV_texture_rectangle, GL_ARB_point_sprite, GL_EXT_packed_depth_stencil, GL_ARB_vertex_shader, GL_ARB_vertex_buffer_object, GL_ARB_sync, GL_ARB_shader_objects, GL_EXT_provoking_vertex, GL_IBM_multimode_draw_arrays, GL_MESA_ycbcr_texture, GL_ARB_framebuffer_object, GL_EXT_texture_rectangle, GL_EXT_fog_coord, GL_EXT_texture3D, GL_EXT_subtexture, GL_ARB_window_pos, GL_EXT_point_parameters, GL_ARB_vertex_program, GL_EXT_texture_env_combine, GL_ARB_texture_cube_map, GL_ARB_point_parameters, GL_EXT_compiled_vertex_array, GL_EXT_bgra, GL_EXT_vertex_array, GL_ARB_multisample, GL_ARB_vertex_array_object, GL_ARB_draw_buffers, GL_ATI_draw_buffers, GL_ARB_texture_compression, GL_EXT_multi_draw_arrays, GL_APPLE_vertex_array_object, GL_APPLE_packed_pixels, GL_EXT_blend_func_separate, GL_MESA_pack_invert, GL_ATI_blend_equation_separate, GL_EXT_blend_color, GL_EXT_pixel_buffer_object, GL_NV_vertex_program1_1, GL_NV_blend_square
16:08:10.353 [rendering.opengl.gpuSpecific]: Matched GPU configuration "Intel GMA 900/950 family".
16:08:10.354 [rendering.opengl.shader.support]: Shaders will not be used (OpenGL extension GL_ARB_fragment_shader is not available).
16:08:10.354 [speech.synthesis]: Spoken messages are off.
16:08:13.452 [script.javascript.init]: JavaScript reset successful.
16:08:14.482 [script.load.world.listAll]: Loaded 61 world scripts:
ams_system 2.02
Anarchies 2.6
armoury_machineScript.js 1.00
assassins
AsteroidStorm 4.02
behemoth 2.6
BGS-M 1.4
bigShips_populator 1.0.2
black_monks
Bounty Scanner 2.0 2.00
Cabal_Common_Briefing 1.5.1
Cabal_Common_Comms 1.5.1
Cabal_Common_Functions 1.5.1
Cabal_Common_Keyboard 1.5.1
Cabal_Common_MissionHandling 1.5.1
Cabal_Common_Music 1.5.1
Cabal_Common_OXPStrength 1.5.1
Cabal_Common_SpecialMarkets 1.5.1
Caduceus Damage Control Node 2.0
Cheyd_JS_Common_Functions_1 0.0.5
clipper_tanks_script.js 1.2
CT_Script 2.0
Deep Horizon - Systems 2.0.8
Deep Horizon - Systems API 2.0.5
Deep Horizon - Systems Exclusion Lists 1.0.1
dictators.js 1.0
ecl_SAR_worldscript.js 1.4
escapePodLocator.js 1.4
Escort_Contracts 1.5.1
Escort_Contracts_Rep 1.5.1
executivespaceways.js 1.0
Factions 1.10
Famous Planets 2.5.1
feudal-challenge.js 8.0
feudal-mission.js 9.0
feudal-planetfall.js 3.0
feudal-promotion.js 5.0
feudal-ranks.js 4.0
feudal-tournament.js 9.0
FlightLog 1.02
free-trade-zone
FuelStation-Setup 1.33
GalNavy 5.4.3
Gas Giant Refueling 1.0.7
hofd 5.3.0
hoopy_casino 1.2
illegal_goods_missions 1.6
illegal_goods_tweak 1.6
LaveAcademy 1.2
oolite-cloaking-device 1.76
oolite-constrictor-hunt 1.76
oolite-nova 1.76
oolite-thargoid-plans 1.76
oolite-tianve 1.3
oolite-trumbles 1.76
oreProcessor 1.57
PlanetFall 1.40
PlanetFall_Oohaul 1.10
Random_Hits 1.4.12
thargoid_wars 4.5.4
wormhole-restoration 1.1
16:08:18.620 [files.notFound]: ----- WARNING: Could not find texture file "StarSeeker_wings.png".
16:08:18.888 [debugTCP.disconnect]: No connection to debug console: "Connection to debug console failed: '' (outStream status: 7, inStream status: 7)."
16:08:18.889 [debugTCP.disconnect]: No connection to debug console: "Connection to debug console failed: 'unknown error.' (outStream status: 0, inStream status: 0)."
16:08:18.889 [debugTCP.connect.failed]: Failed to connect to debug console at address 127.0.0.1:8563.
16:08:18.959 [Flightlog]: Kills Store set to player score
16:08:18.959 [escapePodLocator.js]: Range in normal space modifier: default. Range in interstellar space modifier: default.
16:08:20.543 [loading.complete]: ========== Loading complete. ==========
-------------------------------------------------------------------------------------------------------------

Thanks for reading, fellow commanders! :)
Last edited by CommRLock78 on Tue Jun 05, 2012 10:58 pm, edited 2 times in total.
"I'll laser the mark all while munching a fistful of popcorn." - Markgräf von Ededleen, Marquess, Brutal Great One, Assassins' Guild Exterminator
---------------------------
At the helm of the Caduceus Omega, 'Murderous Morrígan'

User avatar
CommRLock78
---- E L I T E ----
---- E L I T E ----
Posts: 1132
Joined: Sat Apr 07, 2012 7:35 pm
Location: US
Contact:

Re: Intel Graphics / Generic Monitor Issue

Post by CommRLock78 »

CommRLock78 wrote:I have tried the same fix that I used for the other machine (see http://aegidian.org/bb/viewtopic.php?f=9&t=11888) but to no avail. A friend of mine thinks it might be because I have a very ACME moniter which I guess Linux treats as though it where a legacy monitor (it says Micron, model AP150T on the back label, but otherwise no name anywhere on the thing), so consider this before racking your brain too hard. If that's the case then I'll probably just need to get a better monitor.
Update: I went ahead and tried switching monitors out and that didn't change anything (still crashed even using the Dell monitor), so it isn't anything with the generic monitor that I can tell.
"I'll laser the mark all while munching a fistful of popcorn." - Markgräf von Ededleen, Marquess, Brutal Great One, Assassins' Guild Exterminator
---------------------------
At the helm of the Caduceus Omega, 'Murderous Morrígan'

User avatar
SandJ
---- E L I T E ----
---- E L I T E ----
Posts: 1045
Joined: Fri Nov 26, 2010 9:08 pm
Location: Help! I'm stranded down here on Earth!

Re: Intel Graphics / Generic Monitor Issue

Post by SandJ »

You might want to fix:
~/.Oolite/AddOns/ixianfreighter.oxp
~/.Oolite/AddOns/ixianfreighter.oxp/ixianfreighter.oxp
and:
~/.Oolite/AddOns/MildAudio.oxp
~/.Oolite/AddOns/MildAudio.oxp/MildAudio.oxp
Flying a Cobra Mk I Cobbie 3 with nothing but Explorers Club.OXP and a beam laser 4 proper lasers for company :D
Dropbox referral link 2GB of free space online + 500 Mb for the referral: good for securing work-in-progress.

User avatar
Lone_Wolf
---- E L I T E ----
---- E L I T E ----
Posts: 545
Joined: Wed Aug 08, 2007 10:59 pm
Location: Netherlands

Re: Intel Graphics / Generic Monitor Issue

Post by Lone_Wolf »

Code: Select all

16:08:10.256 [rendering.opengl.version]: OpenGL renderer version: 1.3.0 ("1.3 Mesa 8.0.2"). Vendor: "Tungsten Graphics, Inc". Renderer: "Mesa DRI Intel(R) 865G x86/MMX/SSE2".

Code: Select all

16:08:10.353 [rendering.opengl.gpuSpecific]: Matched GPU configuration "Intel GMA 900/950 family".
It does look oolite may have chosen the wrong configuration, as the 865G chipset is NOT in the GMA family.
The 865G was produced before intel switched to GMA architecture.

Try the following :

look for the .GNUstepDefaults file (note : enable search for hidden files)

Open that file in an editor, scroll down until you see something like this :

Code: Select all

<key>shader-mode</key>
	<integer>1</integer>
Change the number to 0 like this :
<key>shader-mode</key>
<integer>0</integer>

This will disable shaders completely.
Let us know if that solves the crashes.
OS : Arch Linux 64-bit - rolling release

OXPs : My user page

I am subscribed to the threads for my oxps, if you need my attention just post in them or send a pm.

User avatar
CommRLock78
---- E L I T E ----
---- E L I T E ----
Posts: 1132
Joined: Sat Apr 07, 2012 7:35 pm
Location: US
Contact:

Re: Intel Graphics / Generic Monitor Issue

Post by CommRLock78 »

Well, this is precious. I checked that .GNUstepDefaults file and it seemed a little short compared to the same file on the other computer. I needed to restart Xubuntu because the network wasn't working and firefox was crashing, but now the whole computer just hangs on boot - something it's never done before. I've tried a recovery boot, and that doesn't work, if I just leave it, it starts Timidity, then Apache, then goes to restart Timidity, and that gives a [fail] on the second go (odd) - pretty frustrating.... So I guess I have to fix this nonsense before I can go back to solving the other nonsense...
"I'll laser the mark all while munching a fistful of popcorn." - Markgräf von Ededleen, Marquess, Brutal Great One, Assassins' Guild Exterminator
---------------------------
At the helm of the Caduceus Omega, 'Murderous Morrígan'

User avatar
CommRLock78
---- E L I T E ----
---- E L I T E ----
Posts: 1132
Joined: Sat Apr 07, 2012 7:35 pm
Location: US
Contact:

Re: Intel Graphics / Generic Monitor Issue

Post by CommRLock78 »

CommRLock78 wrote:Well, this is precious. I checked that .GNUstepDefaults file and it seemed a little short compared to the same file on the other computer. I needed to restart Xubuntu because the network wasn't working and firefox was crashing, but now the whole computer just hangs on boot - something it's never done before. I've tried a recovery boot, and that doesn't work, if I just leave it, it starts Timidity, then Apache, then goes to restart Timidity, and that gives a [fail] on the second go (odd) - pretty frustrating.... So I guess I have to fix this nonsense before I can go back to solving the other nonsense...
Well, I started a live Mint session preparing for the worst and backing things up, and automagically, now Xubuntu starts again. That's a big strike for Xubuntu I must say. Below is the .GNUstepdefaults file, in full:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//GNUstep//DTD plist 0.9//EN" "http://www.gnustep.org/plist-0_9.xml">
<plist version="0.9">
<dict>
<key>NSGlobalDomain</key>
<dict>
</dict>
<key>oolite</key>
<dict>
</dict>
</dict>
</plist>
"I'll laser the mark all while munching a fistful of popcorn." - Markgräf von Ededleen, Marquess, Brutal Great One, Assassins' Guild Exterminator
---------------------------
At the helm of the Caduceus Omega, 'Murderous Morrígan'

User avatar
CommRLock78
---- E L I T E ----
---- E L I T E ----
Posts: 1132
Joined: Sat Apr 07, 2012 7:35 pm
Location: US
Contact:

Re: Intel Graphics / Generic Monitor Issue

Post by CommRLock78 »

SandJ wrote:You might want to fix:
~/.Oolite/AddOns/ixianfreighter.oxp
~/.Oolite/AddOns/ixianfreighter.oxp/ixianfreighter.oxp
and:
~/.Oolite/AddOns/MildAudio.oxp
~/.Oolite/AddOns/MildAudio.oxp/MildAudio.oxp
I went ahead and checked those - it turns out those OXP folders are nested a little strangely. I will fix that, but first I need to kick Xubuntu off of my machine. I'm pretty well fed up - between the problem I had earlier, and now with it telling me my primary drive is full, when I know damn well it isn't, has led me to think that is time for Mint on the old machine as well.
"I'll laser the mark all while munching a fistful of popcorn." - Markgräf von Ededleen, Marquess, Brutal Great One, Assassins' Guild Exterminator
---------------------------
At the helm of the Caduceus Omega, 'Murderous Morrígan'

User avatar
CommRLock78
---- E L I T E ----
---- E L I T E ----
Posts: 1132
Joined: Sat Apr 07, 2012 7:35 pm
Location: US
Contact:

Re: Intel Graphics / Generic Monitor Issue

Post by CommRLock78 »

I installed Mint and the xorg ppa, as well as given the kernel an update (up to 3.1.0-030100). So, here's the new data, I've tried to trim it down some to save space and time. The outputs of lshw -c video and modinfo look pretty much the same with the exception of the kernel version. I also fixed the weird nesting, so there's no more double oxp listings in the log.

01:03:02.394 [log.header]: Opening log for Oolite version 1.76 (x86-32 test release) under Linux at 2012-05-10 01:03:02 -0700.
2 processors detected.
Build options: spoken messages, mass/fuel pricing, JavaScript console support, OXP verifier, localization tools, debug GraphViz support, JavaScript profiling.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

01:03:02.546 [display.mode.list.native]: X11 native resolution detected: 1024 x 768
01:03:02.628 [joystick.init]: Number of joysticks detected: 0
01:03:03.301 [searchPaths.dumpAll]: Unrestricted mode - resource paths:
/opt/Oolite/oolite.app/Resources
AddOns
~/.Oolite/AddOns
AddOns/Basic-debug.oxp
~/.Oolite/AddOns/PlanetFall Link - hOopy Casino 1.0.oxp.......................................
.............etc
01:03:03.301 [rendering.opengl.version]: OpenGL renderer version: 1.3.0 ("1.3 Mesa 8.0.2"). Vendor: "Tungsten Graphics, Inc". Renderer: "Mesa DRI Intel(R) 865G x86/MMX/SSE2".
01:03:03.301 [rendering.opengl.extensions]: OpenGL extensions (100):
GL_ARB_texture_env_crossbar, .........................etc........................................, GL_NV_blend_square
01:03:03.310 [rendering.opengl.gpuSpecific]: Matched GPU configuration "Intel GMA 900/950 family".
01:03:03.310 [rendering.opengl.shader.support]: Shaders will not be used (OpenGL extension GL_ARB_fragment_shader is not available).
01:03:03.310 [speech.synthesis]: Spoken messages are off.
01:03:05.299 [script.javascript.init]: JavaScript reset successful.
01:03:05.361 [script.load.world.listAll]: Loaded 61 world scripts:
....................etc...........................................................
01:03:08.760 [files.notFound]: ----- WARNING: Could not find texture file "StarSeeker_wings.png".
01:03:09.334 [debugTCP.disconnect]: No connection to debug console: "Connection to debug console failed: '' (outStream status: 7, inStream status: 7)."
01:03:09.334 [debugTCP.disconnect]: No connection to debug console: "Connection to debug console failed: 'unknown error.' (outStream status: 0, inStream status: 0)."
01:03:09.334 [debugTCP.connect.failed]: Failed to connect to debug console at address 127.0.0.1:8563.
01:03:09.347 [Flightlog]: Kills Store set to player score
01:03:09.347 [escapePodLocator.js]: Range in normal space modifier: default. Range in interstellar space modifier: default.
01:03:10.461 [loading.complete]: ========== Loading complete. ==========
01:03:26.787 [bigShips_populator]: 0 big trader(s) added to the Lave system.
------------------------------------------------------------------------------------------------------------------------------
As you can see, the system still configured itself for the 865G. The .GNUstepdefaults file is even shorter, with just an entry for oolite essentially. I went ahead and added the code that you suggested, Lone Wolf, but the sadly, the game still crashes in exactly the same fashion - it just shuts down without warning. I am not sure that I made all the right changes to the file, because there still appears to be shading on the spacecraft when I start the game.

I went ahead and checked the same file on the other machine and it is rather lengthy, but I wasn't able to find "shader-mode" or even "shade" in a search of the file.
"I'll laser the mark all while munching a fistful of popcorn." - Markgräf von Ededleen, Marquess, Brutal Great One, Assassins' Guild Exterminator
---------------------------
At the helm of the Caduceus Omega, 'Murderous Morrígan'

User avatar
Lone_Wolf
---- E L I T E ----
---- E L I T E ----
Posts: 545
Joined: Wed Aug 08, 2007 10:59 pm
Location: Netherlands

Re: Intel Graphics / Generic Monitor Issue

Post by Lone_Wolf »

CommRLock78 wrote: As you can see, the system still configured itself for the 865G. The .GNUstepdefaults file is even shorter, with just an entry for oolite essentially. I went ahead and added the code that you suggested, Lone Wolf, but the sadly, the game still crashes in exactly the same fashion - it just shuts down without warning. I am not sure that I made all the right changes to the file, because there still appears to be shading on the spacecraft when I start the game.

I went ahead and checked the same file on the other machine and it is rather lengthy, but I wasn't able to find "shader-mode" or even "shade" in a search of the file.
If it is in the wrong dictionary, it will likely be ignored by gnustep/oolite .
i hope you made a backup copy of .GNUsyepDefaults , if so just put that back.

However, i realised there's a simpler way to disable shaders from within oolite :
F2 > game options
Check what it says under Shader effects, and set it to None if needed.

If disabling shaders doesn't help, maybe someone else has an idea.
OS : Arch Linux 64-bit - rolling release

OXPs : My user page

I am subscribed to the threads for my oxps, if you need my attention just post in them or send a pm.

User avatar
Capt. Murphy
Commodore
Commodore
Posts: 1127
Joined: Fri Feb 25, 2011 8:46 am
Location: UK South Coast.

Re: Intel Graphics / Generic Monitor Issue

Post by Capt. Murphy »

Hi ,

I think you are barking up the wrong tree looking at Gnustepdefaults - that just contains the setting saved by the game when it shuts down (e.g did you shut down in windowed mode or not, what was the window size, shader mode when shutdown etc.). The reason it's empty is because it is crashing, not shutting down normally. The log already says that shaders aren't supported in what Oolite thinks is the graphics card.

See what happens OXP free, and if your crash free start adding them back in a few at a time. At the same time check for OXP updates - a few in your list have new versions.

In the system stable apart from Oolite? If not I'd be doing some hardware diagnostics - particularly checking that the old and the new memory is good.
[EliteWiki] Capt. Murphy's OXPs
External JavaScript resources - W3Schools & Mozilla Developer Network
Win 7 64bit, Intel Core i5 with HD3000 (driver rev. 8.15.10.2696 - March 2012), Oolite 1.76.1

User avatar
Capt. Murphy
Commodore
Commodore
Posts: 1127
Joined: Fri Feb 25, 2011 8:46 am
Location: UK South Coast.

Re: Intel Graphics / Generic Monitor Issue

Post by Capt. Murphy »

Lone_Wolf wrote:
It does look oolite may have chosen the wrong configuration, as the 865G chipset is NOT in the GMA family.
The 865G was produced before intel switched to GMA architecture.
The file to that sets up compatibility options for known 'problem' GPU's is gpu-setting.plist which is found in the Resources\Config folder in the core game files.

This is what the entry that is being used looks like. If you decide to edit this file either keep a back-up or (I've not tried this but is should work), put a copy in your AddOns folder and edit that copy.

Code: Select all

"Intel GMA 900/950 family" =
	{
		match =
		{
			vendor = "Tungsten|Intel";
			/*	"GMA<anything>9##" (or 8##) but not 9###. N.b. the Tunsgten
				Mesa drivers use the chipset number (which may start with 8)
				rather than the graphics engine number.
			*/
			renderer = "(Intel|GMA).*\\b[89]\\d{2}(?!\\d)";
		};
		maximum_shader_level = "SHADERS_SIMPLE";
		default_shader_level = "SHADERS_SIMPLE";
		smooth_points = false;		// Point smoothing is not supported in hardware.
		use_dust_shader = false;	// Vertex shaders are emulated on CPU.
	};
[EliteWiki] Capt. Murphy's OXPs
External JavaScript resources - W3Schools & Mozilla Developer Network
Win 7 64bit, Intel Core i5 with HD3000 (driver rev. 8.15.10.2696 - March 2012), Oolite 1.76.1

User avatar
CommRLock78
---- E L I T E ----
---- E L I T E ----
Posts: 1132
Joined: Sat Apr 07, 2012 7:35 pm
Location: US
Contact:

Re: Intel Graphics / Generic Monitor Issue

Post by CommRLock78 »

Capt. Murphy wrote:Hi ,

I think you are barking up the wrong tree looking at Gnustepdefaults - that just contains the setting saved by the game when it shuts down (e.g did you shut down in windowed mode or not, what was the window size, shader mode when shutdown etc.). The reason it's empty is because it is crashing, not shutting down normally. The log already says that shaders aren't supported in what Oolite thinks is the graphics card.

See what happens OXP free, and if your crash free start adding them back in a few at a time. At the same time check for OXP updates - a few in your list have new versions.

In the system stable apart from Oolite? If not I'd be doing some hardware diagnostics - particularly checking that the old and the new memory is good.
That would make sense about the log file. I actually ran Oolite before I put any OXPs in the AddOns folder, and it crashed. As far as I can tell the system seems stable - much better than before really, when Xubuntu was telling me that my drive was full (anyone that has an idea as to why that might be I'd love to know :? ). Since I'm still in my first 6 months of using Linux, I'm unsure of how to do said hardware diagnostics, but the system monitor says the there's 1000MB of RAM, so all the modules (4x256MB) appear to be working.
Last edited by CommRLock78 on Thu May 10, 2012 8:31 pm, edited 2 times in total.
"I'll laser the mark all while munching a fistful of popcorn." - Markgräf von Ededleen, Marquess, Brutal Great One, Assassins' Guild Exterminator
---------------------------
At the helm of the Caduceus Omega, 'Murderous Morrígan'

User avatar
CommRLock78
---- E L I T E ----
---- E L I T E ----
Posts: 1132
Joined: Sat Apr 07, 2012 7:35 pm
Location: US
Contact:

Re: Intel Graphics / Generic Monitor Issue

Post by CommRLock78 »

Lone_Wolf wrote: However, i realised there's a simpler way to disable shaders from within oolite :
F2 > game options
Check what it says under Shader effects, and set it to None if needed.

If disabling shaders doesn't help, maybe someone else has an idea.
Unfortunately, that option is greyed out, and says "Shader Effects: Not Available".

However, there does seem to be some sort of shadows on the spacecraft on startup, if that says anything....
"I'll laser the mark all while munching a fistful of popcorn." - Markgräf von Ededleen, Marquess, Brutal Great One, Assassins' Guild Exterminator
---------------------------
At the helm of the Caduceus Omega, 'Murderous Morrígan'

User avatar
CommRLock78
---- E L I T E ----
---- E L I T E ----
Posts: 1132
Joined: Sat Apr 07, 2012 7:35 pm
Location: US
Contact:

Re: Intel Graphics / Generic Monitor Issue

Post by CommRLock78 »

Capt. Murphy wrote:
Lone_Wolf wrote:
It does look oolite may have chosen the wrong configuration, as the 865G chipset is NOT in the GMA family.
The 865G was produced before intel switched to GMA architecture.
The file to that sets up compatibility options for known 'problem' GPU's is gpu-setting.plist which is found in the Resources\Config folder in the core game files.

This is what the entry that is being used looks like. If you decide to edit this file either keep a back-up or (I've not tried this but is should work), put a copy in your AddOns folder and edit that copy.
Taking a cautionary approach, I of course backed up, and then changed only:

Code: Select all

maximum_shader_level = "SHADERS_SIMPLE";
             default_shader_level = "SHADERS_SIMPLE";
to

Code: Select all

maximum_shader_level = "SHADERS_OFF";
             default_shader_level = "SHADERS_OFF";
In just that section of the file. I'm not sure if that's the only change I need to make, but it still crashes, even holding shift as it started :roll: (grrr). There are still shadows on the spacecraft when it starts, but I'm not sure if that says anything. I can't help but wonder, since STK crashes the same way, that there's something system-wide causing this problem (or, even worse, some sort of conflict with the hardware??). These are the only crashes I'm aware of yet on this system, and I've even checked some other applications which are otherwise fairly resource demanding (not necessarily graphics heavy - except for Celestia, but still fairly resource gobbling) which all seem to work just fine. Very weird :? .....
"I'll laser the mark all while munching a fistful of popcorn." - Markgräf von Ededleen, Marquess, Brutal Great One, Assassins' Guild Exterminator
---------------------------
At the helm of the Caduceus Omega, 'Murderous Morrígan'

User avatar
Commander McLane
Intergalactic Spam Assassin
Intergalactic Spam Assassin
Posts: 9520
Joined: Thu Dec 14, 2006 9:08 am
Location: a Hacker Outpost in a moderately remote area
Contact:

Re: Intel Graphics / Generic Monitor Issue

Post by Commander McLane »

CommRLock78 wrote:There are still shadows on the spacecraft when it starts, but I'm not sure if that says anything.
The lighting system should work regardless of shader settings. 'Shaders' and 'shadows' have nothing to do with each other, despite the word similarity.

Post Reply