Page 1 of 1

Unable to start 1.86 on Ubuntu 16.04

Posted: Wed Apr 25, 2018 11:04 am
by Bugbear
Hi all,
Decided to take my Cobra out from under the dustcloth, but I'm being denied before I can even get the game to launch. Following are the contents of my latest.log

What I'm seeing is the icon appearing in the task bar, then it disappears after a few seconds.

I've tried uninstalling / reinstalling, also tried downgrading to 1.84 but to no avail.

Code: Select all

Opening log for Oolite version 1.86 (x86-64 test release) under Linux 4.13.0-39-generic at 2018-04-25 19:00:11 +0800.
8 processors detected.
Build options: OpenAL, new planets, JavaScript console support, OXP verifier, localization tools, debug GraphViz support, JavaScript profiling.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

19:00:11.818 [dataCache.rebuild.pathsChanged]: Cache is stale (search paths have changed). Rebuilding from scratch.
Any suggestions?

Re: Unable to start 1.86 on Ubuntu 16.04

Posted: Wed Apr 25, 2018 11:21 am
by Norby
This is the full log? :shock: How about the nightly?

Re: Unable to start 1.86 on Ubuntu 16.04

Posted: Wed Apr 25, 2018 12:45 pm
by another_commander
Make sure you are installing the binaries from and not from the distro repository.

Re: Unable to start 1.86 on Ubuntu 16.04

Posted: Wed Apr 25, 2018 1:17 pm
by Bugbear
Norby wrote:
Wed Apr 25, 2018 11:21 am
This is the full log? :shock: How about the nightly?
Yep, that's the full log.
another_commander wrote: Make sure you are installing the binaries from and not from the distro repository.
Downloaded 1.86 and 1.84 from

Given that both versions are behaving the same, it could be that my Ubuntu build is getting a little long in the tooth and could be due a refresh.

I can also try building my own from source - see if I get any different behaviour. I'll give the nightly a try first.

Re: Unable to start 1.86 on Ubuntu 16.04

Posted: Wed May 23, 2018 4:28 am
by Bugbear
Took a while but I've finally refreshed my laptop with Ubuntu 18.04. Still having grief unfortunately, but at least the behaviour is a bit different.

Running Oolite v1.86 - Oct 25 2017

Latest.log contents

Code: Select all

Opening log for Oolite version 1.86 (x86-64) under Linux 4.15.0-20-generic at 2018-05-23 12:04:46 +0800.
8 processors detected.
Build options: OpenAL, new planets.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

12:04:46.223 [dataCache.notFound]: No data cache found, starting from scratch.
12:04:46.306 [display.mode.list.native]: X11 native resolution detected: 3840 x 1080
12:04:46.856 [joystick.init]: Number of joysticks detected: 0
12:04:46.858 [rendering.opengl.version]: OpenGL renderer version: 3.0.0 ("3.0 Mesa 18.0.0-rc5"). Vendor: "Intel Open Source Technology Center". Renderer: "Mesa DRI Intel(R) Sandybridge Mobile ".
12:04:46.859 [rendering.opengl.extensions]: OpenGL extensions (213):
GL_ARB_draw_instanced, GL_ARB_get_texture_sub_image, GL_ARB_cull_distance, GL_ARB_occlusion_query, GL_EXT_texture_env_add, GL_ARB_texture_storage, GL_ARB_texture_env_dot3, GL_ARB_sync, GL_ARB_texture_multisample, GL_ARB_buffer_storage, GL_ARB_explicit_uniform_location, GL_NV_texture_env_combine4, GL_KHR_context_flush_control, GL_ARB_point_parameters, GL_ARB_vertex_array_object, GL_ARB_blend_func_extended, GL_EXT_provoking_vertex, GL_ARB_seamless_cubemap_per_texture, GL_EXT_blend_equation_separate, GL_ARB_compressed_texture_pixel_storage, GL_EXT_texture_snorm, GL_ARB_texture_non_power_of_two, GL_ARB_texture_mirrored_repeat, GL_ARB_debug_output, GL_EXT_multi_draw_arrays, GL_ARB_timer_query, GL_ARB_clip_control, GL_SGIS_texture_edge_clamp, GL_EXT_abgr, GL_ARB_vertex_program, GL_ATI_texture_float, GL_ARB_draw_buffers_blend, GL_ARB_shadow, GL_NV_light_max_exponent, GL_EXT_texture_cube_map, GL_EXT_texture_compression_dxt1, GL_NV_primitive_restart, GL_EXT_framebuffer_object, GL_MESA_pack_invert, GL_EXT_texture_sRGB, GL_3DFX_texture_compression_FXT1, GL_ARB_get_program_binary, GL_ARB_multitexture, GL_ARB_clear_texture, GL_AMD_seamless_cubemap_per_texture, GL_SUN_multi_draw_arrays, GL_EXT_texture_compression_rgtc, GL_ARB_shader_objects, GL_EXT_blend_func_separate, GL_EXT_bgra, GL_ARB_pixel_buffer_object, GL_ARB_draw_buffers, GL_APPLE_packed_pixels, GL_NV_texgen_reflection, GL_ARB_texture_env_crossbar, GL_ARB_fragment_shader, GL_MESA_shader_integer_functions, GL_EXT_texture_swizzle, GL_EXT_fog_coord, GL_EXT_vertex_array_bgra, GL_EXT_framebuffer_blit, GL_ARB_shader_draw_parameters, GL_ARB_texture_compression_rgtc, GL_EXT_transform_feedback, GL_OES_read_format, GL_ARB_sample_shading, GL_ARB_seamless_cube_map, GL_EXT_texture_shared_exponent, GL_ARB_shading_language_420pack, GL_ATI_blend_equation_separate, GL_APPLE_object_purgeable, GL_EXT_polygon_offset, GL_INGR_blend_func_separate, GL_EXT_compiled_vertex_array, GL_KHR_debug, GL_ARB_copy_image, GL_AMD_shader_trinary_minmax, GL_EXT_separate_specular_color, GL_ARB_vertex_type_2_10_10_10_rev, GL_EXT_vertex_array, GL_ARB_shading_language_100, GL_EXT_framebuffer_multisample_blit_scaled, GL_EXT_rescale_normal, GL_ARB_texture_float, GL_EXT_packed_depth_stencil, GL_ARB_texture_swizzle, GL_ARB_half_float_pixel, GL_EXT_texture_compression_s3tc, GL_EXT_draw_instanced, GL_ARB_occlusion_query2, GL_AMD_draw_buffers_blend, GL_ARB_texture_rgb10_a2ui, GL_SGIS_texture_lod, GL_KHR_no_error, GL_ARB_framebuffer_object, GL_NV_conditional_render, GL_EXT_stencil_two_side, GL_ARB_texture_rg, GL_ARB_color_buffer_float, GL_EXT_blend_color, GL_NV_packed_depth_stencil, GL_EXT_texture_rectangle, GL_NV_texture_rectangle, GL_ARB_vertex_array_bgra, GL_ARB_texture_filter_anisotropic, GL_ANGLE_texture_compression_dxt3, GL_EXT_texture_integer, GL_EXT_texture_array, GL_ANGLE_texture_compression_dxt5, GL_ARB_shading_language_packing, GL_ARB_fragment_program_shadow, GL_ARB_map_buffer_range, GL_ARB_fragment_program, GL_ARB_copy_buffer, GL_EXT_texture, GL_S3_s3tc, GL_NV_depth_clamp, GL_EXT_texture_lod_bias, GL_EXT_texture_filter_anisotropic, GL_EXT_draw_buffers2, GL_ARB_pipeline_statistics_query, GL_EXT_secondary_color, GL_ARB_transform_feedback2, GL_ARB_ES3_compatibility, GL_EXT_framebuffer_multisample, GL_ARB_window_pos, GL_IBM_rasterpos_clip, GL_EXT_texture_env_combine, GL_ARB_vertex_shader, GL_SGIS_generate_mipmap, GL_EXT_packed_float, GL_ARB_texture_border_clamp, GL_ARB_explicit_attrib_location, GL_NV_blend_square, GL_ARB_internalformat_query, GL_EXT_texture3D, GL_ARB_arrays_of_arrays, GL_ARB_ES2_compatibility, GL_ARB_texture_query_lod, GL_ARB_invalidate_subdata, GL_EXT_texture_sRGB_decode, GL_ARB_texture_compression, GL_ARB_texture_env_add, GL_ARB_provoking_vertex, GL_ARB_texture_rectangle, GL_EXT_texture_edge_clamp, GL_MESA_texture_signed_rgba, GL_ARB_draw_elements_base_vertex, GL_ARB_fragment_coord_conventions, GL_ARB_separate_shader_objects, GL_IBM_multimode_draw_arrays, GL_ARB_texture_cube_map, GL_ARB_vertex_attrib_binding, GL_EXT_framebuffer_sRGB, GL_ARB_clear_buffer_object, GL_KHR_robustness, GL_ARB_vertex_type_10f_11f_11f_rev, GL_ARB_robustness, GL_ARB_polygon_offset_clamp, GL_ARB_point_sprite, GL_INTEL_performance_query, GL_ARB_texture_gather, GL_ARB_internalformat_query2, GL_SGIS_texture_border_clamp, GL_ARB_depth_texture, GL_EXT_texture_object, GL_ARB_instanced_arrays, GL_EXT_blend_minmax, GL_ATI_draw_buffers, GL_OES_EGL_image, GL_ARB_multi_bind, GL_ARB_conditional_render_inverted, GL_ARB_framebuffer_sRGB, GL_EXT_shader_integer_mix, GL_EXT_blend_subtract, GL_EXT_packed_pixels, GL_IBM_texture_mirrored_repeat, GL_EXT_draw_range_elements, GL_ARB_texture_mirror_clamp_to_edge, GL_ARB_texture_cube_map_array, GL_ARB_sampler_objects, GL_ARB_half_float_vertex, GL_ARB_depth_clamp, GL_ARB_texture_storage_multisample, GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object, GL_ARB_texture_query_levels, GL_ARB_texture_barrier, GL_EXT_pixel_buffer_object, GL_ATI_texture_env_combine3, GL_EXT_polygon_offset_clamp, GL_ARB_transform_feedback_overflow_query, GL_ARB_texture_env_combine, GL_ARB_shader_group_vote, GL_KHR_blend_equation_advanced, GL_ARB_shader_bit_encoding, GL_EXT_timer_query, GL_EXT_gpu_program_parameters, GL_ARB_shader_texture_lod, GL_ARB_program_interface_query, GL_ARB_uniform_buffer_object, GL_ARB_multisample, GL_EXT_texture_env_dot3, GL_EXT_shadow_funcs, GL_ARB_depth_buffer_float, GL_ARB_map_buffer_alignment, GL_EXT_copy_texture, GL_EXT_stencil_wrap, GL_EXT_point_parameters, GL_ATI_separate_stencil, GL_EXT_subtexture, GL_NV_texture_barrier, GL_MESA_window_pos
12:04:46.876 []: Shaders are supported.
12:04:46.877 [dataCache.notFound]: No data cache found, starting from scratch.
12:04:46.880 [searchPaths.dumpAll]: Resource paths: 
Haven't tried building my own as yet (on this OS) so that's the next step.

Re: Unable to start 1.86 on Ubuntu 16.04

Posted: Wed May 23, 2018 5:33 am
by phkb
I'm not on Linux, and my knowledge of it is subsequently minimal, but can you try some of the startup options? "-nosplash" and "-noshaders" in particular. It might be helpful to see what the results are from those.

That shows you how much knowledge I have of Linux... :oops:

What I meant to say (obviously) was to try out some of the settings in the .GNUstepDefaults file. See this wiki page for details about the file and settings available.

Re: Unable to start 1.86 on Ubuntu 16.04

Posted: Sun May 27, 2018 8:17 pm
by Anonymissimus
What's your GPU and driver ?
Try minimizing the graphics requirements with startup parameters first as phkb suggests (probably less work than building).

As for building, although considered outdated, most of the steps in viewtopic.php?f=9&t=4595 are still valid, such as the "(1.2) Setup GNUstep environment variables" step (I needed it).
Packages which I needed on 16.04 according to my notes:


Seems I already had git (for getting the source) and curl.

Well, curl isn't needed. I'm now also on 18.04. This machine has a GeForce 8600 GT with proprietary nvidia-340 drivers, hardware from maybe 2007. Runs oolite pretty well on "extra detail". :P