Help Install on MX Linux, please

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: another_commander, winston, Getafix

user2357
Average
Average
Posts: 14
Joined: Tue Jan 21, 2020 3:37 pm

Help Install on MX Linux, please

Post by user2357 »

Hi, All

I googled 'site:aegidian.org/bb 1.88 mx linux', and I've wiki.alioth'ed a bit, and scanned these forums and Oolite-Linux topics, but my issue doesn't seem to have been addressed yet.

The Oolite 1.88 64-bit .tgz autopackage worked fine on Linux Mint 18.2 xfce, but Mint borked on me for indeterminable reasons, and https://distrowatch.com indicated that MX Linux is the new favourite by far. Therefore, same machine, new OS.

However, trying back and forth for an entire day now to install on MX Linux 19 (December) [which is based on Debian (Stable) and antiX], either in /home or /opt, trying with and without sudo, and trying to run it from either the terminal or the Games-menu entry, I get no joy.

Whether from the terminal or the Games menu, I always get only a quick flash of the Oolite splash screen. From the terminal, I get (1) rarely the 'This is the first time you've run the game. ...' README message, but (2) always the following error-log message:

'AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
Segmentation fault

Erk. It looks like Oolite died with an error. When making an error
report, please copy + paste the log above into the report.

(Press Ctrl-C to continue)'

...and then nothing further. :(

What does the error message mean, please? ...and what should I do to get Oolite running again?

I don't know if it might be part of the problem, or useful at all, but Nvidia drivers don't work for me on Linux. I have an ASUS i7 ROG laptop with an Nvidia GTX 1050 (4GB GDDR5), but using the onboard Intel Graphics 630.

I would really appreciate any support that anyone might be able to provide.

Thanks, kindly, Commanders. <o

User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 13805
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: Help Install on MX Linux, please

Post by Cody »

Welcome aboard, Commander! Hopefully, one of the penguinistas will be along shortly.

user2357
Average
Average
Posts: 14
Joined: Tue Jan 21, 2020 3:37 pm

Re: Help Install on MX Linux, please

Post by user2357 »

Muchas gracias, amigo Cody, for the warm welcome aboard. 8)

I would really like to get Oolite going on MX Linux. MX seems to be a little bit better than Mint, in my limited experience.

Edit: Turning it off, and turning it back on again, doesn't help, and neither does uninstalling, getting a fresh download, and reinstalling, either.

It doesn't seem to be an issue with the autopackage, nor with the hardware, because Oolite 1.88 worked fine on the same machine running Linux Mint, previously. It seems to be some issue between Oolite and MX Linux... Either Oolite needs something extra to make it run on MX Linux, or I need to do something in MX Linux to make Oolite run on it. That's as much as I can figure. Thanks.

Commander_X
---- E L I T E ----
---- E L I T E ----
Posts: 325
Joined: Sat Aug 09, 2014 4:16 pm

Re: Help Install on MX Linux, please

Post by Commander_X »

When you say "autopackage", is it from Oolite site download page, or is it from your Linux distribution packaging repositories?

You can also check in your $HOME/.Oolite/Logs/Latest.log to see if 1. is created and/or 2. has some more insight on what's happening.

user2357
Average
Average
Posts: 14
Joined: Tue Jan 21, 2020 3:37 pm

Re: Help Install on MX Linux, please

Post by user2357 »

Thanks, Commander_X.

I downloaded the autopackage from the oolite.org website (https://github.com/OoliteProject/oolite ... x86_64.tgz). Synaptic Package Manager on MX Linux does not list any version of Oolite in its repositories.

Here is the complete contents of the .Oolite/Logs/Latest.log. I hope it is more useful to you than it is to me. :oops:

*

Opening log for Oolite version 1.88 (x86-64) under Linux 4.19.0-6-amd64 at 2020-01-22 20:22:06 +0200.
8 processors detected.
Build options: OpenAL, new planets.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

20:22:06.476 [dataCache.notFound]: No data cache found, starting from scratch.
20:22:06.542 [display.mode.list.native]: X11 native resolution detected: 1920 x 1080
20:22:06.610 [joystick.init]: Number of joysticks detected: 0
20:22:06.612 [rendering.opengl.version]: OpenGL renderer version: 3.0.0 ("3.0 Mesa 18.3.6"). Vendor: "Intel Open Source Technology Center". Renderer: "Mesa DRI Intel(R) HD Graphics 630 (Kaby Lake GT2) ".
20:22:06.612 [rendering.opengl.extensions]: OpenGL extensions (256):
GL_ARB_draw_instanced, GL_ARB_get_texture_sub_image, GL_ARB_cull_distance, GL_ARB_occlusion_query, GL_ARB_texture_storage, GL_ARB_sync, GL_ARB_texture_env_dot3, GL_EXT_texture_env_add, GL_ARB_buffer_storage, GL_ARB_texture_multisample, GL_ARB_explicit_uniform_location, GL_KHR_context_flush_control, GL_NV_texture_env_combine4, GL_ARB_shader_atomic_counter_ops, GL_ARB_point_parameters, GL_ARB_vertex_array_object, GL_ARB_shader_ballot, GL_ARB_blend_func_extended, GL_ARB_seamless_cubemap_per_texture, GL_EXT_provoking_vertex, GL_ARB_compressed_texture_pixel_storage, GL_EXT_blend_equation_separate, GL_ARB_texture_stencil8, GL_EXT_texture_snorm, GL_ARB_texture_non_power_of_two, GL_ARB_texture_mirrored_repeat, GL_ARB_debug_output, GL_EXT_multi_draw_arrays, GL_ARB_timer_query, GL_ARB_clip_control, GL_SGIS_texture_edge_clamp, GL_ARB_vertex_program, GL_EXT_abgr, GL_ARB_draw_buffers_blend, GL_ATI_texture_float, GL_ARB_shadow, GL_ARB_shader_atomic_counters, GL_EXT_texture_compression_dxt1, GL_EXT_texture_cube_map, GL_NV_light_max_exponent, GL_NV_primitive_restart, GL_EXT_framebuffer_object, GL_EXT_texture_sRGB, GL_MESA_pack_invert, GL_3DFX_texture_compression_FXT1, GL_ARB_shader_storage_buffer_object, GL_ARB_conservative_depth, GL_ARB_get_program_binary, GL_ARB_clear_texture, GL_ARB_multitexture, GL_AMD_seamless_cubemap_per_texture, GL_ARB_shader_image_size, GL_SUN_multi_draw_arrays, GL_EXT_texture_compression_rgtc, GL_ARB_shader_objects, GL_ARB_pixel_buffer_object, GL_EXT_blend_func_separate, GL_EXT_bgra, GL_ARB_draw_buffers, GL_APPLE_packed_pixels, GL_ARB_texture_env_crossbar, GL_NV_texgen_reflection, GL_ARB_fragment_shader, GL_MESA_shader_integer_functions, GL_EXT_texture_swizzle, GL_EXT_fog_coord, GL_KHR_texture_compression_astc_sliced_3d, GL_EXT_vertex_array_bgra, GL_ARB_shader_draw_parameters, GL_EXT_framebuffer_blit, GL_ARB_texture_compression_rgtc, GL_EXT_transform_feedback, GL_OES_read_format, GL_ARB_sample_shading, GL_ARB_seamless_cube_map, GL_ARB_shading_language_420pack, GL_AMD_depth_clamp_separate, GL_EXT_texture_shared_exponent, GL_INTEL_shader_atomic_float_minmax, GL_ATI_blend_equation_separate, GL_ARB_fragment_shader_interlock, GL_AMD_shader_stencil_export, GL_APPLE_object_purgeable, GL_INGR_blend_func_separate, GL_EXT_compiled_vertex_array, GL_KHR_debug, GL_ARB_copy_image, GL_AMD_shader_trinary_minmax, GL_ARB_shader_image_load_store, GL_ARB_vertex_type_2_10_10_10_rev, GL_EXT_separate_specular_color, GL_ARB_shading_language_100, GL_EXT_vertex_array, GL_EXT_shader_framebuffer_fetch, GL_EXT_framebuffer_multisample_blit_scaled, GL_ARB_texture_float, GL_EXT_rescale_normal, GL_ARB_texture_swizzle, GL_EXT_packed_depth_stencil, GL_ARB_half_float_pixel, GL_EXT_draw_instanced, GL_EXT_texture_compression_s3tc, GL_AMD_draw_buffers_blend, GL_ARB_occlusion_query2, GL_ARB_texture_rgb10_a2ui, GL_KHR_no_error, GL_SGIS_texture_lod, GL_ARB_derivative_control, GL_ARB_framebuffer_object, GL_ARB_ES3_1_compatibility, GL_AMD_conservative_depth, GL_NV_conditional_render, GL_ARB_texture_rg, GL_EXT_stencil_two_side, GL_ARB_color_buffer_float, GL_EXT_blend_color, GL_EXT_texture_rectangle, GL_NV_packed_depth_stencil, GL_ARB_vertex_array_bgra, GL_NV_texture_rectangle, GL_ARB_texture_filter_anisotropic, GL_ANGLE_texture_compression_dxt3, GL_EXT_texture_integer, GL_EXT_texture_array, GL_ANGLE_texture_compression_dxt5, GL_ARB_fragment_layer_viewport, GL_ARB_shading_language_packing, GL_ARB_fragment_program_shadow, GL_ARB_map_buffer_range, GL_ARB_copy_buffer, GL_ARB_fragment_program, GL_EXT_texture, GL_S3_s3tc, GL_NV_depth_clamp, GL_EXT_draw_buffers2, GL_EXT_texture_lod_bias, GL_EXT_texture_filter_anisotropic, GL_ARB_pipeline_statistics_query, GL_ARB_transform_feedback2, GL_EXT_secondary_color, GL_KHR_texture_compression_astc_ldr, GL_ARB_ES3_compatibility, GL_ARB_transform_feedback3, GL_EXT_framebuffer_multisample, GL_ARB_window_pos, GL_EXT_texture_env_combine, GL_IBM_rasterpos_clip, GL_ARB_texture_compression_bptc, GL_ARB_vertex_shader, GL_SGIS_generate_mipmap, GL_ARB_explicit_attrib_location, GL_EXT_packed_float, GL_ARB_texture_border_clamp, GL_ARB_internalformat_query, GL_NV_blend_square, GL_ARB_arrays_of_arrays, GL_EXT_texture3D, GL_ARB_robust_buffer_access_behavior, GL_ARB_ES2_compatibility, GL_ARB_texture_query_lod, GL_ARB_invalidate_subdata, GL_EXT_texture_sRGB_decode, GL_ARB_texture_compression, GL_ARB_texture_env_add, GL_ARB_framebuffer_no_attachments, GL_ARB_provoking_vertex, GL_ARB_texture_rectangle, GL_EXT_texture_edge_clamp, GL_ARB_multi_draw_indirect, GL_MESA_texture_signed_rgba, GL_ARB_draw_elements_base_vertex, GL_ARB_fragment_coord_conventions, GL_ARB_shader_stencil_export, GL_EXT_shader_framebuffer_fetch_non_coherent, GL_ARB_separate_shader_objects, GL_ARB_texture_cube_map, GL_IBM_multimode_draw_arrays, GL_ARB_vertex_attrib_binding, GL_ARB_clear_buffer_object, GL_EXT_framebuffer_sRGB, GL_ARB_query_buffer_object, GL_KHR_robustness, GL_ARB_vertex_type_10f_11f_11f_rev, GL_ARB_robustness, GL_ARB_polygon_offset_clamp, GL_ARB_point_sprite, GL_INTEL_performance_query, GL_ARB_texture_gather, GL_ARB_internalformat_query2, GL_ARB_shader_texture_image_samples, GL_SGIS_texture_border_clamp, GL_ARB_depth_texture, GL_EXT_texture_object, GL_ARB_instanced_arrays, GL_NV_fog_distance, GL_EXT_blend_minmax, GL_ARB_compute_shader, GL_ATI_draw_buffers, GL_ARB_conditional_render_inverted, GL_ARB_multi_bind, GL_OES_EGL_image, GL_KHR_blend_equation_advanced_coherent, GL_ARB_framebuffer_sRGB, GL_EXT_shader_integer_mix, GL_EXT_blend_subtract, GL_EXT_packed_pixels, GL_IBM_texture_mirrored_repeat, GL_NV_fragment_shader_interlock, GL_ARB_shader_clock, GL_ARB_post_depth_coverage, GL_ARB_texture_mirror_clamp_to_edge, GL_ARB_texture_cube_map_array, GL_EXT_draw_range_elements, GL_ARB_sampler_objects, GL_ARB_half_float_vertex, GL_ARB_shader_precision, GL_ARB_depth_clamp, GL_ARB_texture_storage_multisample, GL_ARB_transpose_matrix, GL_ARB_texture_query_levels, GL_ARB_vertex_buffer_object, GL_ARB_texture_barrier, GL_AMD_multi_draw_indirect, GL_ARB_draw_indirect, GL_EXT_pixel_buffer_object, GL_ARB_transform_feedback_instanced, GL_ARB_texture_view, GL_ATI_texture_env_combine3, GL_EXT_polygon_offset_clamp, GL_ARB_transform_feedback_overflow_query, GL_ARB_shader_group_vote, GL_ARB_texture_env_combine, GL_ARB_indirect_parameters, GL_KHR_blend_equation_advanced, GL_ARB_shader_bit_encoding, GL_ARB_shader_texture_lod, GL_EXT_timer_query, GL_EXT_gpu_program_parameters, GL_ARB_program_interface_query, GL_ARB_uniform_buffer_object, GL_ARB_multisample, GL_AMD_query_buffer_object, GL_EXT_texture_env_dot3, GL_ARB_stencil_texturing, GL_EXT_shadow_funcs, GL_ARB_depth_buffer_float, GL_ARB_map_buffer_alignment, GL_KHR_robust_buffer_access_behavior, GL_EXT_copy_texture, GL_EXT_stencil_wrap, GL_EXT_shader_samples_identical, GL_EXT_point_parameters, GL_ATI_separate_stencil, GL_EXT_subtexture, GL_NV_texture_barrier, GL_MESA_window_pos
20:22:06.618 [rendering.opengl.shader.support]: Shaders are supported.
20:22:06.618 [dataCache.notFound]: No data cache found, starting from scratch.
20:22:06.619 [searchPaths.dumpAll]: Resource paths:
~/GNUstep/Applications/Oolite/oolite.app/Resources
AddOns

*

...Data cache... :?:

user2357
Average
Average
Posts: 14
Joined: Tue Jan 21, 2020 3:37 pm

Re: Help Install on MX Linux, please

Post by user2357 »

I have now also followed the instructions at https://mxlinux.org/wiki/system/installing-software/, under 'Other formats' at the bottom of the page, as applicable to .run packages, with the same effects as described before, except that no Latest.log is generated at all. :o

Commander_X
---- E L I T E ----
---- E L I T E ----
Posts: 325
Joined: Sat Aug 09, 2014 4:16 pm

Re: Help Install on MX Linux, please

Post by Commander_X »

To be honest, I didn't install from the package in a long time, and I don't really know the layout of the installed application very well (I'm mostly running self compiled trunk).

Did you run the installation as root, but are trying to run it as a different user, by any chance? Because it seems you installed the game in your $HOME folder, but if you did is as root, that could explain the behavior you're facing.

Commander_X
---- E L I T E ----
---- E L I T E ----
Posts: 325
Joined: Sat Aug 09, 2014 4:16 pm

Re: Help Install on MX Linux, please

Post by Commander_X »

user2357 wrote:
Tue Jan 21, 2020 5:29 pm
[... ]
I don't know if it might be part of the problem, or useful at all, but Nvidia drivers don't work for me on Linux. I have an ASUS i7 ROG laptop with an Nvidia GTX 1050 (4GB GDDR5), but using the onboard Intel Graphics 630.
[...]
Whew, this looks like an "Optimus" dual graphics hardware setup.
I recall another_commander did some "coding facilities" to take advantage of the better card sometimes back, but not sure if it's part of 1.88 or not. It might help you to do your best to fix your graphics setup (my main suggestion would be to try to use the "bumblebee" package -- or something like that, sorry, it's the only hint I can give you from memory, I only got through this type of setup once, did it and forgot about it).

another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5465
Joined: Wed Feb 28, 2007 7:54 am

Re: Help Install on MX Linux, please

Post by another_commander »

Commander_X wrote:
Thu Jan 23, 2020 8:26 pm
Whew, this looks like an "Optimus" dual graphics hardware setup.
I recall another_commander did some "coding facilities" to take advantage of the better card sometimes back, but not sure if it's part of 1.88 or not.
Taking advantage of the better card is indeed part of 1.88 but it is Windows-only, so I don't think it will be of help to user2357.

user2357
Average
Average
Posts: 14
Joined: Tue Jan 21, 2020 3:37 pm

Re: Help Install on MX Linux, please

Post by user2357 »

Thank you, commanders. <o

I appreciate every little bit of input and feedback I can get. I've run out of options, as far as I can think, at this stage.

I am contemplating an experiment with Manjaro Linux (#2 after MX Linux on the popularity polls at distrowatch.com, at the moment). If that doesn't work, I might go back to a newer version of Mint. I do have a dual boot with Win10Pro, but I do most of my work in Linux, because I hate L0$e-doze, and rebooting back and forth is just not going to cut it for me.

Thanks again for your kind consideration and support in my hour of desperation. :wink:

Commander_X
---- E L I T E ----
---- E L I T E ----
Posts: 325
Joined: Sat Aug 09, 2014 4:16 pm

Re: Help Install on MX Linux, please

Post by Commander_X »

user2357 wrote:
Fri Jan 24, 2020 6:42 am
[...] I've run out of options, as far as I can think, at this stage.
[...] but I do most of my work in Linux, because I hate L0$e-doze, and rebooting back and forth is just not going to cut it for me. [...]
Being myself a "Windows cutter" lately, I can hear you about desperation (although most of the D3D/OpenGL Windows games I like(d) run under the recent versions of Wine -- with quirks and tweaks).
I can help with couple more options you can try. First would be to check my assumption with permissions. The easiest I can think of would be to run the following in a console/terminal logged in as the user that tried to run Oolite:

Code: Select all

cd
find . -type d | xargs ls -ld 2>>/dev/null | grep -v <your_username>
You'll need to replace the <your_username> placeholder above with your username used when logging in (or, e.g., as returned by the linux command whoami).
If there are no entries returned by this sequence of commands you should be in a good shape, and the next step would be to check how/what is Oolite trying to use for its dynamic libraries.

user2357
Average
Average
Posts: 14
Joined: Tue Jan 21, 2020 3:37 pm

Re: Help Install on MX Linux, please

Post by user2357 »

Thanks, Commander_X.

The suggested "change directory" command without any further arguments didn't give any output itself, nor did the "find" command from the default /home/user0 directory. So, I cd'ed all the way back to /, and then did the "find" thing again. I hope that is what I was supposed to have done. Here below follows the output. I'd appreciate if you could translate any useful bits into human-speak for me, because I don't really know what I'm staring at. :oops:

Thanks, commander. Standing by. <o

EDIT: P.S. - I've uninstalled Oolite again, in the meanwhile. Should I perhaps re-install, and then do "find" again (so that you might be able to see the associated permissions for that as well)?...

EDIT2: (just cleaned up my mess here below, removed the "pollution" of the unnecessary / "find" output from the boards.)
Last edited by user2357 on Sun Jan 26, 2020 5:42 am, edited 1 time in total.

Commander_X
---- E L I T E ----
---- E L I T E ----
Posts: 325
Joined: Sat Aug 09, 2014 4:16 pm

Re: Help Install on MX Linux, please

Post by Commander_X »

user2357 wrote:
Sat Jan 25, 2020 6:28 pm
[...] So, I cd'ed all the way back to /, and then did the "find" thing again. [...]
Whew that might had taken a while :) No, I didn't want to peek over your filesystem(s), I just wanted to know if in your home folder there was any file not own by the user that's supposed to play Oolite. No output is good, as it means everything had the right ownership.
BTW, you said you uninstalled Oolite, was it installed when you ran the command in your home directory?
You should re-install Oolite, not as a root user, but as your regular (player) user, and (of course) install it in your home directory.
Once you have that done, 1. you should confirm you're still having the same issue, and 2. you might want to:

Code: Select all

cd
cd GNUstep/Applications/Oolite
find . > ~/oolite_layout.txt
This should help me set you on the next attempt to check what's/if anything's missing for your installation.
Maybe it would be worthwhile to PM me the listing (i.e. the file oolite_layout.txt in your $HOME folder), in order to reduce the "pollution" on the board :-D

user2357
Average
Average
Posts: 14
Joined: Tue Jan 21, 2020 3:37 pm

Re: Help Install on MX Linux, please

Post by user2357 »

Thanks again, Commander_X.

Oolite was not installed when I ran the "find" command last night, and posted the results here above. This morning, however, I realised that I should perhaps rather actually re-install Oolite as user0 in $HOME, and "find" again... right? :wink: ...But ... No output, and still the same issue.

I'll PM you the contents of oolite_layout.txt.

Commander_X
---- E L I T E ----
---- E L I T E ----
Posts: 325
Joined: Sat Aug 09, 2014 4:16 pm

Re: Help Install on MX Linux, please

Post by Commander_X »

user2357 wrote:
Sun Jan 26, 2020 5:31 am
[...] Oolite was not installed when I ran the "find" command last night, and posted the results here above.[...]
Oh, at least you ran it (unnecessarily ;) ) after you installed it as the player user into your home folder. Again, no-output is good.
Next thing is to check how are the libraries lining up for your runtime:

Code: Select all

cd
cd GNUstep/Applications/Oolite
echo $LD_LIBRARY_PATH >~/oolite_ldd.txt
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:./oolite-deps/lib ldd oolite.app/oolite >>~/oolite_ldd.txt
The oolite_ldd.txt file in your $HOME folder would bring some light on what libraries is the application seeing/trying to use.

Post Reply