[Solved] Debian testing repos install problem

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Post Reply
imoldovan
Mostly Harmless
Mostly Harmless
Posts: 2
Joined: Tue Aug 31, 2010 2:04 am

[Solved] Debian testing repos install problem

Post by imoldovan » Tue Aug 31, 2010 2:19 am

I am running Lenny testing. I added the debs to my sources file.
When trying to install I get the following

root@acerdeb:/home/ionut# aptitude install oolite
The following NEW packages will be installed:
oolite{b} oolite-data{a}
0 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,655kB/20.9MB of archives. After unpacking 26.7MB will be used.
The following packages have unmet dependencies:
oolite: Depends: libgnustep-base1.16 (>= 1.16.1) which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) oolite [Not Installed]

Leave the following dependencies unresolved:
2) oolite-data recommends oolite (>= 1.74.1.3629-0lenny~test1)


Accept this solution? [Y/n/q/?]

I have tried a few things but no cigar... It this a bug??
I tried to download the packages separately but the link is broken.

imoldovan
Mostly Harmless
Mostly Harmless
Posts: 2
Joined: Tue Aug 31, 2010 2:04 am

Post by imoldovan » Tue Aug 31, 2010 2:44 am

I was able to download and install libgnustep-base1.16 and the oolite installed with no problem.

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Post by Getafix » Tue Aug 31, 2010 9:28 am

Hi imoldovan, and welcome to the friendliest board this side of Riedquat.

I would suggest you use libgnustep-base1.18.
It resolves a vsync issue with some gfx cards, resulting in
smooth animation without any screen tearing.

Of course, if you don't have any such issues, leave your setup as it is. :)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

User avatar
Micha
Commodore
Commodore
Posts: 815
Joined: Tue Sep 02, 2008 2:01 pm
Location: London, UK
Contact:

Post by Micha » Tue Oct 19, 2010 4:12 pm

Rather late reply but better than never.

Debian lenny only ships with libgnustep-base1.16. Hence packages built specifically for lenny will have to link against that version of libgnustep-base. And that is mostly the point of the Oolite .deb repository - to provide distro-specific builds which integrate nicely (*).

Debian stable is notorious for being quite out-of-date with its packages. This is generally seen as a bad thing for desktops where the latest & greatest versions are desired, but a good thing for servers where long-term stability is required.

To use a newer version of libgnustep-base with Oolite on Debian lenny, you will either need to compile it all yourself (quite a bit of work), or use the autopackage version of Oolite which includes its version 1.18 of libgnustep-base.


(*) This is unfortunately not the case for Ubuntu Lucid and Ubuntu Maverick, since both of these distros ship with a known broken version of libgnustep-base.
The glass is twice as big as it needs to be.

Post Reply