[Solved] Not able to launch Oolite from the Oolite Icon

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Solar Patriot
Average
Average
Posts: 14
Joined: Thu Feb 24, 2011 5:57 pm
Location: USA
Contact:

Re: Not able to launch Oolite from the Oolite Icon

Post by Solar Patriot » Sat Apr 09, 2011 10:58 pm

Hi Getafix.

Here's the output that you requested.
You should know that I am experiencing another problem that is unrelated to Oolite.
A few days ago I swapped out my Radeon X300 video card for a PNY GeForce4 MX440se 64MB SDR PCI with TV-Out & RCA Video Card. When I switched back to the Radeon card I lost the last 3" of the desktop/display. I also lost all of my "Screenlets". I have a post with the Linux Mint Forum but so far the problem has not been resolved.
The actions taken to fix this problem thus far--found and removed any xorg.conf files that contained the name, Nvidia.
I hope that this new problem doesn't complicate the issue that we are trying to resolve here. :cry:


joseph@joseph-desktop / $ cd /
joseph@joseph-desktop / $ for i in `sudo find . -name oolite*desktop -print 2> /dev/null`
> do
> echo $i
> cat $i
> done

./home/joseph/.local/share/applications/oolite.desktop
#!/usr/bin/env xdg-open

[Desktop Entry]
Actions=Apkg-Verify;Apkg-Remove;
Categories=Game;Simulation;X-Red-Hat-Base;
Comment=An OpenGL Elite-like space game
Exec=/usr/bin/oolite
Icon=oolite-icon
Name=Oolite
Terminal=false
Type=Application
X-Autopackage=@oolite-linux.berlios.de/oolite:1.75-test

[Desktop Action Apkg-Verify]
Exec=package verify oolite
Icon=package
Name=Verify Package
Name[de]=Validieren Paket
Name[en]=Verify Package
Name[es]=Verifique El Paquete
Name[fr]=Vérifier l'emballage
Name[it]=Verifichi Il Pacchetto
Name[nl]=Pakket Controleren

[Desktop Action Apkg-Remove]
Exec=/usr/libexec/autopackage/autosu-gtk --root-only package remove oolite
Icon=package
Name=Remove Package
Name[de]=Entfernen Paket
Name[en]=Remove Package
Name[es]=Quite El Paquete
Name[fr]=Enlevez Le Paquet
Name[it]=Rimuova Il Pacchetto
Name[nl]=Pakket Verwijderen

./usr/share/applications/oolite.desktop
[Desktop Entry]
Actions=Apkg-Verify;Apkg-Remove;
Categories=Game;Simulation;X-Red-Hat-Base;
Comment=An OpenGL Elite-like space game
Exec=/usr/bin/oolite
Icon=oolite-icon
Name=Oolite
Terminal=false
Type=Application
X-Autopackage=@oolite-linux.berlios.de/oolite:1.75-test

[Desktop Action Apkg-Verify]
Exec=package verify oolite
Icon=package
Name=Verify Package
Name[de]=Validieren Paket
Name[en]=Verify Package
Name[es]=Verifique El Paquete
Name[fr]=Vérifier l'emballage
Name[it]=Verifichi Il Pacchetto
Name[nl]=Pakket Controleren

[Desktop Action Apkg-Remove]
Exec=/usr/libexec/autopackage/autosu-gtk --root-only package remove oolite
Icon=package
Name=Remove Package
Name[de]=Entfernen Paket
Name[en]=Remove Package
Name[es]=Quite El Paquete
Name[fr]=Enlevez Le Paquet
Name[it]=Rimuova Il Pacchetto
Name[nl]=Pakket Verwijderen

joseph@joseph-desktop / $

Again Getafix, thank you for your assistance.

Regards,
Joe
Last edited by Solar Patriot on Mon Apr 11, 2011 8:43 pm, edited 1 time in total.
Solar Patriot
Fear is a powerful advocate of action, however, there is one even greater -- Hope.

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: Not able to launch Oolite from the Oolite Icon

Post by Getafix » Sun Apr 10, 2011 6:12 am

Hi Solar Patriot. Considering that you can start Oolite by executing "oolite -nosplash",
we will instruct your Oolite menu entry to execute oolite using the -nosplash option too.
In a terminal execute:

Code: Select all

$ cd ~
$ awk -v var="Exec=/usr/bin/oolite -nosplash" '{ gsub(/Exec=\/usr\/bin\/oolite/,var,$0); print }' /home/joseph/.local/share/applications/oolite.desktop > oolite.desktop.tmp 
$ mv oolite.desktop.tmp /home/joseph/.local/share/applications/oolite.desktop
$ sudo awk -v var="Exec=/usr/bin/oolite -nosplash" '{ gsub(/Exec=\/usr\/bin\/oolite/,var,$0); print }' /usr/share/applications/oolite.desktop > oolite.desktop.tmp 
$ sudo mv oolite.desktop.tmp /usr/share/applications/oolite.desktop
Does this do the trick?


For my information (and irrelevant to the first paragraph),
please, post the result of:

Code: Select all

$ cd /
$ sudo find . -name Oolite* -print 2> /dev/null
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

Solar Patriot
Average
Average
Posts: 14
Joined: Thu Feb 24, 2011 5:57 pm
Location: USA
Contact:

Re: Not able to launch Oolite from the Oolite Icon

Post by Solar Patriot » Mon Apr 11, 2011 3:44 am

@Getafix
I really appreciate your help in this matter.

FYI, I followed your earlier instructions.....

Code: Select all

$ cd /
$ for i in `sudo find . -name oolite*desktop -print 2> /dev/null`   # Press <Enter>
> do   # Press <Enter>
> echo $i   # Press <Enter>
> cat $i   # Press <Enter>
> done   # Press <Enter>
[sudo] password for <user>:   # Type your password and press <Enter>
Immediately following this procedure, I opened a Terminal and entered oolite --nosplash as usual to launch the game, but instead of the game launching, it returned the following error:

joseph@joseph-desktop ~ $ oolite --nosplash

It seems that your operating system does not have a valid timezone name
configured and is using an abbreviation instead. By comparing timezone
file data it is has been possible to find the actual timezone used, but
doing that is a slow process.

You can avoid slowness of this time zone detecting approach
by setting the environment variable TZ='America/Chicago'
Or You can override the timezone name by setting the 'Local Time Zone'
NSUserDefault via the 'defaults' command line utility, a Preferences
application, or some other utility.
eg "defaults write NSGlobalDomain 'Local Time Zone' 'America/Chicago'"

Segmentation fault

Erk. It looks like Oolite died with an error. When making an error
report, please copy + paste the log above into the report.

As you have already stated, most of this is nothing to be concerned about. However, the Segmentation fault error has me a little concerned.
I tried to launch the game from the Oolite Menu Icon but, still no joy. Sorry mate! :?

Anyhow, here's the result of

Code: Select all

$ cd /
$ sudo find . -name Oolite* -print 2> /dev/null
./home/joseph/GNUstep/Library/Caches/Oolite-cache.plist
./home/joseph/.Oolite/AddOns/OoliteTheme.ogg.svn-work
./home/joseph/.Oolite/AddOns/OoliteTheme.ogg
./home/joseph/Documents/Oolite Install Notes.odt
./home/joseph/Documents/Oolite Install Notes.rtf
./var/packages/@oolite-linux.berlios.de/oolite:1.75-test/backup/usr/lib/Oolite
./usr/lib/Oolite
./usr/lib/Oolite/oolite.app/Resources/Music/OoliteTheme.ogg
./usr/lib/Oolite/doc/OoliteRS.pdf
./usr/lib/Oolite/doc/OoliteReadMe.pdf

I am waiting for your input before I attempt anything else. Including trying to start the game again.
As always, thank you for all your help.
Solar Patriot
Fear is a powerful advocate of action, however, there is one even greater -- Hope.

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: Not able to launch Oolite from the Oolite Icon

Post by Getafix » Mon Apr 11, 2011 5:27 am

Well, I'm a bit confused.
From your first and seventh post, I thought that you were able to run oolite from a terminal, executing "oolite -nosplash".
Can you run oolite at all? :? If the answer is "no", then my last two posts have nothing to do with it.
The first just lists the .desktop files and the second just alters the command to execute when you click on the Oolite icon.
Going back and forth with the video cards seem to have broken something. :(

You could try hiding the GNUstep Defaults file

Code: Select all

$ mv ~/GNUstep/Defaults/.GNUstepDefaults ~/GNUstep/Defaults/.GNUstepDefaults.original
and then try executing (note: don't skip this step)

Code: Select all

$ oolite
and if that doesn't work, then try

Code: Select all

$ oolite -nosplash
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

Solar Patriot
Average
Average
Posts: 14
Joined: Thu Feb 24, 2011 5:57 pm
Location: USA
Contact:

Re: Not able to launch Oolite from the Oolite Icon

Post by Solar Patriot » Mon Apr 11, 2011 10:01 pm

Getafix,
My friend, please don't think that I am accusing or blaming you for anything. :cry: You have been a tremendous help here and I applaud your efforts regarding this issue.
I agree with you, that when I swapped the Radeon card for the PNY Nvidia card, it broke something.

At least before the swap I was able to play the game.
Now I can't even do that.
If I had any idea that simply changing video cards would have caused this much trouble I wouldn't even have considered it. I have done the same thing under Windows and never had a problem! I guess I thought maybe Linux was the same in that regard. (Now that I think about it though, Linux is so much smarter and secure than Windows it was foolish to think that way).

Anyhow, here are the results of the latest instructions:

Code: Select all

$ mv ~/GNUstep/Defaults/.GNUstepDefaults ~/GNUstep/Defaults/.GNUstepDefaults.original
joseph@joseph-desktop ~ $ mv ~/GNUstep/Defaults/.GNUstepDefaults ~/GNUstep/Defaults/.GNUstepDefaults.original

Code: Select all

$ oolite
joseph@joseph-desktop ~ $ oolite
oolite: src/SDL/MyOpenGLView.m:220: -[MyOpenGLView init]: Assertion `surface != ((void *)0)' failed.
Aborted

Erk. It looks like Oolite died with an error. When making an error
report, please copy + paste the log above into the report.

(Press Ctrl-C to continue)

Code: Select all

$ oolite -nosplash
joseph@joseph-desktop ~ $ oolite -nosplash


Segmentation fault

Erk. It looks like Oolite died with an error. When making an error
report, please copy + paste the log above into the report.

(Press Ctrl-C to continue)
^C
joseph@joseph-desktop ~ $

In order to keep this post a little less cluttered,
I have removed the all of the benign Time Zone Error stuff that appears when I
run the "oolite -nosplash" command form the Terminal.

As always Getafix, thank you for your help.
Solar Patriot
Fear is a powerful advocate of action, however, there is one even greater -- Hope.

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: Not able to launch Oolite from the Oolite Icon

Post by Getafix » Tue Apr 12, 2011 5:47 am

OK. Now it's my turn to apologize for the misunderstanding.
When I wrote that my last two posts had nothing to do with the new issue you are facing,
I didn't mean that you were thinking that this had broken your Oolite. Sorry, man. :oops:
Thank you also for all the appreciation you are showing. 8)
However, I've been only scratching the surface so far.

Returning back to our case, it seems the gfx/video setup is now broken.
You should either reinstall the Linux Mint drivers (jockey could help a bit) or install the
ATI proprietary driver from here. If you do the second you should follow
the "Installer Instructions" carefully. For example one of the things to verify,
before the installation of the proprietary driver, is that the POSIX Shared Memory support
is enabled, as this is required for 3D apps. Here you can find a simple way to do that.

Cheers, mate! :)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

Solar Patriot
Average
Average
Posts: 14
Joined: Thu Feb 24, 2011 5:57 pm
Location: USA
Contact:

Re: Not able to launch Oolite from the Oolite Icon

Post by Solar Patriot » Tue Apr 12, 2011 7:46 pm

Thank you Getafix,
You have nothing to apologise for friend. :)

I have been looking (on the Linux Forums) for someone that could lead me to the information to re-install the proprietary ATI drivers. Because I am convinced that this is the problem. At least with the display problems.

I will follow your suggestions and post the results.

Thanks, mate.
Solar Patriot
Fear is a powerful advocate of action, however, there is one even greater -- Hope.

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: Not able to launch Oolite from the Oolite Icon

Post by Getafix » Sat Apr 16, 2011 7:46 pm

OK, Solar Patriot. When you are done with the display driver,
raise a flag here to help you rollback the Oolite installation changes you applied
following my post.

By the way, after driver installation, first try running oolite without the -nosplash option.

Cheers.
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: Not able to launch Oolite from the Oolite Icon

Post by Getafix » Tue May 17, 2011 10:48 am

This is just to summarize a bit the case.
There are two issues:
a. Cannot launch Oolite from icon
b. Oolite crashes at full screen mode 1366x768 with ATI video card.

The issue, not being able to launch Oolite from icon seems to be related to the fact that
even from a terminal, executing "oolite" crashes. However, "oolite -nosplash" gives a successful launch.
This leads to the assumption of a driver glitch, which I consider minor since a launch is feasible using
the "-nosplash" option. I have instructed Solar Patriot to replace the command executed by the
icon (i.e. system-wide installation, therefore, "/usr/local/bin/oolite") with "/usr/local/bin/oolite -nosplash".
Solar Patriot will come back with some feedback on this.

Solar Patriot informed me that the issue with the full-screen crash still persists even after a fresh Linux Mint installation with the latest ATI proprietary drivers.
I haven't been able to replicate this through a VBox Linux Mint installation. Full-screen mode was functional even in weird resolutions,
such as 309x613! Micha has also reported here that 1366x768 resolution works fine in full-screen mode in Ubuntu.
Therefore, I conclude that again the issue is raised by the integration of ATI drivers in Linux Mint.

@Solar Patriot
I think I can give you a solution to run Oolite in full-screnn mode in a smaller resolution than 1366x768. If you are interested let me know.
If you can't live without 1366x768 full-screen in Oolite and you don't care trying another distro (since you have just installed Mint)
you could go for Ubuntu (I suggest 10.04) or Fedora that are still very user friendly.

Cheers!
Last edited by Getafix on Wed May 18, 2011 5:04 am, edited 1 time in total.
Reason: Fixed some typos
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

User avatar
JensAyton
Grand Admiral Emeritus
Grand Admiral Emeritus
Posts: 6657
Joined: Sat Apr 02, 2005 2:43 pm
Location: Sweden
Contact:

Re: Not able to launch Oolite from the Oolite Icon

Post by JensAyton » Tue May 17, 2011 7:27 pm

For the display issue, try disabling shaders. If you can’t do it through the UI, install this OXP.

If this works, please post the top of Latest.log, up to and including the bit that says “GL” a lot.

Patriot
Harmless
Harmless
Posts: 1
Joined: Tue Dec 14, 2010 6:15 am

Re: Not able to launch Oolite from the Oolite Icon

Post by Patriot » Thu May 19, 2011 11:24 pm

First I want to thank everyone that replied to this post with help.
I have removed my install of Linux Mint 10 code named Julia and replaced it with Mint 11 64bit "Katya". This is a fresh install, not an upgrade.
I believe that I was forced into a corner with no other options because of my limited knowledge of Linux at this time. I posted the issue with all of the mainstream Linux Forums and received a number of things to try but none of them worked. I could not resolve the issue with the last 3" of the display missing so I backed up my home folder and deleted the partition where Mint 10 32bit.(Julia) lived and repartitioned it and installed Mint 11 64bit. (Katya).
I have reinstalled Oolite 1.75.2 beta using the instructions that Getafix supplied i.e., http://www.aegidian.org/bb/viewtopic.php?f=9&t=9570 and now I am able to launch the game from the Game Menu Icon. In addition, I am able to switch between Windowed mode and Full screen without crashing the game. :D
Everything is working great now.

So, once again, to all that assisted me with this issue - thank you.
And a special thank you to Getafix for keeping in touch and continuing to investigate these issues. :)

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: Not able to launch Oolite from the Oolite Icon

Post by Getafix » Thu May 19, 2011 11:55 pm

Hi, Patriot. It's our pleasure that you are back in the game with your issues solved. 8)

Happy Ooliting!
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: Not able to launch Oolite from the Oolite Icon

Post by Getafix » Fri May 20, 2011 1:38 pm

Just to close this properly for people visiting this topic with the same issues.

1. Can't open Oolite from icon
If you can open oolite from a terminal by executing "oolite -nosplash" then
edit the "Oolite (oolite.org)" menu entry to execute oolite using the "-nosplash" option.
If you don't know how to do this feel free to ask here or to a forum related to your linux distro.
The process of menu editing is not the same for all the distros.

2. Fullscreen mode crashes
So far we have concluded that this is related to the Linux-distro <--> Video driver integration.
If you have the latest drivers and you still have crashes with fullscreen mode, then you could try forcing
Oolite to start in fullscreen but in some other resolution than the default one.

On that purpose you should edit your ~/GNUstep/.GNUstepDefaults file.
Locate the following chunk of code (figures may vary)

Code: Select all

    <key>window_height</key>
    <integer>288</integer>
    <key>window_width</key>
    <integer>512</integer>
and update as shown here

Code: Select all

    <key>display_height</key>
    <integer>480</integer>
    <key>display_refresh</key>
    <integer>0</integer>
    <key>display_width</key>
    <integer>640</integer>
    <key>fullscreen</key>
    <string>YES</string>
    <key>window_height</key>
    <integer>288</integer>
    <key>window_width</key>
    <integer>512</integer>
Here we have added display_height, display_refresh and display_width.
After that when you startup Oolite, it should start in fullscreen mode in a very very very low resolution (i.e. 640x480).
From within the Oolite game go to "Game Options..." menu, then go to "Full Screen Mode: 640x480" and start changing
resolutions using the right-arrow key. In that way you should find the highest resolution which can be used with no crash.
Suppose that this resolution is 1024x768. Return to your ~/GNUstep/.GNUstepDefaults file and edit it accordingly.
Example for 1024x768 full screen resolution:

Code: Select all

    <key>display_height</key>
    <integer>768</integer>
    <key>display_refresh</key>
    <integer>0</integer>
    <key>display_width</key>
    <integer>1024</integer>
    <key>fullscreen</key>
    <string>YES</string>
    <key>window_height</key>
    <integer>288</integer>
    <key>window_width</key>
    <integer>512</integer>
Not a full screen at your highest resolution, but it's a full screen mode after all! :)
Last edited by Getafix on Fri May 20, 2011 1:42 pm, edited 1 time in total.
Reason: More generic approach for .GNUstepDefaults code chunk
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

Post Reply